Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 11-16-2010, 02:29 PM #1
ItsKingCoopa
 
 
ItsKingCoopa's Avatar
 
Join Date: Nov 2010
Location: Ontario,Canada
Please Help Me and my x7 Tippman

Hey everyone, about a year ago, i purchased a brand new x7 (i live 5 mins away from wasaga paintball, wanted to go more often) the first day i got it, i had my tank filled, and went into the bush to fire off a few rounds. after about ten, i got a break (at the bolt, Not in the hopper), out of about 200 balls, this happened about a dozen more times. When i got home, i called and talked to the tech at the paintball field. he told me that there were only a few impacts that a ball could take, and i probably just needed to reduce the wear an tear that the ball was going through. I read all sorts of tips on the tippman forum and did the following: got soft paddles,Gently sanded (with ultra fine sandpaper) the inside of the hopper til it was smooth as hell, new ratchet system for smoother rotation of the cyclone, lapco big shot 8", Q.E.P.H.,electronic trigger,sanded the edge of the stock bolt (plus bought a new stock bolt that i didnt sand, plus a a delrin bolt)i even put a small amount of silly putty over the screw on top of the paddles, believing that the recesses' in the philips slot would constitute a bur).

i then went to the field, hoping that the problem would be resolved. i tried all the bolts, different barrels, different velocities, but still would have to come off every two or so games, strip down the gun, clean it out (the breaks mostly seem to happen where the ball leaves the cyclone and meets the bolt) and hope for the best the next round out. at first i was diligent about this, however after going three times a week for about four or so months, it seemed like i was spending most of my time off the field with allen keys, cleaning my gun and being frustrated while my other friends played paintball.
I started to lose interest, and with all the money i had put into the gun, i was kind of stuck. First off, i don't really like the look or feel of speed ball guns (all of my friends use them), and second, i had already invested so much money into my x7, that i couldn't afford another gun. eventually, i went less and less, and gave up hope, then i moved an hour away, and stopped going completely.

However, 2 weeks ago i moved back home. and all my buddies wanted me to go to the field, tired of dealing with my gun, i started to look for a new one. None of the guns really looked the way i wanted, then i came across the phenom. the new softer bolt sounded like it might be a fix.... so i started to read reviews and came across one in this forum titled "x7 phenom BIG PROBLEMS". Im not sure if it was real or not, however, a tippman rep, posted on it and said that the company would have the problem fixed. I always heard that tippman had excellent customer service, but had never thought to contact them directly, i just saw local techs (who are all speedball player, and didnt think highly of my big woodsball gun) and they never had a fix for it.

I Know thats pretty long, and im sorry, but those are all the details i could think of, im hoping someone maybe had a similar problem and got a fix, but im mainly hoping a tippmann rep will read and be able to help. I'm not writing this to bash tippmann, there products seem to be very reliable, i just think i got a lemon and cant afford a new gun.... plus i really want to get out on the field.
Please Help me Tippmann
Ryan
ItsKingCoopa is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 11-16-2010, 03:46 PM #2
preacha365
 
 
Join Date: Jun 2010
just simply give tippmann a call,tell them the issues you're having and see if they can walk you through a fix. better yet call them then send it in to tippmann and they will fix it. i just sent my four year old x-7 in two weeks ago. they replaced and or fixxed the parts and shipped it back to me at no charge. the marker works like brand new.
tippmanns customer service is second to none in my openion.
preacha365 is offline   Reply With Quote
Old 11-16-2010, 04:10 PM #3
ItsKingCoopa
 
 
ItsKingCoopa's Avatar
 
Join Date: Nov 2010
Location: Ontario,Canada
thanks man, just got off the phone with them. apparently, the store i bought it from must have had it for a long time as its the oldest model of x7 available. the rep was very helpful and is sending me a new barrel adaptor,new paddles, new ratchet and springs and some other goodies that he believes will fix the problem. Hopefully that will work, ill give an update when theyre installed and ive had a chance to play with it, till then id appreciate any other input that anyone has.....thanks again, this forum Kicks ***

Last edited by Whiteyboy : 11-16-2010 at 05:18 PM. Reason: corrected filter bypass
ItsKingCoopa is offline   Reply With Quote
Old 11-16-2010, 05:28 PM #4
Whiteyboy
 
 
Whiteyboy's Avatar
 
Join Date: Feb 2007
Location: NY "9won4"
Whiteyboy is a Supporting Member
 has been a member for 10 years
Whiteyboy donated to help Peyton Trent
Whiteyboy supports our troops
Quote:
Originally Posted by ItsKingCoopa View Post
so i started to read reviews and came across one in this forum titled "x7 phenom BIG PROBLEMS".
Some of the earlier Phenoms may have had some rough spots/burrs on the front bolt, which was usually fixed with some light sanding. The newer one shouldn't really have this issue.

Quote:
Originally Posted by preacha365 View Post
just simply give tippmann a call,tell them the issues you're having and see if they can walk you through a fix. better yet call them then send it in to tippmann and they will fix it. i just sent my four year old x-7 in two weeks ago. they replaced and or fixxed the parts and shipped it back to me at no charge. the marker works like brand new.
tippmanns customer service is second to none in my openion.


As always, Tippmann has some of the best customer service I have ever dealt with in any industry.

Quote:
Originally Posted by ItsKingCoopa View Post
thanks man, just got off the phone with them. apparently, the store i bought it from must have had it for a long time as its the oldest model of x7 available. the rep was very helpful and is sending me a new barrel adaptor,new paddles, new ratchet and springs and some other goodies that he believes will fix the problem. Hopefully that will work, ill give an update when theyre installed and ive had a chance to play with it, till then id appreciate any other input that anyone has.....thanks again, this forum Kicks <del>***</del>
Keep us updated.

Hopefully the replacement parts will fix the issue you've been having.

Were you playing in cold weather?

How is the quality of paint your field uses?
__________________
Whiteyboy is offline   Reply With Quote
Old 11-17-2010, 05:27 PM #5
ItsKingCoopa
 
 
ItsKingCoopa's Avatar
 
Join Date: Nov 2010
Location: Ontario,Canada
like i said, i haven't been out in almost a year,but, where i was playing, its indoor and outdoor, when it gets cooler later in the season (october through winter) they switch to winter paint and its only indoor, and although the entire x-ball building isn't heated,its not very cold (between 10 and 15 degrees Celsius) and during the summer its nrmally pretty warm. aas for paint i cant recall, i know at one point i was usin v-1's,but ill post again after i talk to the tech tonight and find out.
ItsKingCoopa is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump