Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 04-23-2021, 02:53 PM #1
Kronkron
 
 
Join Date: Apr 2021
Im looking for help on my alien

I have 2009 alien i believe its a inceptor it doesnt leak and the board and grip regulator are fine the solinoid seems to want to shoot but doesnt basically the ram stick it clicks but doesnt shoot any opinions
Kronkron is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 04-28-2021, 12:57 AM #2
Mr. Charlie
 
 
Mr. Charlie's Avatar
 
Join Date: Jun 2018
Location: FL
Mr. Charlie owns a Planet Eclipse - Emek
Mr. Charlie owns a Planet Eclipse - Emek
Reset the board back to stock/the proper settings?
__________________
Dynasty Scales CS1, M3s+, PAL EMEK, and M2 all with Ninja SL2 77/4500 tanks with PowerHouse Haymaker Gen. III tank Regulators!
Mr. Charlie is offline   Reply With Quote
Old 04-29-2021, 11:14 AM #3
Paul77
Can't find my old account
 
Paul77's Avatar
 
Join Date: Sep 2016
Location: Canada
Annual Supporting Member
Paul77 supports DLX Technology
im with charlie

new orings and lube on the ram wouldnt hurt either
__________________


Powered By Powerhouse Regulators, DLX Luxe X, Pro-Shar Paintballs, Prairie Storm Paintball

All my weird random paintball parts for sale on eBay feel free to PM me offers on here.


Paul77 is online now   Reply With Quote
Old 05-02-2021, 12:30 AM #4
rluna
Moderator
 
rluna's Avatar
 
Join Date: Dec 2002
rluna is a Moderator
rluna is a Supporting Member
 has been a member for 10 years
rluna is playing at Living Legends III
I would use a lot of periods when typing. Would make things easier to read....

A drop of oil on the ram. I use kc trouble -free an all my aliens. I think PMI would work well too.

New battery or old? Maybe the hpr is too low (time to take it apart for an inspection / lube perhaps)? Is the HPR turned up enough? Maybe something is obstructing the flow of air where the tank meets the ASA?

When gassed up how much resistance is there on the bolt? Push it forward, does it feel like the lpr pressure is right? No? Turn up the lpr.

With the market degassed, move the bolt back and forth. It does stick a litte bit (mine does), but does it seem like it takes too much force to move it? If yes take the rammer out of the housing and inspect the o-ring.
__________________
Excessive force does indeed answer all questions if there is no one left to ask them....
My Old Feedback

My E-Blazer,
My Markers... The Osirus is... (sold)

Last edited by rluna : 05-02-2021 at 12:32 AM.
rluna is offline   Reply With Quote
Old 05-16-2021, 12:07 PM #5
MstrKey
 
 
Join Date: Aug 2001
Location: SSM, Ontario, Canada
MstrKey is a founding member
 has been a member for 10 years
MstrKey is for the Gunfight
MstrKey supports our troops
When was it used last? I've seen this on guns that have sat around unused for too long. I had an angel that did the same. I took the solenoid off, put a drop of oil down into the spool then worked the spool back and forth with a plastic tooth pic to break it free. Put everything back together and it worked fine after that.
__________________
Cool Ref/player wear if anyone wants any

https://teespring.com/stores/politically-incorrect-36
MstrKey is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump