Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 11-30-2019, 07:36 PM #1
rjervis75
 
 
Join Date: Aug 2019
D3s

So my son bought one of these guns recently. Bought a new tank and had it filled. Connected tank to guns and opened ASA and gun was losing air everywhere. Bought a seal kit and changed the prints. Connected tank again and sounds like it’s losing air in the middle of the gun. Any ideas?
rjervis75 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 12-01-2019, 06:19 AM #2
Mr. Charlie
Dye DSR, M2, M3
 
Mr. Charlie's Avatar
 
Join Date: Jun 2018
Location: FL
Mr. Charlie owns a Planet Eclipse - Emek
Mr. Charlie owns a Planet Eclipse - Emek
What is the tested Tank output pressure?

What is your Velocity?

I’ve read that the D3S’ come set up from factory with the HPR set too high. Try lowering it.
__________________
Gonna scare you up and shoot ya, cause Mr. Charlie told me so.
Mr. Charlie is online now   Reply With Quote
Old 12-01-2019, 05:05 PM #3
toxikimpulse
 
 
Join Date: Dec 2018
Call D3fy. I doubt it was an o-ring from the bolt or regulator, sounds like an internal solenoid o-ring either was blew out of it's place or the o-ring was damaged when the marker was aired up.
toxikimpulse is offline   Reply With Quote
Old 12-01-2019, 06:06 PM #4
romanlynch
 
 
Join Date: Jan 2005
Location: Stuck in Ohio
 has been a member for 10 years
If it's leaking down the barrel it's most likely this

https://www.youtube.com/watch?v=7gr8n4BfmUQ&t=41s

They have some quality control issues but once the silly stuff is straightened out they are actually nice markers. I've used one for a while with absolutely no issues.
romanlynch is offline   Reply With Quote
Old 12-02-2019, 06:43 PM #5
toxikimpulse
 
 
Join Date: Dec 2018
Quote:
Originally Posted by romanlynch;100161351[/url

They have some quality control issues but once the silly stuff is straightened out they are actually nice markers. I've used one for a while with absolutely no issues.
toxikimpulse is offline   Reply With Quote
Old 12-06-2019, 07:54 AM #6
Nyknight01
 
 
Nyknight01's Avatar
 
Join Date: Jul 2016
Nyknight01 owns a Planet Eclipse Geo
Nyknight01 owns a Planet Eclipse Ego
Nyknight01 owns a Planet Eclipse - Emek
this was an old issue...the markers were apparently tested with a low output compressor....so in order to get them to velocity they had to turn up the markers reg.
this would output over 180psi when hooked to a proper hpa tank.
this in turn would blow the noid spool ring.

albeit it was annoying but its not a hard fix.
If you are capable then certainly its something a person with small enough allens can handle...as the 2.5mm screw holding the noid to the body are super small.

once that is set back in place...turn the velocity screw all the way out...ccw ...start to cycle the marker...slow 1/8th turns cw. until u achieve velocity.
never exceed 300 fps...or 180psi and youll be fine.
if u change out different tanks or use a different tank...then id repeat the chronoing process...zero out and slowly open.
if u are local to ny or close and don't wanna deal with it I can certainly help ya out!
Nyknight01 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump