Osiris Regulator question - PbNation
Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

 
Archived Thread - Cannot Edit  
Old 01-18-2005, 03:50 AM #1
Oscarine
 
 
Join Date: Nov 2004
Oscarine is a Supporting Member
 has been a member for 10 years
Osiris Regulator question

Well I guess this is more of a Bob Long Torpedo reg question nonetheless here it goes:

I had a Air America Apocalypse 2k Air system connected to my Osiris, about a week ago something got stuck and my Osiris got hit by about 12-1500 PSI. Since I couldn't get my Apoc fixed in time for my trip to Canada I fished out an on/off ASA and brought along a Crossfire HP tank. Now heres the problem when I connect the Crossfire to the gun the gauge (its a new gauge) is recharging very very slowly between shots like a whole second or so, and also dips down if rapidly shot, also if not fired, the pressure spikes well over what the reg is set at (200ish) past 300. I'd like to play this weekend so what do you think I need.
A. a Low Pressure tank
B. a New Regulator
or C. I broke something else
Oscarine is offline  
Old Sponsored Links Remove Advertisement
Advertisement
Old 01-18-2005, 10:47 AM #2
suprtpr
 
 
suprtpr's Avatar
 
Join Date: Dec 2003
Location: alabama
suprtpr is a Supporting Member
 has been a member for 10 years
It sound like you are having problems with you inline reg. What reg are you using? I was having problems like this on my Osiris. When I first got my Osiris it had an Air America inline reg on it. I was having some shootdown at high rates of fire. The reg would also creep if you let it sit with the air on and didn't shoot it. I replaced the AA reg with a palmer stabalizer and it worked great. I sent the AA reg off to get rebuilt and AA said that the reg seat was bad, and that was causing my problems.
__________________
My Old Feedback
suprtpr is offline  
Old 01-18-2005, 04:00 PM #3
Polish Guy
WarMachine Guru
 
Polish Guy's Avatar
 
Join Date: Oct 2002
Location: Greenville, SC
 has been a member for 10 years
Definitely a reg. prob. It sounds like your reg seat or pressure spring or even both were crushed and there for severely weakened. That'll explain why your pressure creeps.

It's been a while since I've had a BL Torp, but I know you can take them apart. Do that before you go and buy something, check the seat and the spring and see if they are intact. If so, clean and oil (a spike over 1200psi coulda wiped out any lube in the reg) and then give it a shot, but be careful

If that's not it, just get the reg rebuilt - only should cost $30-$40 at most. Or you could send to BL and see what they'll give you.

Overall they're good regs and it's not enitrely worth getting a different one unless you're in the market or whatever.

Hope that helps.
__________________
Dark Carnival

The Original WarMachine Factory Team
SN's a nationality - not a shoe shine...

FeedbacK
Polish Guy is offline  
Old 01-18-2005, 10:48 PM #4
Oscarine
 
 
Join Date: Nov 2004
Oscarine is a Supporting Member
 has been a member for 10 years
Yeah I talked to Leon I guess it was and its the Reg... I'll get it rebuilt, but since I'm away from home now and have a game this weekend just gonna buy a new one for now... thanks
Oscarine is offline  
 




Posting Rules
Forum Jump