Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 06-20-2014, 10:08 PM #1
toastertree
 
 
toastertree's Avatar
 
Join Date: Jan 2014
Location: Ames, Iowa
Etha Issue

Recently I have been having a problem with my Etha where the bolt wont cycle with every trigger pull. Sometimes the bolt will not cycle and a little air will come out of the grip frame. I think it is the noid. A few weeks ago I forgot to reset the regulator after I took it apart. When I gassed up the gun I over pressurized the noid and it started venting.

I have the gun chronoed at ~285. So far I have tried replacing the battery, lubing the bolt and reg, increasing the dwell and I checked the noid for any cracks and made sure it wasn't loosening from the grip frame. Increasing the dwell seemed to help a bit but it is currently at 13 ms and the problem still occasionally happens.

Any suggestions?
toastertree is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 06-21-2014, 12:59 AM #2
Calculon The Great
 
 
Calculon The Great's Avatar
 
Join Date: Mar 2009
Location: Montreal, Canada
Gotta ask, you have the springless poppet installed + brand new battery?
Calculon The Great is offline   Reply With Quote
Old 06-21-2014, 07:14 AM #3
toastertree
 
 
toastertree's Avatar
 
Join Date: Jan 2014
Location: Ames, Iowa
Yes, I probably should have mentioned that in my original post. I have the springless poppet and a new battery installed.
toastertree is offline   Reply With Quote
Old 06-21-2014, 07:47 PM #4
B Web
Black Karma Scenario Team
 
B Web's Avatar
 
Join Date: Dec 2009
Location: Huntsvegas, AL
B Web owns a Planet Eclipse Geo
B Web owns a Planet Eclipse Etha
Bolt guide and bumper clean and dry? Lube on either can cause bolt stick.
__________________
Black Karma Scenario Paintball Team
Black Karma on Facebook

Proudly Sponsored by
Planet Eclipse
B Web is offline   Reply With Quote
Old 06-21-2014, 10:03 PM #5
toastertree
 
 
toastertree's Avatar
 
Join Date: Jan 2014
Location: Ames, Iowa
Yes, I checked the bolt guide and bumper and they were both clear of lube.
toastertree is offline   Reply With Quote
Old 06-25-2014, 09:27 AM #6
CrusaderPB
Field, Pro Shop & Repairs
 
CrusaderPB's Avatar
 
Join Date: Feb 2010
Location: Fairless Hills, PA
Annual Supporting Member
CrusaderPB owns a Planet Eclipse Ego
CrusaderPB supports Bob Gurnsey
CrusaderPB supports our troops
CrusaderPB has perfected Level 1 in PbNation Pursuit
CrusaderPB has achieved Level 3 in PbNation Pursuit
CrusaderPB supports Empire
Try replacing the 010 and 011 on the middle and rear of the poppet
__________________
Crusader Paintball -Serving Philadelphia, Trenton and Princeton
225 Lincoln Highway
Fairless Hills PA 19030 Phone: 215-949-4600
Now a Planet Eclipse Service Center

Like us on Facebook! Follow us on Twitter! Subscribe to our Thread!
CrusaderPB is offline   Reply With Quote
Old 06-25-2014, 09:31 PM #7
toastertree
 
 
toastertree's Avatar
 
Join Date: Jan 2014
Location: Ames, Iowa
Right now I am on vacation but I will try replacing those o rings when I get home.
toastertree is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump