Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 03-25-2014, 06:10 PM #1
JR#21
 
 
JR#21's Avatar
 
Join Date: Nov 2010
Location: Rock Hill
JR#21 owns a Planet Eclipse Lv1
JR#21 plays in the APPA D5 division
JR#21 has achieved Level 2 in PbNation Pursuit
Leak coming from Lv1 solenoid/manifold

Hey guys, been battling with a leak from either the solenoid or the manifold. I've taken the gun apart, made sure the solenoid, gaskets, and manifold are clean and have no visual damage. After I button everything back down and air it up its fine, no leaks, but after a day or two I'll air it up and once again a slight leak will be coming from that area. I've done this multiple times and had the same results every time. Wondering if anyone else has encountered this issue, and what you did to permanently fix the issue?
__________________
Carolina Krush
AHC
JR#21 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 03-27-2014, 04:30 PM #2
USNAPaint
Great White Buffalo
 
USNAPaint's Avatar
 
Join Date: Jul 2011
Location: Annapolis, MD or LA, CA
USNAPaint owns a Planet Eclipse Geo
USNAPaint is an NCPA player
USNAPaint plays in the APPA beginner division
im having a similar problem.
__________________
United States Naval Academy Class of 2016


Vamp'd Planet Eclipse LV1///Virtue Spire///68/45 Ninja Duracoat

Fight until Hell freezes over. Then, Fight on the ice!
USNAPaint is offline   Reply With Quote
Old 03-27-2014, 04:46 PM #3
Magic rat
 
 
Join Date: Dec 2012
Location: WALES UK
Magic rat owns a Planet Eclipse Lv1
Magic rat owns a Planet Eclipse GSL
I had the same problem slight hiss when placed against your ear,sent it back to PE under warranty.
Cracked manifold ,changed no problems since.
Magic rat is online now   Reply With Quote
Old 03-27-2014, 04:53 PM #4
JR#21
 
 
JR#21's Avatar
 
Join Date: Nov 2010
Location: Rock Hill
JR#21 owns a Planet Eclipse Lv1
JR#21 plays in the APPA D5 division
JR#21 has achieved Level 2 in PbNation Pursuit
Quote:
Originally Posted by Magic rat View Post
I had the same problem slight hiss when placed against your ear,sent it back to PE under warranty.
Cracked manifold ,changed no problems since.
How long was the turnaround time from PE?
__________________
Carolina Krush
AHC
JR#21 is offline   Reply With Quote
Old 03-28-2014, 12:56 PM #5
Magic rat
 
 
Join Date: Dec 2012
Location: WALES UK
Magic rat owns a Planet Eclipse Lv1
Magic rat owns a Planet Eclipse GSL
I'm from the UK so back in a couple of days.
Magic rat is online now   Reply With Quote
Old 04-05-2014, 01:45 AM #6
Dwilliams31
 
 
Join Date: Nov 2013
Location: Kentucky
Dwilliams31 owns a Planet Eclipse Lv1
I had the same thing happen with mine. I couldnt figure it out to save my life, I changed o-ring after o-ring and regreased everything. I sent it to a shop and it turned out to be the barb that connects the air line to your manifold. Ive heard its kindof a common issue with egos. Hope this helps!
Dwilliams31 is offline   Reply With Quote
Old 05-04-2014, 07:47 PM #7
LZ Newbee
P Mob / NE Crusade
 
LZ Newbee's Avatar
 
Join Date: Feb 2010
Location: Boston
LZ Newbee owns a Planet Eclipse Ego
LZ Newbee plays in the APPA D4 division
I had the same problem, took the gun apart to change the rubber gaskets on the manifold. I noticed 1 of the 3 screws to the manifold was loose, I changed the gaskets and made sure to tighten the screws, everything is fine now. I saw someone else post that all they did was tighten the manifold screws and it worked.
LZ Newbee is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump