Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 03-24-2014, 11:00 AM #253
WHOWHAT?
Team Who
 
WHOWHAT?'s Avatar
 
Join Date: Sep 2006
Location: SUNNY SW FLA
Annual Supporting Member
WHOWHAT? owns a Planet Eclipse Ego
WHOWHAT? owns a Planet Eclipse Lv1
WHOWHAT? supports Team VICIOUS
WHOWHAT? is attending Decay of Nations VII
I am having trouble with my lv1. My issue started when I noticed my marker did not seem to hit the 12 bps. Sounded slow. Reset everything to stock settings ( I just picked it up) and it would not fire. This was caused because the marker trigger defaulted to opto, for some reason when it is set to opto it will not fire. It has to be set in switch mode. I checked the micro switch activation screw to make sure it was not the issue. Checked all settings to make sure they were set to stock, still no luck. Please help.
__________________
B&D Army/ Navy. Venice Fla
[COLOR="SeaGreen"]2008 D-2 XBALL SERIES CHAMPIONS[/color]
1ST PLACE D-2 XBALL 08 WORLD CUP
1ST PLACE D-3 XBALL 08 WORLD CUP
2ND PLACE CHICAGO OPEN 08 D3 XBALL
2008 SPYDER CUP CHAMPS
WHOWHAT? is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 03-25-2014, 05:34 AM #254
assa
 
 
assa's Avatar
 
Join Date: Feb 2004
Location: Miami, SoFla
 has been a member for 10 years
My SL-94 broke at the barrel threads (barrel got stuck on the grass and I landed on my gun...)
Is there a way to get another sl94 body? Who should I contact? I sent an email to info.usa@planeteclipse.com last week but haven't heard back.

Thanks! I love this gat and would really like to get it back up and running.

__________________
my feedback
assa is offline   Reply With Quote
Old 03-25-2014, 02:31 PM #255
kumite45
Sempai
 
kumite45's Avatar
 
Join Date: Feb 2012
Location: Massachucetts
Hey Bill, I have an LV1 and I get an air purge/excessive air sound on the first shot. No hot or low velocity just the purge sound? It will do it everytime the gun is shut off and turned back on. any thoughts Ive seen other people on you tube posting the exact issue with there LV1's. thanks for any help
kumite45 is offline   Reply With Quote
Old 03-27-2014, 12:41 PM #256
scar80
 
 
Join Date: Dec 2013
My ego 11 board is broken and was wondering what would be better, an OEM board from PE or a virtue board?
scar80 is offline   Reply With Quote
Old 03-29-2014, 11:30 PM #257
INXS17
SEMI-PRO PLAYER
 
INXS17's Avatar
 
Join Date: Apr 2005
Location: Southern California
INXS17 plays in the PSP
INXS17 owns a Planet Eclipse Geo
INXS17 owns a Planet Eclipse Lv1
Im having a solenoid issue on my lv1. Where the air vents out underneath the right sfr there is a constant leak. I changed the manifold gasket and solenoid gasket to no avail. I am leanin towards the solenoid is bad but wanted.to know if i should try something.else. thanks in advance.
__________________
"then I busted to the spike and shot like 8 guys.....did a run through.....wiped five hits.....bonus balled six kids in the dead box.....and punched a fat kid in the face"

LOCKOUT
VALKEN PAINTBALL-CAMP PENDLETON-SHAWN WALKER-P.I.C.PAINTBALL.NET-THE HOOD BAR AND PIZZA
R.I.P. BUSHWACKERS
INXS17 is offline   Reply With Quote
Old 03-31-2014, 02:10 PM #258
aroun7
 
 
aroun7's Avatar
 
Join Date: Oct 2007
Location: College place WA
aroun7 owns a Planet Eclipse Ego
aroun7 plays in the APPA D5 division
aroun7 has achieved Level 2 in PbNation Pursuit
aroun7 supports Empire
Hey I have a ego 8 and I was woundering why when the eyes are on its not shootong at 12.5 but when the eyes are off it does shoot at 12.5 and I cleaned the eyes and everything
aroun7 is offline   Reply With Quote
Old 03-31-2014, 08:31 PM #259
cockerman dan
Ole Miss Alum
 
cockerman dan's Avatar
 
Join Date: Sep 2006
Location: Oxford, Mississippi
cockerman dan owns a Planet Eclipse Ego
cockerman dan is an NCPA player
cockerman dan plays in the APPA D4 division
Bill,

Long time owner of an 08 Ego and have had no problems up until recently. Gun airs up, turns on. The bolt and ram are getting air pressure, but it will not cycle or fire. I have put in fresh batteries, taken it apart, cleaned and lubricated everything (valve, bolt, ram, lpr, hpr). I can hear the solenoid click, but nothing happens. No leaks anywhere. Any ideas? I do have a new solenoid for it, but if its not that, I don't want to replace it.
cockerman dan is offline   Reply With Quote
Old 04-02-2014, 08:34 AM #260
scarface478
 
 
scarface478's Avatar
 
Join Date: Jun 2007
Location: 203
scarface478 plays in the PSP
scarface478 is an NCPA player
I broke the frame of my CSL, how can I replace this? is it under warranty?
__________________
CT ballin
scarface478 is offline   Reply With Quote
Old 04-03-2014, 08:44 PM #261
oo Shermin
Photographer
 
oo Shermin's Avatar
 
Join Date: May 2011
Location: Summerville, SC
oo Shermin plays in the PSP
oo Shermin owns a Planet Eclipse Geo
oo Shermin owns a Planet Eclipse Ego
oo Shermin plays in the APPA D4 division
I have re lubed every o ring in the gun replaced every o ring in the gun cleaned everything rebuilt the reg. Still cant get the gun to chrono consistently more than 260 and it spiked once to 270 i really need help asap.
oo Shermin is offline   Reply With Quote
Old 04-04-2014, 11:45 PM #262
RJAY
PBS Founder
 
RJAY's Avatar
 
Join Date: Feb 2007
Location: Irvine, CA
What kind of maintenance do I need to do on an Ego7 that haven't been used for a few years?
RJAY is offline   Reply With Quote
Old 04-05-2014, 05:29 AM #263
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by RJAY View Post
What kind of maintenance do I need to do on an Ego7 that haven't been used for a few years?
Change out the battery
Oil the rammer orings
Grease the HPR and LPR orings
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline   Reply With Quote
Old 04-05-2014, 05:30 AM #264
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by oo Shermin View Post
I have re lubed every o ring in the gun replaced every o ring in the gun cleaned everything rebuilt the reg. Still cant get the gun to chrono consistently more than 260 and it spiked once to 270 i really need help asap.
What year / model marker?
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline   Reply With Quote
Old 04-05-2014, 05:30 AM #265
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by scarface478 View Post
I broke the frame of my CSL, how can I replace this? is it under warranty?
It most likely isnt covered. Try contacting gerry.b@planeteclipse.com
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline   Reply With Quote
Old 04-05-2014, 05:31 AM #266
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by cockerman dan View Post
Bill,

Long time owner of an 08 Ego and have had no problems up until recently. Gun airs up, turns on. The bolt and ram are getting air pressure, but it will not cycle or fire. I have put in fresh batteries, taken it apart, cleaned and lubricated everything (valve, bolt, ram, lpr, hpr). I can hear the solenoid click, but nothing happens. No leaks anywhere. Any ideas? I do have a new solenoid for it, but if its not that, I don't want to replace it.

- Try a new Energy, Duracell or Energizer battery. The gun needs a good amount of power to run the marker properly. A lessor brand of battery may read fully charged but doesn't have the upkeep to sustain the power needed to run the gun. This is the #1 cause of all issues in an EGO.
- Replace the #11 rammer oring. Even if it looks good. It will be the largest black oring
towards the rear of the rammer (page 55/56 in the manual).
- With in your Inline regulator is a large spring. This spring sits on the piston only one way. If you take the piston out of the reg body you will notice the spring will slide onto the piston easy one way and with alot of friction the other. You want the spring to sit with no friction. Lube the piston oring and re-install (pages 51/52 in the manual) .
- HPR Piston: Check the HPR Piston reg seat. There should be a small plastic like disk that is pressed into the end of the piston shaft. Make sure it is there and not cracked.
- Set your dwell to 14.0
- QEV Diaphragm issue. Inside the QEV block, between the blue body and silver caps, is a rubber diaphragm. This part should be one piece. Make sure it is not ripped or cut (see pages 64/65 in the manual).
- LPR: Be sure the LPR is assembled properly. There are 5 parts inside the LPR Cap. Listing from front to rear - Adjuster screw, adjuster piston (silver cuplike part), gold spring, silver piston and gold spring. The oring on the piston should be lightly greased with Eclipse grease or Sleek.Both springs are the same. Put the adjuster screw flush to one turn out, see if this affects the velocity at all.
- While you have the LPR apart check the LPR piston seat. Looks just like the HPR piston but smaller. Seat is in the same area...
- ASA On/Off knob turned in to far? When you add your air system to the gun you want to turn the knob until you hear the initial gas transfer. Do not turn it more then one complete turn more or you will actually restrict the airflow coming out of your air system.
- Complete oring overhaul, cleaning and lubrication.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline   Reply With Quote
Old 04-05-2014, 05:33 AM #267
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by aroun7 View Post
Hey I have a ego 8 and I was woundering why when the eyes are on its not shootong at 12.5 but when the eyes are off it does shoot at 12.5 and I cleaned the eyes and everything
Are you using paint and air of are you blocking the breech? If so, then you are faulting the eyes to 10bps.

If using air and paint, make sure the eyes are not pinched or dirty.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline   Reply With Quote
Old 04-05-2014, 05:34 AM #268
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by INXS17 View Post
Im having a solenoid issue on my lv1. Where the air vents out underneath the right sfr there is a constant leak. I changed the manifold gasket and solenoid gasket to no avail. I am leanin towards the solenoid is bad but wanted.to know if i should try something.else. thanks in advance.
LPR could be over pressurizing. Check the piston seat and the orings.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline   Reply With Quote
Old 04-05-2014, 05:34 AM #269
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by scar80 View Post
My ego 11 board is broken and was wondering what would be better, an OEM board from PE or a virtue board?
You're asking a PE tech lol
Ofcourse we are going to say stock! Although I personally believe it to be true!
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline   Reply With Quote
Old 04-05-2014, 05:36 AM #270
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by kumite45 View Post
Hey Bill, I have an LV1 and I get an air purge/excessive air sound on the first shot. No hot or low velocity just the purge sound? It will do it everytime the gun is shut off and turned back on. any thoughts Ive seen other people on you tube posting the exact issue with there LV1's. thanks for any help
Contact gerry.b@planeteclipse.com

He will send you a new oring for your LPR piston. Its a bit firmer and will not bind.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline   Reply With Quote
Old 04-05-2014, 05:36 AM #271
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by assa View Post
My SL-94 broke at the barrel threads (barrel got stuck on the grass and I landed on my gun...)
Is there a way to get another sl94 body? Who should I contact? I sent an email to info.usa@planeteclipse.com last week but haven't heard back.

Thanks! I love this gat and would really like to get it back up and running.

Odds are very slim they have a replacement but if they do, gerry.b@planeteclipse.com is the only guy to ask.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline   Reply With Quote
Old 04-06-2014, 09:44 AM #272
Jack7898
Jack7898
 
Join Date: Jun 2013
Location: Ellicott city
Jack7898 owns a Planet Eclipse Etek
I bought a Geo 1 and it is not firing. the air goes out in front of my trigger guard up in the corner of my inline regulator whenever i pull the trigger.I checked the red ball that moves back and forth and that seems fine. I have replaced batteries and made sure it is not in training mode. What else should i check before i decide to send it up to Rhode island?
Jack7898 is offline   Reply With Quote
Old 04-06-2014, 01:17 PM #273
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Try changing the bolt orings. You can also make sure the solenoid housing isnt cracked.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump