Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 03-25-2013, 09:00 PM #1
MarkeyMark
*#732*#
 
MarkeyMark's Avatar
 
Join Date: Nov 2003
Location: New Jersey
Annual Supporting Member
MarkeyMark is a Supporting Member
 has been a member for 10 years
MarkeyMark has perfected Level 1 in PbNation Pursuit
MarkeyMark has achieved Level 2 in PbNation Pursuit
MarkeyMark supports DLX Technology
1.5 Luxe charging issue?

Ok idk if anyone has experienced this before. I didn't really find anything on this either, but apologies if it was somewhere and I over looked it.

I traded my DM12 away for this luxe 1.5 everything is great about it except when I went to charge it today. I plug it in and nothing. I switched out the batteries to see if that was the problem, still nothing. Checked all the connections seems like everything is plugged in properly. Read the manual, nothing. Could it be that my board is messed up, or could it simply just be the charger is broke? If anyone could help it would be greatly appreciated.
__________________

**VAPOR VENDETTA**
:DODGY: ARMY SUPPORT
HOSTILE TAKEOVER/TOP GUN TEMPO
MURDER INC. PAINTBALL NJ *RIP*
OLD FeedBack (+13/-0):http://www.pbnation.com/showthread.p...hreadid=464631
MarkeyMark is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 03-26-2013, 12:32 AM #2
Kornbred
Mustache Mike
 
Kornbred's Avatar
 
Join Date: Dec 2011
Location: Ventura, CA
Annual Supporting Member
Kornbred supports DLX Technology
Kornbred owns a Planet Eclipse GSL
It could be either one. I would grab a buddies charger and see if that works. If it doesn't, I would imagine there is a problem in the board if you have already swapped out the batteries. Make sure you are plugging the battery into the port that say "BAT", it is in really small writing on the board. If the battery is plugged into the speaker port (they will fit), it will fry the board.

From what your describing, it sounds like you are on the right track.
__________________
Kornbred is offline   Reply With Quote
Old 03-26-2013, 01:40 AM #3
MarkeyMark
*#732*#
 
MarkeyMark's Avatar
 
Join Date: Nov 2003
Location: New Jersey
Annual Supporting Member
MarkeyMark is a Supporting Member
 has been a member for 10 years
MarkeyMark has perfected Level 1 in PbNation Pursuit
MarkeyMark has achieved Level 2 in PbNation Pursuit
MarkeyMark supports DLX Technology
Quote:
Originally Posted by Kornbred View Post
It could be either one. I would grab a buddies charger and see if that works. If it doesn't, I would imagine there is a problem in the board if you have already swapped out the batteries. Make sure you are plugging the battery into the port that say "BAT", it is in really small writing on the board. If the battery is plugged into the speaker port (they will fit), it will fry the board.

From what your describing, it sounds like you are on the right track.
Thank you kornbred, Idk anybody that has a Luxe so ill have to go to my local shop probably to check out if its the charger. Yes, I believe that the battery is plugged into the battery port. I'm really hoping I don't have to replace the board that would be bad . I'm also going to contact DLX too just incase they know something I don't.
__________________

**VAPOR VENDETTA**
:DODGY: ARMY SUPPORT
HOSTILE TAKEOVER/TOP GUN TEMPO
MURDER INC. PAINTBALL NJ *RIP*
OLD FeedBack (+13/-0):http://www.pbnation.com/showthread.p...hreadid=464631
MarkeyMark is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump