Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 02-23-2013, 03:14 AM #1
Pr3claTol2
Basic ~ USU Paintball
 
Pr3claTol2's Avatar
 
Join Date: May 2006
Location: UTAH
Pr3claTol2 owns a Planet Eclipse Geo
Pr3claTol2 owns a Planet Eclipse Geo
Firing Issues with Geo 2. Help Needed

Hello Nation~


I am stumped. After taking apart, cleaning and lubing my Geo 2, it will not cycle properly

I have checked the stickies, the entire manual and quite a few threads here by people with this similar problem.

When I fire the marker the solenoid seems to only half cycle and just purges air through the usual spot between the body and grip frame right behind the regulator.

The inline regulator seems to be functioning fine. I cleaned and lubed it very thoroughly and have done so multiple times. I have taken apart the solenoid and cleaned and re-lubed the spool pack. The back-check assembly seems to all be fine. The manifold seems just fine. The filter on the gasket IS damaged. The filter has actually been removed because it was dangling and I thought it might have been getting stuck in the marker causing it not to fire. I know I need to get this replaced; the solenoid DOES leak slightly. It should not cause the marker to not fire because I was having this same problem when the solenoid wasn't leaking and the filter was still intact on the gasket.

I have replaced several of the orings on the bolt(especially the ones recommended, the 017 and the 14X2's). Re-lubed. I am using Dow 55 lubricant.

The dwell I bumped form 10 back up to 12.5.


I have stripped it COMPLETELY, cleaned very thouroughly and re-lubed everything. I have been working on this for 5+ hours. I'm stuck. I'm done. I even set the board to FACTORY. Nothing. Are there any other board settings I can try?

I try and not post questions here without doing as much research as I can myself. I really need some help on this one. I am fairly new to the Geo, but not Planet Eclipse guns nor gun teching in general. I have worked on many, many guns and am simply stuck. Please help!
__________________
Team Basic | USU Paintball
HK•Army | Utah Xtreme Paintball


Gearbag Sale | ANS Chaos Cocker & FS5 F/S/T

Don't Call It A Comeback, I've Been Here For Years

Last edited by Pr3claTol2 : 02-23-2013 at 03:28 AM.
Pr3claTol2 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 02-23-2013, 02:41 PM #2
I'm_Addicted
snowman FTW
 
I'm_Addicted's Avatar
 
Join Date: Mar 2005
Location: CT
I'm_Addicted owns a Planet Eclipse Geo
I'm_Addicted owns a Planet Eclipse Geo
I'm_Addicted owns a Planet Eclipse Geo
Dow 55 causes the orings to swell, which would cause some bolt stick. You need Dow 33 or a similar lube.
I'm_Addicted is offline   Reply With Quote
Old 02-23-2013, 03:03 PM #3
Pr3claTol2
Basic ~ USU Paintball
 
Pr3claTol2's Avatar
 
Join Date: May 2006
Location: UTAH
Pr3claTol2 owns a Planet Eclipse Geo
Pr3claTol2 owns a Planet Eclipse Geo
Quote:
Originally Posted by I'm_Addicted View Post
Dow 55 causes the orings to swell, which would cause some bolt stick. You need Dow 33 or a similar lube.
Cool, I will start there, thanks!
__________________
Team Basic | USU Paintball
HK•Army | Utah Xtreme Paintball


Gearbag Sale | ANS Chaos Cocker & FS5 F/S/T

Don't Call It A Comeback, I've Been Here For Years
Pr3claTol2 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump