Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 02-28-2013, 02:22 AM #22
MrSickNasty
 
 
Join Date: Jan 2013
MrSickNasty owns a Planet Eclipse Ego
Had a hunch it might be the LPR assembly since ive changed every o-ring on the bolt about 3 times. On my olive PM5 I pulled out the LPR seal assembly (brass piece you use to tune to LPR setting.) Cleaned it up and replaced the o-ring which I noticed visual damage too. Put it back in reset to 75 PSI (5 turns out) and the gun doesn't leak at all. Too late to test fire it but I will tomorrow. Hopefully thats one problem solved.

Maybe this is why I wasn't getting any motion even after setting the HPR way too high. Cause of a leak in the LPR???


Anyway did the same thing to the blue PM5 (the one I started this thread about.) And it still leaks. So now im thinking it might be the other o-rings on the LPR assembly.




1 down 2 to go.
__________________
MrSickNasty is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 03-01-2013, 12:58 AM #23
MrSickNasty
 
 
Join Date: Jan 2013
MrSickNasty owns a Planet Eclipse Ego
So I got two of them to stop leaking. The blue one and the olive pm5's. I dont have a chrono so its hard to test things. The top hat o-ring keeps blowing forward into the bolt on the blue one. And I keep getting these barrel/solenoid area leaks. So far the only thing ive been able to trace it too is the tuning of the LPR and HPR. It seems that I have to turn the HPR many times to get the bolt to move.

LPRs are both set at 75 psi (5 turns)

And HPR is set to a random amount of turns till the bolt begins to move. Seems like its more turns than it should be. I pulled the LPR out and replaced those o-rings aswell.
__________________

Last edited by MrSickNasty : 03-01-2013 at 01:01 AM.
MrSickNasty is offline   Reply With Quote
Old 03-06-2013, 08:57 AM #24
MrSickNasty
 
 
Join Date: Jan 2013
MrSickNasty owns a Planet Eclipse Ego
As noted my solenoid-board wiring harness was a little messed up. And actually ripped apart. I was wondering if this one would work. Also how are you supposed to remove the old one from the solenoid. Couldn't figure it out, obviously the linked item will need to be spliced.

http://www.ebay.com/itm/Dye-Proto-DM...em27cfde 403f



Also would a DM4 LPR knob fit a PM5??
__________________

Last edited by MrSickNasty : 03-06-2013 at 09:01 AM.
MrSickNasty is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump