Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 02-11-2013, 06:31 AM #1
NJjesters4
Kong-Ker
 
NJjesters4's Avatar
 
Join Date: Jan 2004
Location: RIP Ronnie
NJjesters4 is a Supporting Member
 has been a member for 10 years
Geo 3 ramp seems to lag

I have 2 geo 3's one custom edition team gun which was flawless right out of the box. My other geo 3 which I just got seems to have some lag to ramping

Anybody else have the same problem? Any quick tips on how you were able to adjust the settings. I need it to be in basically Psp mode

Thanks for any help
NJjesters4 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 02-11-2013, 08:48 AM #2
abenguyen
Abe Na-Goo-Yen
 
abenguyen's Avatar
 
Join Date: Jun 2008
Location: DFW, TX
abenguyen owns a Planet Eclipse Geo
abenguyen owns a Planet Eclipse Geo
abenguyen posts videos on PbNation
abenguyen plays in the APPA beginner division
abenguyen supports DLX Technology
Quote:
Originally Posted by NJjesters4 View Post
I have 2 geo 3's one custom edition team gun which was flawless right out of the box. My other geo 3 which I just got seems to have some lag to ramping

Anybody else have the same problem? Any quick tips on how you were able to adjust the settings. I need it to be in basically Psp mode

Thanks for any help
Change the board setting to the PSP preset mode and not the ramp mode. That'll make it easier to ramp.
abenguyen is offline   Reply With Quote
Old 02-11-2013, 09:00 AM #3
egogeo
 
 
egogeo's Avatar
 
Join Date: Dec 2012
How many trigger pulls do you have it set to before it ramps?
egogeo is offline   Reply With Quote
Old 02-11-2013, 09:53 AM #4
BMFer
 
 
BMFer's Avatar
 
Join Date: Jul 2005
Location: Iowa
Make sure you are in the PSP12 mode.
There is a "PSP10" mode.

Been playing with mine on PSP12. I have not noticed a lag.
Could be the wrong mode, or a specific issue with your Geo.
BMFer is offline   Reply With Quote
Old 02-11-2013, 12:39 PM #5
Mr. Bishi
Get at ya boiiiiii!
 
Mr. Bishi's Avatar
 
Join Date: Apr 2011
Location: Concord
Mr. Bishi plays in the PSP
Mr. Bishi owns a Planet Eclipse Geo
Mr. Bishi supports Team VICIOUS
Mr. Bishi plays in the APPA D3 division
Mr. Bishi has achieved Level 3 in PbNation Pursuit
You can also lower your Kickin/Sustain tigger pull settings
__________________
VooDooKings
Scenario Paintball Team

Border Patrol #68
MMPhotography
Mr. Bishi is offline   Reply With Quote
Old 02-11-2013, 02:26 PM #6
gznick
 
Join Date: Oct 2002
Location: long island ny
 has been a member for 10 years
gznick is a Professional paintball player
my geo3 is like that as well it takes a while to get up to 12.5 balls a sec it starts ramping but doenst get to 12.5 right away and i lowered my kickin and sustain to 3.3 still slow gettiing up to speed
gznick is offline   Reply With Quote
Old 02-12-2013, 09:21 AM #7
jonny72888
 
 
jonny72888's Avatar
 
Join Date: Feb 2008
Location: Mass
jonny72888 owns a Planet Eclipse Geo
jonny72888 posts videos on PbNation
jonny72888 plays in the APPA D5 division
Quote:
Originally Posted by gznick View Post
my geo3 is like that as well it takes a while to get up to 12.5 balls a sec it starts ramping but doenst get to 12.5 right away and i lowered my kickin and sustain to 3.3 still slow gettiing up to speed
Is it on psp12 or is it in ramp.
I think ramp goes off how you pull the trigger and if its in psp12 it shoots at 12.5
__________________
GEO3

PnL Paintball PaintballPunks.com
jonny72888 is offline   Reply With Quote
Old 02-12-2013, 11:16 AM #8
Jack Wood
 
 
Jack Wood's Avatar
 
Join Date: Jul 2001
Location: Planet Eclipse, England
Annual Supporting Member
Jack Wood is a founding member
 has been a member for 10 years
Jack Wood works for a Paintball manufacturer
Jack Wood owns a Planet Eclipse GSL
You also need to make sure your Restart is set at 1.0sec
Jack Wood is offline   Reply With Quote
Old 02-13-2013, 06:42 AM #9
NJjesters4
Kong-Ker
 
NJjesters4's Avatar
 
Join Date: Jan 2004
Location: RIP Ronnie
NJjesters4 is a Supporting Member
 has been a member for 10 years
The restart did it. Thanks jack. Gun is ripping like it shoud now
NJjesters4 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump