Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 02-28-2013, 01:29 PM #1
47zap47
 
 
Join Date: Feb 2013
Bt-tm7 not firing? Any info appreciated

Hello, i went paintballing for my first time in over 5 years a few weekends back and loved it. I decided to get back into it and i picked up a lightly used bt tm-7 from a private seller. Gun worked absolutely perfect as far as i could tell. i put a few hoppers of paint through it at my house and change the fire rates to what i wanted and had no issues. THE PROBLEM.. The first time i went to a field to use it (last night, and i had fired the gun that morning with no issues) i set it all up and went to chrono it and it wouldnt fire.. The light was flashing green green at normal speed with a red flash in between ocasionally with no balls in the eyes. when i put a ball in the chamber the light would rapidly flash green repeatedly and would not fire. I tore it apart right there went through my knowledge of the gun so far from what ive read and couldnt figure it out. Any help from you guys would be extremely appreciated! Thank you very much for reading.

New info:
*** found that i am un able to turn the eyes off so is seems the trigger isnt sending a signal, but im not sure. I tried turning the eyes off with the tourney lock on and off and it didnt turn them off ***

Last edited by 47zap47 : 02-28-2013 at 05:41 PM.
47zap47 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 02-28-2013, 02:21 PM #2
Sirriko
WAKA WAKA
 
Sirriko's Avatar
 
Join Date: Jan 2013
Location: Great White North
Annual Supporting Member
Sirriko is playing at Living Legends VI
Sirriko owns a Planet Eclipse Geo
Sirriko supports Team VICIOUS
Sirriko supports Team VICIOUS
Sirriko posts videos on PbNation
Sirriko has achieved Level 2 in PbNation Pursuit
I would take it to the local gun tech, I'll try to look more into it.
__________________
I used to be a professional paintball player, then I took a paintball to the knee...


Canadian eh? Would you like a donut?
Sirriko is offline   Reply With Quote
Old 02-28-2013, 02:22 PM #3
todamax369
Dustin
 
todamax369's Avatar
 
Join Date: May 2008
Location: NY 845
todamax369 is BST Trusted
todamax369 is playing at Living Legends VII
todamax369 posts videos on PbNation
todamax369 is attending Decay of Nations VII
Have you replaced your battery? For the most part that's really the only thing that can go wrong in a couple of hours like that. Plus it's the easiest thing to rule out. I can't tell you how many eye and solenoid issues I've had all because of bad battery.
todamax369 is offline   Reply With Quote
Old 02-28-2013, 02:26 PM #4
Sirriko
WAKA WAKA
 
Sirriko's Avatar
 
Join Date: Jan 2013
Location: Great White North
Annual Supporting Member
Sirriko is playing at Living Legends VI
Sirriko owns a Planet Eclipse Geo
Sirriko supports Team VICIOUS
Sirriko supports Team VICIOUS
Sirriko posts videos on PbNation
Sirriko has achieved Level 2 in PbNation Pursuit
Heres what I found so far:
" I belive you have a bad solinoid as a lot of tm-7 had bad solinoids, though I sugest you try to clean out the solinoid becuase there may just be some factory junk in there. "

"I would assume that it would be the solenoid, I had some trouble with mine, and I had Kee themselves fix it, they threw on a brand new solenoid, and it works flawlessly, I even think they even put the solenoid upgrade onto it, because it sounds quiter now.
Just contact BT, and see if they can just have you ship them your gun, and have them replace it."

http://www.******.com/forum/index.php?showtopic=93517
__________________
I used to be a professional paintball player, then I took a paintball to the knee...


Canadian eh? Would you like a donut?
Sirriko is offline   Reply With Quote
Old 02-28-2013, 02:27 PM #5
Sirriko
WAKA WAKA
 
Sirriko's Avatar
 
Join Date: Jan 2013
Location: Great White North
Annual Supporting Member
Sirriko is playing at Living Legends VI
Sirriko owns a Planet Eclipse Geo
Sirriko supports Team VICIOUS
Sirriko supports Team VICIOUS
Sirriko posts videos on PbNation
Sirriko has achieved Level 2 in PbNation Pursuit
Quote:
Originally Posted by todamax369 View Post
Have you replaced your battery? For the most part that's really the only thing that can go wrong in a couple of hours like that. Plus it's the easiest thing to rule out. I can't tell you how many eye and solenoid issues I've had all because of bad battery.
Or that, lol.
__________________
I used to be a professional paintball player, then I took a paintball to the knee...


Canadian eh? Would you like a donut?
Sirriko is offline   Reply With Quote
Old 02-28-2013, 03:13 PM #6
47zap47
 
 
Join Date: Feb 2013
I have tried changing the battery but it wasnt that. Ive been wondijg if its the so.enoid but i dont know to much about them so i didnt disasemble it, im going to give bt a call about that
47zap47 is offline   Reply With Quote
Old 02-28-2013, 03:15 PM #7
47zap47
 
 
Join Date: Feb 2013
Quote:
Originally Posted by Sirriko View Post
Heres what I found so far:
" I belive you have a bad solinoid as a lot of tm-7 had bad solinoids, though I sugest you try to clean out the solinoid becuase there may just be some factory junk in there. "

"I would assume that it would be the solenoid, I had some trouble with mine, and I had Kee themselves fix it, they threw on a brand new solenoid, and it works flawlessly, I even think they even put the solenoid upgrade onto it, because it sounds quiter now.
Just contact BT, and see if they can just have you ship them your gun, and have them replace it."

http://www.******.com/forum/index.php?showtopic=93517

Thanks very much for looking into this for me! I appreciate it very much, im so lost with it because it just stopped working on me
47zap47 is offline   Reply With Quote
Old 02-28-2013, 03:20 PM #8
super_stanchy
the man with no plan
 
super_stanchy's Avatar
 
Join Date: Feb 2006
Location: Oregon City, Or
Annual Supporting Member
super_stanchy works for a Paintball manufacturer
super_stanchy plays in the PSP
super_stanchy supports Bob Gurnsey
gotta rule out the dumb question....

air tank have air? and is it screwed in FULLY?
my little bro's TM7 the tank screws in and snug, but needs an extra 1/2 turn to depress the stem on the tank

also.... whats your gauge reading at?
super_stanchy is offline   Reply With Quote
Old 02-28-2013, 03:42 PM #9
47zap47
 
 
Join Date: Feb 2013
Quote:
Originally Posted by super_stanchy View Post
gotta rule out the dumb question....

air tank have air? and is it screwed in FULLY?
my little bro's TM7 the tank screws in and snug, but needs an extra 1/2 turn to depress the stem on the tank

also.... whats your gauge reading at?

Air was fully filled and then put it on, the gun released pressure a min after i took the tank off so it had pressure into the gun. Ive got my reg set at 200psi and i bumped it to 220 to see if it changed anything but no dice on that.
47zap47 is offline   Reply With Quote
Old 02-28-2013, 09:28 PM #10
Twaltz628
newb for 8 yrs & counting
 
Twaltz628's Avatar
 
Join Date: Aug 2012
Location: NC
Annual Supporting Member
Twaltz628 has perfected Level 1 in PbNation Pursuit
Twaltz628 has achieved Level 2 in PbNation Pursuit
Twaltz628 supports Empire
Trigger settings.

The tm7 has 4 set screws in the trigger itself, I believe the previous owner had it set for the shortest trigger pull possible or too far perhaps. Either way, you can control where the triggers stops and you can control when the marker is cycled with those screws (plus 2 more relevant settings). If the settings don't intersect, the gun won't fire. There is a manual online that shows the screws location and what they control. Play with them I bit. I've had the problem too and for some reason they worked when I put the marker away and when I got it back out, it didn't. I know my explanation is clear as mud, but good luck.
__________________
Insert funny, witty, inspirational or sales signature here.
Twaltz628 is offline   Reply With Quote
Old 02-28-2013, 10:27 PM #11
todamax369
Dustin
 
todamax369's Avatar
 
Join Date: May 2008
Location: NY 845
todamax369 is BST Trusted
todamax369 is playing at Living Legends VII
todamax369 posts videos on PbNation
todamax369 is attending Decay of Nations VII
Will the marker dry fire with eyes off? If it does then you can rule out a lot.
todamax369 is offline   Reply With Quote
Old 02-28-2013, 10:35 PM #12
p8ntballr68059
Post whore since 08
 
p8ntballr68059's Avatar
 
Join Date: May 2008
Location: corn&cowville
Annual Supporting Member
p8ntballr68059 supports Team VICIOUS
p8ntballr68059 supports Team VICIOUS
p8ntballr68059 supports Team VICIOUS
p8ntballr68059 plays in the APPA D5 division
p8ntballr68059 is one of the top 25 posters on PbNation
p8ntballr68059 is Boss
p8ntballr68059 supports DLX Technology
i will bet it is just the trigger not sending the signal.. to turn the eyes off you need to hold down the trigger while you turn it on.. also one more thing to look at make sure that lever that controls the modes is actually changing it to a firing mode and not just moving freely
__________________
GSA FOREVER
Vicious fan #42
My Current markers Texas Storm G6R,Insight,Sniper,Vice,Marq 7, TonTon Shocker
p8ntballr68059 is offline   Reply With Quote
Old 02-28-2013, 11:20 PM #13
Twaltz628
newb for 8 yrs & counting
 
Twaltz628's Avatar
 
Join Date: Aug 2012
Location: NC
Annual Supporting Member
Twaltz628 has perfected Level 1 in PbNation Pursuit
Twaltz628 has achieved Level 2 in PbNation Pursuit
Twaltz628 supports Empire
Again, the trigger screws

Like p8ntballr mentioned, if the trigger isn't working, you won't be able to turn the eyes off. However, I don't think you need to worry about the safety switch. If it wasn't assembled properly, if would be most likely stuck in one mode. So either would be stuck in safety, turn on but light up red; or it would be stuck in firing mode and just not turn on. It still wouldn't hurt to check, but you problem probably lies with the screw settings IMO.
__________________
Insert funny, witty, inspirational or sales signature here.
Twaltz628 is offline   Reply With Quote
Old 03-01-2013, 12:18 AM #14
Sirriko
WAKA WAKA
 
Sirriko's Avatar
 
Join Date: Jan 2013
Location: Great White North
Annual Supporting Member
Sirriko is playing at Living Legends VI
Sirriko owns a Planet Eclipse Geo
Sirriko supports Team VICIOUS
Sirriko supports Team VICIOUS
Sirriko posts videos on PbNation
Sirriko has achieved Level 2 in PbNation Pursuit
Quote:
Originally Posted by Twaltz628 View Post
Like p8ntballr mentioned, if the trigger isn't working, you won't be able to turn the eyes off. However, I don't think you need to worry about the safety switch. If it wasn't assembled properly, if would be most likely stuck in one mode. So either would be stuck in safety, turn on but light up red; or it would be stuck in firing mode and just not turn on. It still wouldn't hurt to check, but you problem probably lies with the screw settings IMO.
That also, there called the post and pre travel adjustment screws.
__________________
I used to be a professional paintball player, then I took a paintball to the knee...


Canadian eh? Would you like a donut?
Sirriko is offline   Reply With Quote
Old 03-01-2013, 12:19 AM #15
Sirriko
WAKA WAKA
 
Sirriko's Avatar
 
Join Date: Jan 2013
Location: Great White North
Annual Supporting Member
Sirriko is playing at Living Legends VI
Sirriko owns a Planet Eclipse Geo
Sirriko supports Team VICIOUS
Sirriko supports Team VICIOUS
Sirriko posts videos on PbNation
Sirriko has achieved Level 2 in PbNation Pursuit
Quote:
Originally Posted by 47zap47 View Post
Thanks very much for looking into this for me! I appreciate it very much, im so lost with it because it just stopped working on me
yea np
__________________
I used to be a professional paintball player, then I took a paintball to the knee...


Canadian eh? Would you like a donut?
Sirriko is offline   Reply With Quote
Old 03-02-2013, 06:16 PM #16
theCronicles
 
 
theCronicles's Avatar
 
Join Date: Feb 2013
Location: Brooklyn, NY
I shoot a mini which shares much of the tech of the tm-7. I agree with the last two about the trigger adjustment. Lengthen the travel. On the mini the light will always do something when the trigger activates, even if it's not actually firing the marker. Also, check the manual but I don't believe you're ever supposed to set the pressure above 200psi on that marker or you risk damaging the internals.
theCronicles is offline   Reply With Quote
Old 03-03-2013, 08:48 AM #17
Kepope1988
 
 
Join Date: Mar 2013
He's right never operate one above 200 that can lead to internal issues. The first time I took my tm7 apart with the same issue after running full auto all day. I replaced it with the upgraded solenoid and re soldered the connection points for the 9 volt since it broke during disassembly. Let me know if you need a diagram or anything and I can scan mine and email it to you.
Kepope1988 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump