Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 01-19-2013, 12:28 AM #1
usmc2005
 
 
usmc2005's Avatar
 
Join Date: Mar 2009
Location: Twinsburg, ohio
NT Power issues

Hey everyone. So today I went to turn my NT on tonight and nothing it didn't power up. I checked the battery, replaced the battery, check the connection, checked the wires.... And everything thing seems good. So does anyone have any ideas what may be wrong? I'm suppose to play Sunday so let me know. Thanks everyone !!
usmc2005 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 01-19-2013, 02:58 AM #2
Word?
Bring back 10man
 
Word?'s Avatar
 
Join Date: Oct 2004
Location: Go pound sand
Word? is a Supporting Member
Well,

If you checked everything like you said you did. Your board is either dead or the buttons on it are done. You probably need a new board.

I have to be honest though, I've never-in my 10 year span of playing paintball seen a dye board go down. Ever. So, double and triple check that all your connections are correct, none of the wires are crimped and that the battery is in fact good. Also, make sure the positive and negative prongs are in the correct position. Because if not you can fry your board.

Don't forget to check the manual!
__________________
FEEDBACK


LOLWUT
Word? is offline   Reply With Quote
Old 01-19-2013, 08:36 AM #3
usmc2005
 
 
usmc2005's Avatar
 
Join Date: Mar 2009
Location: Twinsburg, ohio
Oh trust me this is my 3rd Dye gun it baffled me last night too. In all my years playing I have never seen this problem. The manual states the same as we have talked about on here. The only thing I see is a crack on the weld for the negative connection on the board. The wires look ok, but who knows. I did notice the buttons on the frame and on the board do not line up fully, so I am going to try and correct that. Thanks
usmc2005 is offline   Reply With Quote
Old 01-19-2013, 10:18 AM #4
MaSsAcRe251
Traeger
 
MaSsAcRe251's Avatar
 
Join Date: Nov 2006
Location: Williamsville, IL
MaSsAcRe251 is playing at Living Legends V
MaSsAcRe251 plays in the APPA D5 division
MaSsAcRe251 has achieved Level 3 in PbNation Pursuit
MaSsAcRe251 supports DLX Technology
I had a similar issue with a board that was in a PM8. It wouldn't turn on no matter what. I ended up getting a new board and it was fine.

So it's possible that getting a new board would fix your problem. See of you can troubleshoot some more before you spend any money though.
__________________
I BUY Your Gear | Luxe 2.0 F/S/T
MaSsAcRe251 is offline   Reply With Quote
Old 01-21-2013, 10:04 AM #5
usmc2005
 
 
usmc2005's Avatar
 
Join Date: Mar 2009
Location: Twinsburg, ohio
After triple checking everything, I took it to the shop I bought it at and it was confirmed to be the board. Thanks for the advise and tips guys. I think I'll get a virtue board lol
usmc2005 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump