Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 01-15-2013, 11:13 AM #1
ashep01
 
 
ashep01's Avatar
 
Join Date: Jun 2012
Location: Raynham, Ma
ashep01 supports Team VICIOUS
ashep01 is for the Gunfight
ashep01 plays in the APPA D4 division
ashep01 supports DLX Technology
Demon troubles.

Hello,

I have a demon and I have been having some electical/board problems. I have already replaced the board once but a problem persists. The previous board I could not get to turn on what so ever, and this new one I can only get to turn on when both the battery is plugged in and the power cord plugged in too. If i remove the power cord the board stays on and I can cycle through the settings and all (have not tried to leave it on and fire). If I then shut off the board (powercord still not plugged in) I can not turn the board back on.
-Battery does have power, i have checked.
ashep01 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 01-15-2013, 11:15 AM #2
Reaper (ACI)
We're Weird
 
Reaper (ACI)'s Avatar
 
Join Date: Apr 2008
Location: Beaverton, OR
Reaper (ACI) works for a Paintball manufacturer
Reaper (ACI) donated to help Peyton Trent
Reaper (ACI) is for the Gunfight
Reaper (ACI) is for the Gunfight
You need to contact the place you bought your new board from and eithe exchange it or return it. It's not working and needs to be replaced.
__________________
VANGUARD CERTIFIED MASTER TECH
Dead Box Sports
West Coast Parts, Service, Warranty, and Distribution
www.deadboxsports.com

I have LEGO Paintballer Mini Figs
Reaper (ACI) is offline   Reply With Quote
Old 01-15-2013, 05:51 PM #3
MstrKey
 
 
Join Date: Aug 2001
Location: SSM, Ontario, Canada
MstrKey is a founding member
 has been a member for 10 years
MstrKey is for the Gunfight
MstrKey supports our troops
Hmmm the board works with the charging cord in. I would try a reset on the board with the power on to see if that helps. It's a tiny grey button on the board itself.

Even though the battery says full power.......the board may not recognize it for some weird reason. Unplug the battery, turn on the board using the charger cord, then when the gun is on plug the battery in. Then power down and try again.

It's worth a shot. I can't see why two different boards would have issues. The only common thing between them is the battery.

Out of curiosity, is the battery puffy?
__________________

Black/Purple Spire F/s. Freshly updated from Virtue.
MstrKey is offline   Reply With Quote
Old 01-15-2013, 06:15 PM #4
ashep01
 
 
ashep01's Avatar
 
Join Date: Jun 2012
Location: Raynham, Ma
ashep01 supports Team VICIOUS
ashep01 is for the Gunfight
ashep01 plays in the APPA D4 division
ashep01 supports DLX Technology
Nothing out of the ordinary with the battery. I will try a reset tomorrow'
ashep01 is offline   Reply With Quote
Old 01-16-2013, 09:48 AM #5
ashep01
 
 
ashep01's Avatar
 
Join Date: Jun 2012
Location: Raynham, Ma
ashep01 supports Team VICIOUS
ashep01 is for the Gunfight
ashep01 plays in the APPA D4 division
ashep01 supports DLX Technology
Quote:
Originally Posted by MstrKey View Post
Hmmm the board works with the charging cord in. I would try a reset on the board with the power on to see if that helps. It's a tiny grey button on the board itself.

Even though the battery says full power.......the board may not recognize it for some weird reason. Unplug the battery, turn on the board using the charger cord, then when the gun is on plug the battery in. Then power down and try again.
So I tried the reset and getting the board to recognize the battery following the steps you outlined.
Here is what I saw and noted.
-If i plug in the power cord to the board with no battery attached, the charge battery screen flickers. but if i then turn on the board the screen displays normally.
-Following the steps to get the board to recognize the battery, after attaching the battery and powering down the board: I unattached the power cord so the remaining power source is the battery. I am able to then turn on the board, however if I turn off the board and attempt to turn it back on I am unable to do so. Once I plug the power cord back in I am immediately able to turn the board back on..

-As I am typing this I am starting to think its the battery...
ashep01 is offline   Reply With Quote
Old 01-16-2013, 11:45 AM #6
MstrKey
 
 
Join Date: Aug 2001
Location: SSM, Ontario, Canada
MstrKey is a founding member
 has been a member for 10 years
MstrKey is for the Gunfight
MstrKey supports our troops
battery

Quote:
Originally Posted by ashep01 View Post
So I tried the reset and getting the board to recognize the battery following the steps you outlined.
Here is what I saw and noted.
-If i plug in the power cord to the board with no battery attached, the charge battery screen flickers. but if i then turn on the board the screen displays normally.
-Following the steps to get the board to recognize the battery, after attaching the battery and powering down the board: I unattached the power cord so the remaining power source is the battery. I am able to then turn on the board, however if I turn off the board and attempt to turn it back on I am unable to do so. Once I plug the power cord back in I am immediately able to turn the board back on..

-As I am typing this I am starting to think its the battery...
Sounds like it. Try again but the second time when you power the gun down, leave the cord in as well. Does the battery show as fully charged on the screen? I had a problem where if I just plugged the cord in with my bad battery, the gun would say the battery is fully charged. If I unplugged the battery, then did the steps I told you to try and turned the gun off while still plugged in.....it would then show my battery as totally dead and start charging it again. I'd have to let it charge but then of course the battery was toast so it would only hold a charge for hours at best. You did get it to turn on once so I'm wondering if your battery is actually dead and the board is lying.....like mine did.
__________________

Black/Purple Spire F/s. Freshly updated from Virtue.

Last edited by MstrKey : 01-16-2013 at 11:48 AM.
MstrKey is offline   Reply With Quote
Old 01-16-2013, 01:24 PM #7
ashep01
 
 
ashep01's Avatar
 
Join Date: Jun 2012
Location: Raynham, Ma
ashep01 supports Team VICIOUS
ashep01 is for the Gunfight
ashep01 plays in the APPA D4 division
ashep01 supports DLX Technology
Quote:
Originally Posted by MstrKey View Post
Sounds like it. Try again but the second time when you power the gun down, leave the cord in as well. Does the battery show as fully charged on the screen? I had a problem where if I just plugged the cord in with my bad battery, the gun would say the battery is fully charged. If I unplugged the battery, then did the steps I told you to try and turned the gun off while still plugged in.....it would then show my battery as totally dead and start charging it again. I'd have to let it charge but then of course the battery was toast so it would only hold a charge for hours at best. You did get it to turn on once so I'm wondering if your battery is actually dead and the board is lying.....like mine did.
I will check in to that tomorrow morning.
As i recall the battery always showed full power and i dont remember a recharge screen coming on after turning off the board. I "drained" the battery a little by leaving just the battery plugged in and screen on. Only then it shows a recharge screen
ashep01 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump