Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 03-24-2013, 02:25 AM #1
sp1jp
 
 
sp1jp's Avatar
 
Join Date: Mar 2013
Location: Ontario, Canada
sp1jp owns a Planet Eclipse Ego
Been a long time...

Hey all! just getting back into the sport and went and picked up my T9 from my fathers house, Which has been sitting in his basement for about 3 years in its case. Well to my surprise I took it apart and found a lot wrong with it and have no clue where to start. First issue is, Rust. Inside the barrel there is light rust and around the screw in points for the barrel extension. Not sure how to go about fixing this. I took everything apart, Seemed okay, oiled it up, replaced the rings, Popped in a fresh co2 cartridge and the gun would just fire blank(tried this with two different mags) Took it apart again to make sure the bolt was in place properly and it was. Id like to fix this myself but Im not sure if the rust issue can be fixed because of where its all located. Any help would be greatly appreciated.
sp1jp is offline   Reply With Quote
Old 03-24-2013, 09:26 AM #2
Fubarius
Yep, it's orange.
 
Fubarius's Avatar
 
Join Date: Aug 2003
Location: New Richmond, WI
Annual Supporting Member
 has been a member for 10 years
Fubarius supports our troops
Fubarius has achieved Level 1 in PbNation Pursuit
Fubarius has achieved Level 2 in PbNation Pursuit
Fubarius is a Forum Captain
That's not rust, or at least not rust from where you think it's from.

The barrel is aluminum. Anodized aluminum doesn't rust.

Now the bolt and air chamber are steel, those can rust, which gets in the lube and can spread down the barrel. The detents are also steel, and have a tendency to rust as well. And possibly the tube inside do the front shroud, I'll have to check mine.

Anyway, any brown crud you find just means the gun needs a bit of cleaning and re-lube.

So lets get to what the gun is actually doing. So the gun is firing, but not feeding paint from the mag?
__________________
David Johnson, AKA Fubarius.

000110 200 11202 10 000020
012211 021 22110 22 121101
222001 222 10220 00 022212
Fubarius is offline   Reply With Quote
Old 03-24-2013, 09:40 AM #3
sp1jp
 
 
sp1jp's Avatar
 
Join Date: Mar 2013
Location: Ontario, Canada
sp1jp owns a Planet Eclipse Ego
Quote:
Originally Posted by Fubarius View Post
That's not rust, or at least not rust from where you think it's from.

The barrel is aluminum. Anodized aluminum doesn't rust.

Now the bolt and air chamber are steel, those can rust, which gets in the lube and can spread down the barrel. The detents are also steel, and have a tendency to rust as well. And possibly the tube inside do the front shroud, I'll have to check mine.

Anyway, any brown crud you find just means the gun needs a bit of cleaning and re-lube.

So lets get to what the gun is actually doing. So the gun is firing, but not feeding paint from the mag?
Ok good to know, Thanks! and yes it wont feed through mags or a hopper, It fires but wont fire a ball.
sp1jp is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump