Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 02-17-2013, 03:31 PM #85
TexasFreeAgent
 
 
TexasFreeAgent's Avatar
 
Join Date: Apr 2011
Location: Lubbock, Tx
TexasFreeAgent owns a Planet Eclipse Geo
TexasFreeAgent supports Team VICIOUS
TexasFreeAgent is an NCPA player
TexasFreeAgent plays in the APPA D5 division
Thanks for all of the info guys. I dont think I will be buying one until the get the first gen kinks out of the way.
__________________
This One Time At Band Camp.......
TexasFreeAgent is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 02-18-2013, 06:28 PM #86
Stan6543
 
 
Stan6543's Avatar
 
Join Date: Apr 2012
Location: Florida
Stan6543 plays in the PSP
Stan6543 owns a Planet Eclipse Geo
Stan6543 posts videos on PbNation
Stan6543 is one of the top 1000 posters on PbNation
Stan6543 is Legendary
Thanks for the help
Stan6543 is offline   Reply With Quote
Old 02-19-2013, 01:37 AM #87
jtguy2269
PL gun collector
 
jtguy2269's Avatar
 
Join Date: Mar 2003
Location: Big Sky, Montana
 has been a member for 10 years
Exalt didn't test this bolt on enough geo2's it seems like. Sounds like some geo2's are doing okay with these where other's aren't. I'll be staying away from this bolt until an updated version comes out... Or sell and by a geo3
__________________
intimidator owner for over a decade
  • Looking for:
  • Freeflow and shocktech markers
jtguy2269 is offline   Reply With Quote
Old 02-19-2013, 09:50 AM #88
Project Secret II
PR # 1 Seller/Trader
 
Project Secret II's Avatar
 
Join Date: Sep 2007
Location: P.R.
Annual Supporting Member
I agree. An official reaction from them will be good too.
__________________

eBay Feedback
Project Secret II is offline   Reply With Quote
Old 02-19-2013, 10:02 AM #89
96 Ls lnteg
Hola
 
96 Ls lnteg's Avatar
 
Join Date: Apr 2004
Location: San Diego
Annual Supporting Member
96 Ls lnteg is a Supporting Member
 has been a member for 10 years
96 Ls lnteg is a Paintball photographer
96 Ls lnteg owns a Planet Eclipse Geo
Anyone try different orings an see if the issues go away?
__________________
ProPaintball
Planet Eclipse
96 Ls lnteg is online now   Reply With Quote
Old 02-19-2013, 10:09 AM #90
jdpower
A.O.Y.T
 
jdpower's Avatar
 
Join Date: Oct 2005
Location: RI
jdpower owns a Planet Eclipse Geo
jdpower plays in the APPA D4 division
I replaced all the o-rings from my stock bolt to the exalt and had no full auto or any other issues. I never tried shooting with the exalt o-rings because it was just too tight in the can. I only shot about 10 pod's of old paint. Haven't played yet.
jdpower is offline   Reply With Quote
Old 02-19-2013, 10:10 AM #91
96 Ls lnteg
Hola
 
96 Ls lnteg's Avatar
 
Join Date: Apr 2004
Location: San Diego
Annual Supporting Member
96 Ls lnteg is a Supporting Member
 has been a member for 10 years
96 Ls lnteg is a Paintball photographer
96 Ls lnteg owns a Planet Eclipse Geo
Colored orings might be the culprit
__________________
ProPaintball
Planet Eclipse
96 Ls lnteg is online now   Reply With Quote
Old 02-19-2013, 10:11 AM #92
Project Secret II
PR # 1 Seller/Trader
 
Project Secret II's Avatar
 
Join Date: Sep 2007
Location: P.R.
Annual Supporting Member
I switch to pooty orings.
Didn't have a problem.
__________________

eBay Feedback
Project Secret II is offline   Reply With Quote
Old 02-19-2013, 10:14 AM #93
minimag03
 
 
minimag03's Avatar
 
Join Date: Aug 2004
Location: Bluefield, WV
 has been a member for 10 years
minimag03 is an NCPA player
minimag03 plays in the APPA D5 division
I'm guessing Exalt didn't use HNBR orings on the bolt where they are required. Switching the orings will probably help with the problem. But honestly, I'd try to get my money back from Exalt if I had bought one. It's not that Exalt hyped them up to sound like an upgrade, but they don't even work.
__________________
Old Feeback
minimag03 is offline   Reply With Quote
Old 02-19-2013, 10:18 AM #94
Project Secret II
PR # 1 Seller/Trader
 
Project Secret II's Avatar
 
Join Date: Sep 2007
Location: P.R.
Annual Supporting Member
Quote:
Originally Posted by minimag03 View Post
I'm guessing Exalt didn't use HNBR orings on the bolt where they are required. Switching the orings will probably help with the problem. But honestly, I'd try to get my money back from Exalt if I had bought one. It's not that Exalt hyped them up to sound like an upgrade, but they don't even work.
I tried to contact them but no luck.
__________________

eBay Feedback
Project Secret II is offline   Reply With Quote
Old 02-19-2013, 12:13 PM #95
I'm_Addicted
snowman FTW
 
I'm_Addicted's Avatar
 
Join Date: Mar 2005
Location: CT
I'm_Addicted owns a Planet Eclipse Geo
I'm_Addicted owns a Planet Eclipse Geo
I'm_Addicted owns a Planet Eclipse Geo
I'm having issues with bolt stick now...to the extent that the bolt won't even move at all. I did replace the orings with ones that came with my geo2. I think the issue may be the bolt tip, don't hold me to that though
I'm_Addicted is offline   Reply With Quote
Old 02-19-2013, 05:09 PM #96
Chrismeisterpmc
C-Nasty
 
Chrismeisterpmc's Avatar
 
Join Date: May 2011
Location: Missouri
Chrismeisterpmc owns a Planet Eclipse Geo
Chrismeisterpmc plays in the APPA D4 division
Quote:
Originally Posted by I'm_Addicted
I'm having issues with bolt stick now...to the extent that the bolt won't even move at all. I did replace the orings with ones that came with my geo2. I think the issue may be the bolt tip, don't hold me to that though
I had all the problems haha, that happened to me also. The bolt tip bent forward and would leak over and over. I replaced the o-rings with the stock bolts and still no fixing it. When I first started shooting it I had the full auto effect then I shot about 1000+ shots then it went to ****. So I put the stock bolt back in and threw the piece of crap exalt bolt somewhere in the bottom of my gear bag...you know with all the dirt and stuff haha. I would not recommend this bolt.
__________________
-Saints Army-
Chris Hale #19
Chrismeisterpmc is offline   Reply With Quote
Old 02-19-2013, 09:48 PM #97
Project Secret II
PR # 1 Seller/Trader
 
Project Secret II's Avatar
 
Join Date: Sep 2007
Location: P.R.
Annual Supporting Member
Quote:
Originally Posted by Chrismeisterpmc View Post
I had all the problems haha, that happened to me also. The bolt tip bent forward and would leak over and over. I replaced the o-rings with the stock bolts and still no fixing it. When I first started shooting it I had the full auto effect then I shot about 1000+ shots then it went to ****. So I put the stock bolt back in and threw the piece of crap exalt bolt somewhere in the bottom of my gear bag...you know with all the dirt and stuff haha. I would not recommend this bolt.
This sucks. The bolt does make the gun more consistent.

I just took the bolt out, putting my stock back in.
__________________

eBay Feedback
Project Secret II is offline   Reply With Quote
Old 02-20-2013, 03:06 PM #98
Project Secret II
PR # 1 Seller/Trader
 
Project Secret II's Avatar
 
Join Date: Sep 2007
Location: P.R.
Annual Supporting Member
Just an update:
I tried to give this bolt a last chance. I went to test the bolt again and after firing 20 or so shots the gun stopped from shooting. It also started to leak through the front and the bolt was all the way forward.

I put the stock bolt back in and the problem was gone.

This bolt version is definitively defective.
__________________

eBay Feedback
Project Secret II is offline   Reply With Quote
Old 02-20-2013, 03:53 PM #99
Chrismeisterpmc
C-Nasty
 
Chrismeisterpmc's Avatar
 
Join Date: May 2011
Location: Missouri
Chrismeisterpmc owns a Planet Eclipse Geo
Chrismeisterpmc plays in the APPA D4 division
Quote:
Originally Posted by Project Secret II
Just an update:
I tried to give this bolt a last chance. I went to test the bolt again and after firing 20 or so shots the gun stopped from shooting. It also started to leak through the front and the bolt was all the way forward.

I put the stock bolt back in and the problem was gone.

This bolt version is definitively defective.
Yeah that's what one of the problems I was talking about in my review, definately a defective product.
__________________
-Saints Army-
Chris Hale #19
Chrismeisterpmc is offline   Reply With Quote
Old 02-20-2013, 03:53 PM #100
96 Ls lnteg
Hola
 
96 Ls lnteg's Avatar
 
Join Date: Apr 2004
Location: San Diego
Annual Supporting Member
96 Ls lnteg is a Supporting Member
 has been a member for 10 years
96 Ls lnteg is a Paintball photographer
96 Ls lnteg owns a Planet Eclipse Geo
Very bad product
__________________
ProPaintball
Planet Eclipse
96 Ls lnteg is online now   Reply With Quote
Old 02-20-2013, 07:15 PM #101
Project Secret II
PR # 1 Seller/Trader
 
Project Secret II's Avatar
 
Join Date: Sep 2007
Location: P.R.
Annual Supporting Member
Quote:
Originally Posted by 96 Ls lnteg View Post
Very bad product
Yeah.
I'm returning mine.
__________________

eBay Feedback
Project Secret II is offline   Reply With Quote
Old 02-20-2013, 08:20 PM #102
jdpower
A.O.Y.T
 
jdpower's Avatar
 
Join Date: Oct 2005
Location: RI
jdpower owns a Planet Eclipse Geo
jdpower plays in the APPA D4 division
Is anyone not having issues with this bolt? I've shot over 1000 shot and tested again yesterday with no issues what so ever. Could it be just a bad batch and I'm one of the lucky one's?
jdpower is offline   Reply With Quote
Old 02-20-2013, 09:09 PM #103
Project Secret II
PR # 1 Seller/Trader
 
Project Secret II's Avatar
 
Join Date: Sep 2007
Location: P.R.
Annual Supporting Member
Quote:
Originally Posted by jdpower View Post
Is anyone not having issues with this bolt? I've shot over 1000 shot and tested again yesterday with no issues what so ever. Could it be just a bad batch and I'm one of the lucky one's?
At this rate, doubt it.
(J/k)
It will be good to hear from guys like I'm_Addicted, Funky Mo Fo (had a problem at first), ADOLF (had a problem at first too), BDidz (had a problem at first too), tranman, etc, they had no issues after testing.
__________________

eBay Feedback
Project Secret II is offline   Reply With Quote
Old 02-21-2013, 08:46 AM #104
I'm_Addicted
snowman FTW
 
I'm_Addicted's Avatar
 
Join Date: Mar 2005
Location: CT
I'm_Addicted owns a Planet Eclipse Geo
I'm_Addicted owns a Planet Eclipse Geo
I'm_Addicted owns a Planet Eclipse Geo
Quote:
Originally Posted by I'm_Addicted View Post
I'm having issues with bolt stick now...to the extent that the bolt won't even move at all. I did replace the orings with ones that came with my geo2. I think the issue may be the bolt tip, don't hold me to that though
Quote:
Originally Posted by Project Secret II View Post
At this rate, doubt it.
(J/k)
It will be good to hear from guys like I'm_Addicted, Funky Mo Fo (had a problem at first), ADOLF (had a problem at first too), BDidz (had a problem at first too), tranman, etc, they had no issues after testing.
I am having issues with the bolt now. I don't even have it in my gun anymore
I'm_Addicted is offline   Reply With Quote
Old 02-22-2013, 01:50 PM #105
jdpower
A.O.Y.T
 
jdpower's Avatar
 
Join Date: Oct 2005
Location: RI
jdpower owns a Planet Eclipse Geo
jdpower plays in the APPA D4 division
Just wondering if anyone was able to return the bad exalt launch bolts?
jdpower is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump