Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 01-03-2013, 11:03 PM #1
Red05gt
 
 
Join Date: Dec 2012
Location: College Station, Texas
Red05gt owns a Planet Eclipse Geo
Electra dx won't re-cock

Basically I air the gun up with an hpa tank, and reguardless or shooting mode it will drop the hammer and not reset itself. I put my hand to cover where the barrel screws in and it does move air although I have not tried shooting a ball through it. Pulled the lpr and the front piece and checked the orings. Any help greatly appreciated.
Red05gt is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 01-04-2013, 12:27 AM #2
Opteron-O3
Elite Spyder Owner
 
Opteron-O3's Avatar
 
Join Date: Feb 2005
Location: Garland, Texas
Opteron-O3 is a Supporting Member
Opteron-O3 posts videos on PbNation
Opteron-O3 is one of the top 1000 posters on PbNation
Have you taken the gun apart before? Kinda sounds like the valve is in backwards. If the gun has a regulator make sure the pressure is adequate 850psi if its stock.
__________________
New Feedback +57/-0
KUSA Feedback+18/-0
Old Feedback +70/-0
MacrolineGuy.com
Opteron-O3 is online now   Reply With Quote
Old 01-04-2013, 01:54 AM #3
Red05gt
 
 
Join Date: Dec 2012
Location: College Station, Texas
Red05gt owns a Planet Eclipse Geo
I haven't had it all apart. With it aired up pressure is right at the max of the green area on the gauge. I was trying to take it down but couldn't get the bolt out because I couldn't get the cocking piece to unscrew from it. How would one remove the valve and install it correctly?
Red05gt is offline   Reply With Quote
Old 01-04-2013, 08:54 PM #4
Opteron-O3
Elite Spyder Owner
 
Opteron-O3's Avatar
 
Join Date: Feb 2005
Location: Garland, Texas
Opteron-O3 is a Supporting Member
Opteron-O3 posts videos on PbNation
Opteron-O3 is one of the top 1000 posters on PbNation
Hmm... de gas the gun and try cleaning it. Make sure to check orings and lube the internals. Do this first and we will go from there.
__________________
New Feedback +57/-0
KUSA Feedback+18/-0
Old Feedback +70/-0
MacrolineGuy.com
Opteron-O3 is online now   Reply With Quote
Old 01-07-2013, 04:47 PM #5
Jdalty
Calls hit checks in Rec.
 
Jdalty's Avatar
 
Join Date: Apr 2011
Location: Massachusetts
Jdalty owns a Planet Eclipse Ego
Check your battery level.
Jdalty is offline   Reply With Quote
Old 01-10-2013, 11:16 PM #6
Red05gt
 
 
Join Date: Dec 2012
Location: College Station, Texas
Red05gt owns a Planet Eclipse Geo
I put a brand new batt. in it, got a schematic for the marker and took it down, cleaned, lubed, reassembled. One oversight I haven't thought of is does there need to be paint for it to function properly? I was dry firing it to check for leaks after fixing a leaky Asa. Feel dumb but would be thrilled if that's all it is.
Red05gt is offline   Reply With Quote
Old 01-10-2013, 11:24 PM #7
Opteron-O3
Elite Spyder Owner
 
Opteron-O3's Avatar
 
Join Date: Feb 2005
Location: Garland, Texas
Opteron-O3 is a Supporting Member
Opteron-O3 posts videos on PbNation
Opteron-O3 is one of the top 1000 posters on PbNation
Sometimes the marker needs paint in order for the marker properly, but that shouldn't be the case.

Is your velocity adjuster screw in all the way? If so, unscrew all the way off. Next check the regulator and tell me what reading it has. Next question, have you done any upgrades to the marker? Does it feel rather difficult to cock the marker back?
__________________
New Feedback +57/-0
KUSA Feedback+18/-0
Old Feedback +70/-0
MacrolineGuy.com
Opteron-O3 is online now   Reply With Quote
Old 01-10-2013, 11:32 PM #8
Red05gt
 
 
Join Date: Dec 2012
Location: College Station, Texas
Red05gt owns a Planet Eclipse Geo
I backed it all the way off when I was messing with the first time. It's not necessarily hard to cock per say. I don't have any air on hand right now to do much more trouble shooting but was gonna take it to play Saturday and see if I couldn't get it acting right. I want to say it was reading like 200 if memory served right.
Red05gt is offline   Reply With Quote
Old 01-11-2013, 06:48 AM #9
Opteron-O3
Elite Spyder Owner
 
Opteron-O3's Avatar
 
Join Date: Feb 2005
Location: Garland, Texas
Opteron-O3 is a Supporting Member
Opteron-O3 posts videos on PbNation
Opteron-O3 is one of the top 1000 posters on PbNation
If this is the older Electra then your pressure is too low. It needs to be around 800
__________________
New Feedback +57/-0
KUSA Feedback+18/-0
Old Feedback +70/-0
MacrolineGuy.com
Opteron-O3 is online now   Reply With Quote
Old 01-11-2013, 09:22 AM #10
Red05gt
 
 
Join Date: Dec 2012
Location: College Station, Texas
Red05gt owns a Planet Eclipse Geo
You're sure right. Somewhere between 750 and 800. Been playing with my impulse all day so 150-200 seemed about right.
Red05gt is offline   Reply With Quote
Old 01-11-2013, 10:01 AM #11
Opteron-O3
Elite Spyder Owner
 
Opteron-O3's Avatar
 
Join Date: Feb 2005
Location: Garland, Texas
Opteron-O3 is a Supporting Member
Opteron-O3 posts videos on PbNation
Opteron-O3 is one of the top 1000 posters on PbNation
Haha that's totally understandable
__________________
New Feedback +57/-0
KUSA Feedback+18/-0
Old Feedback +70/-0
MacrolineGuy.com
Opteron-O3 is online now   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump