Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 11-25-2012, 12:52 PM #1
iHeartzYou
<3
 
iHeartzYou's Avatar
 
Join Date: Jan 2012
Location: Atlanta
iHeartzYou is playing at Living Legends VII
iHeartzYou owns a Planet Eclipse Geo
iHeartzYou supports Team VICIOUS
iHeartzYou plays in the APPA D4 division
Question Need help, Cant Chrono over 280 with velocity all the way open

I recently got this ego 11 and its nice cosmetic condition. The doode i got it from said the gun was tech'd by PE not too long ago.....

Well anyways i shot it yesterday at the field and it shot like crap. At first it would not shoot over 250 then a buddy of mine go it to shoot around 270 -280 and this is with the velocity all the way open but very inconsistent. So what we tried was i put his ego reg into my ego and it shot great the velocity was hardly even out and it was 274, 272 and stayed like 1-2 points it was very consistent. When i put my reg back on it shot like crap again... ive cleaned the reg and made sure the orings in it don't have any knicks on it and lubed it up but it still does not shoot over 280 with the velocity open.......

Anyone have any ideas on how to fix this? im sure its a minor issue since i tried another reg on the ego and it worked fine. maybe my reg is bad? but it didnt look bad at all.
iHeartzYou is offline   Reply With Quote
Old 11-25-2012, 01:03 PM #2
Evil Rocky
 
 
Evil Rocky's Avatar
 
Join Date: Mar 2005
Evil Rocky is playing at Living Legends V
Evil Rocky owns a Planet Eclipse Ego
Evil Rocky owns a Planet Eclipse Ego
Try a brand new, name brand battery

Also change oring in reg and I always zero out the regs in my guns when I get a new gun, or after rebuild. So put reg at zero and then slowly start to adjust pressure.
__________________
CHICAGO DAMAGE INC
CPX, FOX, EMPIRE, PE
IOG http://www.pbnation.com/showthread.php?t=4067259
Evil Rocky is offline   Reply With Quote
Old 11-25-2012, 03:58 PM #3
iHeartzYou
<3
 
iHeartzYou's Avatar
 
Join Date: Jan 2012
Location: Atlanta
iHeartzYou is playing at Living Legends VII
iHeartzYou owns a Planet Eclipse Geo
iHeartzYou supports Team VICIOUS
iHeartzYou plays in the APPA D4 division
Quote:
Originally Posted by Evil Rocky View Post
Try a brand new, name brand battery

Also change oring in reg and I always zero out the regs in my guns when I get a new gun, or after rebuild. So put reg at zero and then slowly start to adjust pressure.
yea i tried the battery i but a Duracell in there brand new, I didnt have any new orings so ima try and rebuild the gun and put new orings throughout the gun.
iHeartzYou is offline   Reply With Quote
Old 11-25-2012, 11:00 PM #4
morolen
Lift Gamma Gain
 
morolen's Avatar
 
Join Date: Jun 2010
Location: Louisville, Colorado
morolen owns a Planet Eclipse Ego
Low velocity can be caused by several things, worn HPR or LPR piston seats or piston o-rings, low battery as well as rammer o-rings. Those are the places to look for issues.
__________________
H+

Hustle Paintball Video Goon
morolen is offline   Reply With Quote
Old 11-26-2012, 01:44 PM #5
MeŠiCX
Boneyard Paintball
 
MeŠiCX's Avatar
 
Join Date: Nov 2006
Location: Plymouth, WI
Annual Supporting Member
MeŠiCX owns a Planet Eclipse Etha
MeŠiCX owns a Planet Eclipse GSL
Replace the #008 NBR70 oring inside the reg adjuster top (refer to page 12 of your manual), replace the #016 NBR70 reg piston oring and replace the regulator seal. Lightly grease those two orings and you should be back in business.
MeŠiCX is offline   Reply With Quote
Old 11-29-2012, 07:37 PM #6
iHeartzYou
<3
 
iHeartzYou's Avatar
 
Join Date: Jan 2012
Location: Atlanta
iHeartzYou is playing at Living Legends VII
iHeartzYou owns a Planet Eclipse Geo
iHeartzYou supports Team VICIOUS
iHeartzYou plays in the APPA D4 division
Quote:
Originally Posted by MeŠiCX View Post
Replace the #008 NBR70 oring inside the reg adjuster top (refer to page 12 of your manual), replace the #016 NBR70 reg piston oring and replace the regulator seal. Lightly grease those two orings and you should be back in business.
Quote:
Originally Posted by morolen View Post
Low velocity can be caused by several things, worn HPR or LPR piston seats or piston o-rings, low battery as well as rammer o-rings. Those are the places to look for issues.
So i gave my buddy the gun to look at, and he said it was the exhaust port, it wad clogged. But thanks for input guys. Im glad i got the gun fixed
iHeartzYou is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump