Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 11-10-2012, 10:01 PM #1
Willd721
 
 
Join Date: Sep 2012
DM7 Bolt Reset Issue

I'm sure this has been discussed in far back threads but I haven't seen any recent questions.

I am having an issue with a DM7 that I recently purchased from a friend where the bolt does not cycle properly without paint in it. I'm running the gun at around 125/90 psi and when I dry fire it in single shot the bolt cycles naturally. However when it is fired rapidly the bolt either sticks forward and leaks air down the front or only partially cycles back. As it sits right now I can consistently shoot 285 with single shots and lay ropes downfield, but don't have measuring for rapid-fire velocity. It has a virtue board with a new battery and I just replaced the top hat o-ring as well as the bolt sail o-ring. Any advice is greatly appreciated as I am just now entering the Dye family.

Thanks
Willd721 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 11-10-2012, 10:30 PM #2
nique303 (Banned)
 
Join Date: Nov 2008
Location: COLORADO
sounds like a LPR issue screw it all the way in and back it out while dry firing it , do this until you get it to fully cycle when shooting rapidly.

info that should help you ~
http://www.pbnation.com/showthread.php?t=3287241

Last edited by nique303 : 11-10-2012 at 10:43 PM.
nique303 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump