Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 10-11-2012, 08:51 PM #1
MZinCamo
PaintcheckPB
 
MZinCamo's Avatar
 
Join Date: Feb 2011
Location: Illinois
MZinCamo plays in the PSP
MZinCamo is playing at Living Legends VI
MZinCamo posts videos on PbNation
MZinCamo is All In
Help.

I need some serious help.

My Droid has been acting up again.

I pressure tested it and set it up at 100psi, the dwell and settings at stock. Starts off at 230 FPS.

I raise the dwell until I'm at 280, my dwell is at 20!

I don't like this at all...any idea? I reset the board same thing, should I just deal with a higher pressure on the reg or should I just deal with higher dwell?
__________________
Follow Team BOOM on Facebook
| Empire Paintball | Blast Camp |

PAINTCHECKPB
PODKA
MZinCamo is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 10-11-2012, 10:26 PM #2
SHOOTNPOO
MACDEV MASTER US TECH
 
SHOOTNPOO's Avatar
 
Join Date: Mar 2008
SHOOTNPOO works for a Paintball manufacturer
SHOOTNPOO plays in the USPL
SHOOTNPOO posts videos on PbNation
Well the higher pressure would be around 110 for 280 correct?
SHOOTNPOO is offline   Reply With Quote
Old 10-11-2012, 11:48 PM #3
xmagman
MacDev Militia
 
xmagman's Avatar
 
Join Date: Sep 2004
Location: Tropical Arkansas
 has been a member for 10 years
xmagman supports Team VICIOUS
xmagman is for the Gunfight
xmagman has achieved Level 1 in PbNation Pursuit
Are the springs in the regulator is this order )()()()(

I had a similar issue and having the reg springs incorrect was the culprit.
__________________
-X

MacDev Clone GTi
MacDev Droid

Shooting MacDev guns since 2006!

Ryukyu Kings Paintball Team
xmagman is offline   Reply With Quote
Old 10-12-2012, 07:01 AM #4
MZinCamo
PaintcheckPB
 
MZinCamo's Avatar
 
Join Date: Feb 2011
Location: Illinois
MZinCamo plays in the PSP
MZinCamo is playing at Living Legends VI
MZinCamo posts videos on PbNation
MZinCamo is All In
I'll check my reg shims later but I know I made sure to put them in that way.

For 280 on 12 dwell the pressure has to be around 120.
__________________
Follow Team BOOM on Facebook
| Empire Paintball | Blast Camp |

PAINTCHECKPB
PODKA
MZinCamo is offline   Reply With Quote
Old 10-12-2012, 08:56 AM #5
SHOOTNPOO
MACDEV MASTER US TECH
 
SHOOTNPOO's Avatar
 
Join Date: Mar 2008
SHOOTNPOO works for a Paintball manufacturer
SHOOTNPOO plays in the USPL
SHOOTNPOO posts videos on PbNation
That is not too bad but chexk the power tube orings and the valve orings for fitment. I bet you will find one of these to be loose causing you to raise your internal pressure.
SHOOTNPOO is offline   Reply With Quote
Old 10-12-2012, 04:45 PM #6
FOOL
N.O. Bounty
 
FOOL's Avatar
 
Join Date: Jul 2001
Location: Metairie La.
Annual Supporting Member
FOOL is a founding member
 has been a member for 10 years
FOOL plays in the PSP
FOOL posts videos on PbNation
FOOL plays in the APPA D4 division
Quote:
Originally Posted by SHOOTNPOO View Post
That is not too bad but chexk the power tube orings and the valve orings for fitment. I bet you will find one of these to be loose causing you to raise your internal pressure.
^
__________________

Macdev Militia
FOOL is offline   Reply With Quote
Old 10-12-2012, 05:36 PM #7
MZinCamo
PaintcheckPB
 
MZinCamo's Avatar
 
Join Date: Feb 2011
Location: Illinois
MZinCamo plays in the PSP
MZinCamo is playing at Living Legends VI
MZinCamo posts videos on PbNation
MZinCamo is All In
I'm going to check the powertube and valve, the reg is fine.

I should have said I have the XXX bolt as well.
__________________
Follow Team BOOM on Facebook
| Empire Paintball | Blast Camp |

PAINTCHECKPB
PODKA
MZinCamo is offline   Reply With Quote
Old 10-13-2012, 11:07 AM #8
SHOOTNPOO
MACDEV MASTER US TECH
 
SHOOTNPOO's Avatar
 
Join Date: Mar 2008
SHOOTNPOO works for a Paintball manufacturer
SHOOTNPOO plays in the USPL
SHOOTNPOO posts videos on PbNation
I would say if u have the stock bolt, swap it back into the marker prior to changing anything and see if you are having an issue with the bolt. But I would definitely say the power tube orings and Valve orings are to blame.
SHOOTNPOO is offline   Reply With Quote
Old 10-13-2012, 03:53 PM #9
MZinCamo
PaintcheckPB
 
MZinCamo's Avatar
 
Join Date: Feb 2011
Location: Illinois
MZinCamo plays in the PSP
MZinCamo is playing at Living Legends VI
MZinCamo posts videos on PbNation
MZinCamo is All In
I haven't gotten around to checking yet, but I don't have the stock bolt. I wish I had a gold bolt but I don't, sadly lol.
__________________
Follow Team BOOM on Facebook
| Empire Paintball | Blast Camp |

PAINTCHECKPB
PODKA
MZinCamo is offline   Reply With Quote
Old 10-13-2012, 10:05 PM #10
MZinCamo
PaintcheckPB
 
MZinCamo's Avatar
 
Join Date: Feb 2011
Location: Illinois
MZinCamo plays in the PSP
MZinCamo is playing at Living Legends VI
MZinCamo posts videos on PbNation
MZinCamo is All In
So I sat down and fitted some orings, got the pressure down about 10 psi by doing that. Now I have a different problem though.

It's leaking from the noid.

I tried the typical fixes, ie powertube orings and bolt sail.

No luck.

Continuous leak.

I don't know if it's the manifold seal or not.

Anyone here hand fit orings for pay haha? I'm so sick of this.
__________________
Follow Team BOOM on Facebook
| Empire Paintball | Blast Camp |

PAINTCHECKPB
PODKA

Last edited by MZinCamo : 10-13-2012 at 10:09 PM.
MZinCamo is offline   Reply With Quote
Old 10-13-2012, 10:52 PM #11
Mark S.
CHOWDAH
 
Mark S.'s Avatar
 
Join Date: May 2009
Location: NH
Mark S. works for a Paintball manufacturer
Mark S. plays in the APPA D4 division
Check your valve for cracks. Do you have the v3 valve? Remove the o-rings and check for cracks where they sit...they sometimes can crack if the marker was overpressurized at some point. A cracked valve could definitely cause a leak from that area and cause that WTF moment where everything looks fine but it still leaks.
Mark S. is offline   Reply With Quote
Old 10-13-2012, 11:10 PM #12
MZinCamo
PaintcheckPB
 
MZinCamo's Avatar
 
Join Date: Feb 2011
Location: Illinois
MZinCamo plays in the PSP
MZinCamo is playing at Living Legends VI
MZinCamo posts videos on PbNation
MZinCamo is All In
I'll check the valve tommorrow but when I inspected it it appeared fine. I changed a loose oring on it perhaps that was it.

I'm really dissapointed because it's a 1 of 10 dust black, and it shoots great all the time...first problem is today


It shall be fixed!
__________________
Follow Team BOOM on Facebook
| Empire Paintball | Blast Camp |

PAINTCHECKPB
PODKA
MZinCamo is offline   Reply With Quote
Old 10-14-2012, 01:18 PM #13
MZinCamo
PaintcheckPB
 
MZinCamo's Avatar
 
Join Date: Feb 2011
Location: Illinois
MZinCamo plays in the PSP
MZinCamo is playing at Living Legends VI
MZinCamo posts videos on PbNation
MZinCamo is All In
Valve orings didn't change it.

I'm lost.
__________________
Follow Team BOOM on Facebook
| Empire Paintball | Blast Camp |

PAINTCHECKPB
PODKA
MZinCamo is offline   Reply With Quote
Old 10-14-2012, 01:49 PM #14
seriouslysilly
 
 
seriouslysilly's Avatar
 
Join Date: Dec 2009
Location: East coast
seriouslysilly owns a Planet Eclipse Ego
seriouslysilly owns a Planet Eclipse Lv1
seriouslysilly posts videos on PbNation
seriouslysilly has achieved Level 3 in PbNation Pursuit
did you do the suction test on the valve?
seriouslysilly is offline   Reply With Quote
Old 10-14-2012, 01:57 PM #15
SHOOTNPOO
MACDEV MASTER US TECH
 
SHOOTNPOO's Avatar
 
Join Date: Mar 2008
SHOOTNPOO works for a Paintball manufacturer
SHOOTNPOO plays in the USPL
SHOOTNPOO posts videos on PbNation
You can see by doing the blow suck test on Valve and bolt to see if its cracked as stated above. Or another option is to send into us here we can test and verify the issue along with repair for you.

Eric
SHOOTNPOO is offline   Reply With Quote
Old 10-14-2012, 02:21 PM #16
frankie says chillax
...bro
 
frankie says chillax's Avatar
 
Join Date: Dec 2011
frankie says chillax plays in the PSP
frankie says chillax plays in the APPA D4 division
take engine out

- pull bolt forward and cover the air hole at the front of the keg. at the same time push the bolt down. it should snap back up every time.
if not, change the bolt sail or front bolt keg oring

- now put the bolt back and cover the rear bolt keg hole. at the same time, pull the bolt out. it should snap back in every time completely. if not, check the red joiner's inner oring and bolt sail

- -take your thumb and cover the face of the bolt and pull it outward at the same time. your thumb should be getting sucked into it. if not, check the powertube orings.

all of these need to glide freely. bolt should move with a slight flick of the wrist when fully assembled but the rings still need to maintain a proper seal.


with all these seals properly fitted and lubed with militia lube, you'll have a great performing droid with little to no need for repair thru the season
__________________
"Originally posted by blueshifty:
Also, eclipse only makes mid-range guns they just charge a premium for them."

WTB MINTY FRESH MACDEV 07 CYBORGS
frankie says chillax is offline   Reply With Quote
Old 10-14-2012, 02:31 PM #17
MZinCamo
PaintcheckPB
 
MZinCamo's Avatar
 
Join Date: Feb 2011
Location: Illinois
MZinCamo plays in the PSP
MZinCamo is playing at Living Legends VI
MZinCamo posts videos on PbNation
MZinCamo is All In
I will give one more shot on testing, changed every o ring twice and still leaks but no visible cracks on valve. I'll try once more and then I'll probably send it off for repair lol.
__________________
Follow Team BOOM on Facebook
| Empire Paintball | Blast Camp |

PAINTCHECKPB
PODKA
MZinCamo is offline   Reply With Quote
Old 10-14-2012, 02:59 PM #18
MZinCamo
PaintcheckPB
 
MZinCamo's Avatar
 
Join Date: Feb 2011
Location: Illinois
MZinCamo plays in the PSP
MZinCamo is playing at Living Legends VI
MZinCamo posts videos on PbNation
MZinCamo is All In
I give up, I've tried everything I knew and everything you all knew...time to send it to the pros
__________________
Follow Team BOOM on Facebook
| Empire Paintball | Blast Camp |

PAINTCHECKPB
PODKA
MZinCamo is offline   Reply With Quote
Old 10-17-2012, 06:24 PM #19
MZinCamo
PaintcheckPB
 
MZinCamo's Avatar
 
Join Date: Feb 2011
Location: Illinois
MZinCamo plays in the PSP
MZinCamo is playing at Living Legends VI
MZinCamo posts videos on PbNation
MZinCamo is All In
Little update-

Manifold orings changed, leak significantly reduced. Still a small leak, tried replacing the powertube oring tip, bolt sail, and valve orings. Still there, but very minor now.

Any ideas?
__________________
Follow Team BOOM on Facebook
| Empire Paintball | Blast Camp |

PAINTCHECKPB
PODKA
MZinCamo is offline   Reply With Quote
Old 10-17-2012, 06:39 PM #20
Mark S.
CHOWDAH
 
Mark S.'s Avatar
 
Join Date: May 2009
Location: NH
Mark S. works for a Paintball manufacturer
Mark S. plays in the APPA D4 division
It's always possible the noid has a small leak, also it can be very tough to see a hairline crack in the valve. If you've gone through all the o-rings then unfortunately it's going to be tricky without having any spare parts to swap out and re-test. Do you know anyone else with a Droid?
Mark S. is offline   Reply With Quote
Old 10-17-2012, 07:22 PM #21
MZinCamo
PaintcheckPB
 
MZinCamo's Avatar
 
Join Date: Feb 2011
Location: Illinois
MZinCamo plays in the PSP
MZinCamo is playing at Living Legends VI
MZinCamo posts videos on PbNation
MZinCamo is All In
Yes, my good friend has a droid. So I'm waiting for him right now, we are gonna swap drivetrains and see if that is the problem.

The reason I find it interesting is because it spontaneously started and the manifold orings reduced the leak significantly.
__________________
Follow Team BOOM on Facebook
| Empire Paintball | Blast Camp |

PAINTCHECKPB
PODKA
MZinCamo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump