Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 08-29-2012, 12:44 AM #1
kwai
 
 
Join Date: Aug 2012
ape rampage problem for phenom

question 1:just got a ape rampage board for my phenom. install it and it shoot when i'm on safety with the fang trigger. with stock trigger it doesnt do that.

question 2: one more thing. when i set it on 3 burst or any other firing mode beside single and true full auto it get stuck when i press the trigger more then 3 time and keep firing. i got to press again hard so it will get loose again. i took it apart 3 time still got the same problem. no wire is stuck or getting squeeze. i cut more of the plastic to get the trigger switch open. still got the same probelm. can someone please help.

i even try calling techt. they just avoid me.
kwai is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 08-29-2012, 06:28 PM #2
tonycon
Knuckleheads Paintball
 
tonycon's Avatar
 
Join Date: Mar 2010
Location: Chi-Town
Annual Supporting Member
tonycon owns a Planet Eclipse Geo
tonycon owns a Planet Eclipse Ego
tonycon owns a Planet Eclipse Lv1
tonycon supports our troops
tonycon is Legendary
tonycon owns a Planet Eclipse GSL
You may need to move the trigger sensors on the board closer/farther away and see if that helps. Try calling ape....techt doesn't make boards!
__________________
Swamp SLS-whitebrown CSL-Midnight/Poison LV1 Pure/Prestige GSL

Proudly Sponsored By:
PBExplosion VirtueSpire Valken Paintball

KnuckleHeads Paintball Team
Game footage
tonycon is online now   Reply With Quote
Old 08-29-2012, 09:14 PM #3
kwai
 
 
Join Date: Aug 2012
i'm running the stock trigger cause my ak74u. the fang trigger dont support the mag.

Last edited by kwai : 09-06-2012 at 02:04 AM.
kwai is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump