Find fields & stores near you!
Find fields and stores
PbNation News
PbNation News
Community Focus
Community Focus

Thread Tools
Old 08-22-2012, 02:55 PM #1
gmaselli's Avatar
Join Date: Mar 2012
Location: The Tar Heel State.
gmaselli owns a Planet Eclipse Ego
gmaselli has achieved Level 1 in PbNation Pursuit
Trouble with an Ion...

Hey guys
I honestly dont know whats wrong with my ion.....
Just two weeks ago i paid someone $50.00 to fix it and now its not working right. What will happen is ill be shooting then instead of the paintballs going the normal distance, They will only go a few feet sometimes even roll out of the barrel! It's almost like the tank ran out of air but my tank is full! If you need further details for it just say so.....

Black River Paintball
gmaselli is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Old 08-22-2012, 08:29 PM #2
Join Date: May 2012
Make sure the tank is screwed in all the way. Check the dwell and make sure it's up enough. Try rebuilding the reg.
bobbybowman90 is offline   Reply With Quote
Old 08-23-2012, 07:28 AM #3
Syphorus's Avatar
Join Date: Sep 2005
 has been a member for 10 years
Bring all your board settings back to stock and see if it fires properly.
PBShiFu Youtube Channel
Syphorus is offline   Reply With Quote
Old 08-23-2012, 11:49 AM #4
ijinxd's Avatar
Join Date: Jan 2010
Location: California
ijinxd owns a Planet Eclipse Ego
ijinxd has perfected Level 1 in PbNation Pursuit
ijinxd has achieved Level 3 in PbNation Pursuit
ijinxd supports DLX Technology
Essentially what everyone suggested. Stock board settings, check your reg (make sure there's enough pressure to push out the paint), and thread in the tank more, if possible.
ijinxd is offline   Reply With Quote

Thread Tools

Posting Rules
Forum Jump