Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 07-16-2012, 05:47 PM #1
tacpiztols
Eman
 
tacpiztols's Avatar
 
Join Date: Mar 2012
Location: La Mirada
tacpiztols owns a Planet Eclipse Etek
tacpiztols has achieved Level 1 in PbNation Pursuit
tacpiztols has perfected Level 1 in PbNation Pursuit
tacpiztols is attending Decay of Nations VI
Etek 3 Cure bolt O ring problem

Hey guys,

so im firing my Etek 3 LT in my backyard, and i take a shot, and nothing comes out, i take another shot and nothing comes out again, i see air come out but no ball is going forward. I pull out the pooty moded cure 4 bolt, and see that the double o-rings right behind the face of the bolt are gone and stuck in the breech. I retrieve them and put them back on. Before I test fired, I pulled out the bolt and lubed all the orings that were on the bolt, this also happened to me last saturday when i first tried to chrono, i needed to replace my o-rings again, any reason why the o-rings are coming off of the bolt? Also, if I lose these O-rings, what size are the o-rings that belong on the cure 4 bolt?
__________________
My Ebay Feedback

Tippmann 98 Custom with CP Barrel

CCI Phantom under construction
tacpiztols is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 07-17-2012, 04:39 AM #2
Nicky T
Eclipse Customer Service
 
Nicky T's Avatar
 
Join Date: Mar 2003
Location: Planet, Manchester
Annual Supporting Member
 has been a member for 10 years
Nicky T works for a Paintball manufacturer
Nicky T supports Bob Gurnsey
Without seeing the modified bolt there is no way of saying.

The size for these o-rings is 015 NBR 70.

Nicky T
__________________
Any feedback is always welcome. Email me at nick.t@planeteclipse.com with your comments.

Follow me on Twitter: https://twitter.com/NickyTruter
Nicky T is offline   Reply With Quote
Old 01-27-2013, 02:51 PM #3
amesago91
 
 
Join Date: Aug 2012
Im Having The Same Problem With An Ego 10, I Upgraded The Bolt To The Cure 4 And Those 2 Orings Keep Coming Out Of The Marker Every 50+ Shots Aprox.

Did You Solve It Already ? Does Anyone Know How To Fix This ?
amesago91 is offline   Reply With Quote
Old 01-27-2013, 02:57 PM #4
Mason74
 
 
Mason74's Avatar
 
Join Date: Dec 2012
Location: Charlotte, NC
Mason74 owns a Planet Eclipse Etek
Mason74 supports Team VICIOUS
Mason74 is for the Gunfight
Mason74 has perfected Level 1 in PbNation Pursuit
Quote:
Originally Posted by amesago91 View Post
Im Having The Same Problem With An Ego 10, I Upgraded The Bolt To The Cure 4 And Those 2 Orings Keep Coming Out Of The Marker Every 50+ Shots Aprox.

Did You Solve It Already ? Does Anyone Know How To Fix This ?
I know this may seem redundant, but check with pooty paintball directly, my guess is that probably may know the fix, or it's likely they have heard of this problem, and may know the solution. Whereas here, u have to hope that someone already has had the problem...

I know it defeats the purpose of the forum, but if u could then post their answer that would be awesome.
Mason74 is offline   Reply With Quote
Old 01-31-2013, 02:53 PM #5
abenguyen
Abe Na-Goo-Yen
 
abenguyen's Avatar
 
Join Date: Jun 2008
Location: DFW, TX
abenguyen owns a Planet Eclipse Geo
abenguyen owns a Planet Eclipse Geo
abenguyen posts videos on PbNation
abenguyen plays in the APPA beginner division
abenguyen supports DLX Technology
I would check your detents and clean your breach out. Afterwards, place one drop of oil in each detent slot. That could be the source of your problems.
abenguyen is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump