Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 06-25-2012, 06:02 AM #1
dose55
 
 
dose55's Avatar
 
Join Date: Mar 2011
Vanguard Demon Help

Just got my brand new 2012 demon and took it to the field yestarday to play a tournament.

Didn't made any change to the board settings and didn't relubed the bolt as it was well lubbed from factory.

At first I had some trouble getting the fps above 265 but I increased the dwell from 15ms to about 17.5ms and was able to get to the 275-280.

Played all day without any problems but at the end fo the day the gun stopped cycling and only makes a puff noise when I shoot it and vents air from the top grip / lower body area.

Since the gun is new to me can anyone guide me to what I need to inspect in order to solve the problem?

Thks!
dose55 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 06-25-2012, 07:41 AM #2
boodahfinger
 
 
Join Date: Jan 2011
Sounds like QEV problem. When I got my Demon it worked right the first day of play but the second time I took it out it was having the problem you described. I replaced the QEV and it worked fine again.
boodahfinger is offline   Reply With Quote
Old 06-25-2012, 11:07 PM #3
Reaper (ACI)
We're Weird
 
Reaper (ACI)'s Avatar
 
Join Date: Apr 2008
Location: Beaverton, OR
Reaper (ACI) works for a Paintball manufacturer
Reaper (ACI) donated to help Peyton Trent
Reaper (ACI) is for the Gunfight
Reaper (ACI) is for the Gunfight
It does sound like the QEV diaphragm as boodah said. Reset the diaphragm and let us know if that fixes the problem.
__________________
VANGUARD CERTIFIED MASTER TECH
Dead Box Sports
West Coast Parts, Service, Warranty, and Distribution
www.deadboxsports.com

I have LEGO Paintballer Mini Figs
Reaper (ACI) is offline   Reply With Quote
Old 07-04-2012, 06:26 AM #4
dose55
 
 
dose55's Avatar
 
Join Date: Mar 2011
Thanks for all the answers.

Haven't got the time do strip the gun down but I relubed the bolt and at least the leak is gone and the gun worked ok.

I'll try to do some more detailed tests this weekend and let you know the results.
dose55 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump