Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 05-07-2012, 01:25 PM #1
ybekool
 
 
ybekool's Avatar
 
Join Date: Jan 2010
Location: Joliet
Annual Supporting Member
ybekool plays in the PSP
ybekool owns a Planet Eclipse Geo
ybekool supports Team VICIOUS
ybekool plays in the APPA D4 division
Geo 2.1 problem

Hey guys, I know quite a bit about the platform, but this problem is still stumping me. At a regional tourney yesterday, after firing a few shots, my 2.1 went crazy. If anyone knows how a gun with a worn down sear sounds, that's basically how it sounds. This happened multiple times over the course of the day, even after switching to 2 different tanks.

Any help would be greatly appreciated.

I use monkey poo on the bolt and dow 33 on the reg, and a 2011 ninja 70/4500 with all shims in.
ybekool is offline   Reply With Quote
Old 10-08-2012, 02:39 PM #2
helipad14399
 
 
helipad14399's Avatar
 
Join Date: Nov 2011
Geo 2.1 Problem

My friend had this problem with his Geo 2. Try lowering your dwell down 1 full stop (ex. from 12.5 to 11.5). If that doesn't work then try re-lubing both o-rings on the bolt cap. If all fails then the screw on the bolt cap that connects to the propshaft should be tightened.
helipad14399 is offline   Reply With Quote
Old 10-08-2012, 06:23 PM #3
ybekool
 
 
ybekool's Avatar
 
Join Date: Jan 2010
Location: Joliet
Annual Supporting Member
ybekool plays in the PSP
ybekool owns a Planet Eclipse Geo
ybekool supports Team VICIOUS
ybekool plays in the APPA D4 division
I got it fixed a long while ago, sorry for not updating the thread.
It ended up being the Ball check spring in the solenoid.
ybekool is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump