Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 04-30-2012, 06:25 AM #1
Hammersmith
O&A Party Rock!
 
Hammersmith's Avatar
 
Join Date: May 2002
Location: Budd Lake, NJ
 has been a member for 10 years
Droid Problem

Played this weekend and out of the blue my Droid seemed to be starving for air every 30-40 shots.

The bolt would cycle slightly and load multiple balls into the barrel and then it wouldn't cycle at all. I would have to unscrew the ASA and then screw it back in to get it to work again for a short period of time.

I'm running the stock reg, stock bolt, with a Tadao board. Battery was brand new but I was changed after this started just to be sure.

Thought that maybe it was my tank so I tried a different one but the result was the same.

Drivetrain was well lubed and all the o-rings are in good shape with no leaks.

I pulled the reg apart when I got home and it seemed a little dry so it's been relubed but I don't have any air yet to test it with but I know that these regs have been suspect in the past but I never had a problem so I never changed it out.

Any thoughts?
__________________
Freaks of Nature
Generation Paintball
J&J Performance
Atlas Paintball Park
R7
OSK
Hammersmith is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 04-30-2012, 06:27 AM #2
Hammersmith
O&A Party Rock!
 
Hammersmith's Avatar
 
Join Date: May 2002
Location: Budd Lake, NJ
 has been a member for 10 years
The only thing different about this weekend was that it was lubed with Marmalade. I had a tub of it and was out of everything else.
__________________
Freaks of Nature
Generation Paintball
J&J Performance
Atlas Paintball Park
R7
OSK
Hammersmith is offline   Reply With Quote
Old 04-30-2012, 06:56 AM #3
JR007
 
 
Join Date: Dec 2011
I'd put $$ on the reg. Make sure nothing is over-lubed.
JR007 is offline   Reply With Quote
Old 04-30-2012, 08:31 AM #4
blueshifty
RIP: Underĝath
 
blueshifty's Avatar
 
Join Date: Jun 2006
Location: Dallas, TX
Sounds like the reg was sticking, so that should fix it but I'd get some different lube while your at it.
__________________
Feedback: Old (+4)
blueshifty is offline   Reply With Quote
Old 04-30-2012, 09:06 AM #5
blame it on god
Rotten to the core
 
blame it on god's Avatar
 
Join Date: Sep 2007
Location: Miami, FL.
blame it on god has achieved Level 1 in PbNation Pursuit
"Drivetrain was well lubed."

That is your problem. The o-rings should only look wet.
__________________
MACDEV
blame it on god is offline   Reply With Quote
Old 04-30-2012, 09:15 AM #6
Shooter28
PEACE
 
Shooter28's Avatar
 
Join Date: Jul 2007
Location: CENTRAL FLORIDA
Shooter28 plays in the PSP
Shooter28 supports DLX Technology
Shooter28 supports Empire
It's the marbalaid. Its good for regs, but not the drive train. Use something like sl33k or any dow33 really(gold cup, militia lube, monkey Poo). And you don't need to make it "well lubed", only need enough to make the orings look wet.

Personally I use militia lube on the valve, monkey Poo on the bolt sail, and sleek on everything else.
__________________
Rebel.Renegade. Must stay paid.
sh(-Ĥ-)ker Owners v.LXII
Macdev
ΞΞ

R.I.P.{HSP}
Gun Sale Thread | SHOCKER PARTS!!! | My gun collection | D00M.
Shooter28 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump