Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 11-30-2013, 10:50 AM #1
chaibill
 
 
Join Date: Apr 2008
Location: Eastern Long Island, NY
Need help tm7 not turning on.

So I have a tm7 that was turning on. Now its not turning on. Tried different 9vbatteries nothing happens.
Is there issues with the boards?
__________________
i have ion thread J&J barrel backs to trade.
Need eastern Long Island players Sunday woods ball
Nib hammer pump for trade.
Lapco t8 t9 barrel 14 inch for sale.
Mini parts stock ASA ,stock bolt. Color kits black or bronze green. Pm me with mini parts.
chaibill is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 11-30-2013, 02:21 PM #2
Slo poke
 
 
Slo poke's Avatar
 
Join Date: Jun 2011
Location: Hot Azz AZ
Do you do anything to it before it stopped working?
Slo poke is offline   Reply With Quote
Old 11-30-2013, 08:27 PM #3
chaibill
 
 
Join Date: Apr 2008
Location: Eastern Long Island, NY
No just put in new battery
__________________
i have ion thread J&J barrel backs to trade.
Need eastern Long Island players Sunday woods ball
Nib hammer pump for trade.
Lapco t8 t9 barrel 14 inch for sale.
Mini parts stock ASA ,stock bolt. Color kits black or bronze green. Pm me with mini parts.
chaibill is offline   Reply With Quote
Old 12-01-2013, 10:45 AM #4
Slo poke
 
 
Slo poke's Avatar
 
Join Date: Jun 2011
Location: Hot Azz AZ
Might sound dumb, but did you put your battery in right? And are you using a good quality battery?
Slo poke is offline   Reply With Quote
Old 12-05-2013, 12:03 PM #5
chaibill
 
 
Join Date: Apr 2008
Location: Eastern Long Island, NY
Yes yes
__________________
i have ion thread J&J barrel backs to trade.
Need eastern Long Island players Sunday woods ball
Nib hammer pump for trade.
Lapco t8 t9 barrel 14 inch for sale.
Mini parts stock ASA ,stock bolt. Color kits black or bronze green. Pm me with mini parts.
chaibill is offline   Reply With Quote
Old 12-10-2013, 08:07 PM #6
TheEnglishGuy
 
 
Join Date: Nov 2008
If you took apart your marker at all then possibly the wires got pinched. Alternatively maybe the small white connector became disconnected. I'd recommend opening it up and tracing the wires to make sure they're all plugged in.

English
TheEnglishGuy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump