Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 06-23-2016, 02:48 PM #1
CrazyDrift500
 
 
Join Date: Jun 2016
Location: Margate Florida
Empire Axe won't fire.

I've had my axe for many years, and never had an issue. Recently it started acting up by not firing until the 4-5th trigger pull. The gun is on, ball in the chamber, and when I pull the trigger nothing. After I pull it several times it will fire. Sometimes only the bolt will move without any air pressure to shoot the ball. Then the next trigger pull it will fire. Anyone have any experience with this issue or have any suggestions? Anything is much appreciated.
CrazyDrift500 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 06-24-2016, 09:12 AM #2
sdzell18
Code it and Load it
 
Join Date: Oct 2005
Location: CA, NJ
sdzell18 works for a Paintball manufacturer
 plays in the NXL
sdzell18 plays in the APPA Pro division
sdzell18 is All In
This is common. You just need to clean the solenoid. Guides on how to do so are in the forum or paintballsolutions.com. Also make sure you are using a fresh, brand name alkaline battery.
__________________
Jamie Ezell - Electronics Engineer @ GI Sportz
Empire Paintball
JT Paintball
My Feedback +43, -0
sdzell18 is offline   Reply With Quote
Old 06-24-2016, 12:18 PM #3
CrazyDrift500
 
 
Join Date: Jun 2016
Location: Margate Florida
Awesome thank you.
CrazyDrift500 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump