Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Closed Thread
 
Thread Tools
Old 11-22-2012, 06:58 AM #1198
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by ijinxd View Post
Just picked up an 07 Ego and I'm trying to adjust the trigger. Does anyone know which allen key (size) is required to adjust trigger travel?
Depending on the trigger it is either .050 or 1/16
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old Sponsored Links Remove Advertisement
Advertisement
Old 11-22-2012, 06:59 AM #1199
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by Jeffro2287 View Post
Bill,

Just brought out my Ego6 and am having trouble with the trigger getting stuck on the back of the trigger frame. It is acting like there is paint stuck somewhere in the trigger, but i took it apart as much as i could and it is all clean. Another way to describe it is when i pull the trigger, it takes a good full 1-2 seconds for it to release back out to be fired again. Thanks for anything
Take the trigger completely out and clean the trigger pin. It is probably gummed up.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-22-2012, 07:10 AM #1200
gijoey959
I Kill Suckers
 
gijoey959's Avatar
 
Join Date: Dec 2011
Location: El Paso, TX
gijoey959 plays in the PSP
gijoey959 owns a Planet Eclipse Lv1
gijoey959 plays in the APPA beginner division
gijoey959 supports DLX Technology
Quote:
Originally Posted by Bill View Post
What year of EGO?
Oh duhh its an 11, but I solved it, turned out to be an o ring in the HPR, but the leak sounded like it was in the body somewhere
__________________

DA LUXE MOB + MACDEV MILITIA
DYE Invision Owners Club
THE MARQ CLAN
HOUSTON HEAT FAN #11
gijoey959 is offline  
Old 11-22-2012, 09:25 AM #1201
Funny Old Guy
 
 
Funny Old Guy's Avatar
 
Join Date: Mar 2007
Location: SoCal
Funny Old Guy plays in the PSP
Funny Old Guy owns a Planet Eclipse Ego
Funny Old Guy plays in the APPA D4 division
I do not possess the confidence to take my 08 and 09 Ego apart to replace O rings, clean and lube. But I wanna learn. I don't wanna be the knucklebutt that can't wrench his own gear.

I am having difficulty finding video on maintenance and tear down of the 08 and 09 Ego's. Any suggestions?
__________________
Square 1 Soldiers
Paintball Ruined My Life!
CEP Fan #96
Masters World Cup 2011 Topgun CFP
Masters World Cup 2012 ICU Mafia
Funny Old Guy is offline  
Old 11-22-2012, 09:27 AM #1202
autodoc
 
 
autodoc's Avatar
 
Join Date: Dec 2011
Location: Boston
Annual Supporting Member
autodoc plays in the PSP
autodoc owns a Planet Eclipse CSL
autodoc owns a Planet Eclipse Geo
autodoc owns a Planet Eclipse Lv1
autodoc plays in the APPA D3 division
autodoc owns a Planet Eclipse GSL
Thank you

Quote:
Originally Posted by Bill View Post
You need to keep the front oring and detent slot oiled at the beginning of every day of play.
I will use the oil a little more liberal....i left out it was a cold cold new England morning at the fox4 fall brawl. I had lubed bolts prior evening
autodoc is offline  
Old 11-24-2012, 02:01 AM #1203
Lorek
Scrub
 
Lorek's Avatar
 
Join Date: Jan 2012
Location: Kansas (785)
Lorek owns a Planet Eclipse Ego
Lorek supports Team VICIOUS
Lorek supports Team VICIOUS
Lorek has perfected Level 1 in PbNation Pursuit
Broke out my Ego 7 today. Tried to fire it and it just puffs air, it sounds like it is above the trigger. No balls come out or air. Any advice on where to start =/
Lorek is offline  
Old 11-24-2012, 07:24 AM #1204
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by Funny Old Guy View Post
I do not possess the confidence to take my 08 and 09 Ego apart to replace O rings, clean and lube. But I wanna learn. I don't wanna be the knucklebutt that can't wrench his own gear.

I am having difficulty finding video on maintenance and tear down of the 08 and 09 Ego's. Any suggestions?
Not sure where you are located but try Mountain View Paintball. If Steve is in your area he may show you how for a small fee. If not, check the Planet site. There may be a tech in your area. As far as videos are concerned, try ******.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-24-2012, 07:26 AM #1205
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by Lorek View Post
Broke out my Ego 7 today. Tried to fire it and it just puffs air, it sounds like it is above the trigger. No balls come out or air. Any advice on where to start =/
I would suggest the following steps...
- Try a new Energy, Duracell or Energizer battery. The gun needs a good amount of power to run the marker properly. A lessor brand of battery may read fully charged but doesn't have the upkeep to sustain the power needed to run the gun. This is the #1 cause of all issues in an EGO.
- Replace the #11 rammer oring. Even if it looks good. It will be the largest black oring towards the rear of the rammer.
- Set your dwell to 14.5 and LPR to stock flush.
- QEV Diaphragm issue. Inside the QEV, between the blue and silver halves, is a rubber diaphragm. This part should be one piece. Make sure it is not ripped or cut (see page 63 in the manual). Also make sure that the person who changed it previous did not leave any of the diaphragm behind.
- Be sure the gun is not set to training mode.
- Oring rebuild
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-24-2012, 10:20 AM #1206
Funny Old Guy
 
 
Funny Old Guy's Avatar
 
Join Date: Mar 2007
Location: SoCal
Funny Old Guy plays in the PSP
Funny Old Guy owns a Planet Eclipse Ego
Funny Old Guy plays in the APPA D4 division
Quote:
Originally Posted by Bill View Post
Not sure where you are located but try Mountain View Paintball. If Steve is in your area he may show you how for a small fee. If not, check the Planet site. There may be a tech in your area. As far as videos are concerned, try ******.
Yes.

Mountain View Paintball is an hour away. I can swing by the shop. Steve is pretty busy lately, I wanted to see if online videos could walk me through some basic dis-assembly and maintenance.

Thanks.
__________________
Square 1 Soldiers
Paintball Ruined My Life!
CEP Fan #96
Masters World Cup 2011 Topgun CFP
Masters World Cup 2012 ICU Mafia
Funny Old Guy is offline  
Old 11-25-2012, 12:08 AM #1207
dcp8750
 
 
dcp8750's Avatar
 
Join Date: Jan 2007
dcp8750 owns a Planet Eclipse Etek
lol no problem
dcp8750 is offline  
Old 11-25-2012, 11:07 AM #1208
Ninjitsu232
DaHalfAznPaintballer
 
Ninjitsu232's Avatar
 
Join Date: Jan 2011
Location: BC Canada
Ninjitsu232 owns a Planet Eclipse Ego
Ninjitsu232 has perfected Level 1 in PbNation Pursuit
Hey Bill,
My 2011 ego is having solenoid issues. I power the gun on and when the solenoid setting is on normal, it doesnt shoot AT ALL. I put it on high power and then there is like FSDO. I think i may have gotten a weak solenoid. I have tried shooting the gun with different 9v's, all brand new, microswitch and opto, solenoid settings at full. only shoots when solenoid is on high power
__________________
Black/Black G6R W/ Premium Bolt -- Ninja Dura 77 W/ SLP and Z2
Red/Silver Ego 9
Canary PM8
I fix guns 'n stuff
Ninjitsu232 is offline  
Old 11-25-2012, 12:12 PM #1209
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
What are your solenoid dial settings at? I would try them at 3/7. Also, what is your dwell? If its cold, try upping the dwell 1ms. The battery has to be a high quality one like a duracell or energizer.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-25-2012, 12:40 PM #1210
kjinxx2
 
 
Join Date: Oct 2012
Hey Bill,

Seems like you accidentally skipped over my question

"Hello,

I recently purchased an Ego 08. It has no leaks but velocity caps around 245 or so - that is with the HPR screw as far out as possible. I stripped the gun, examined all o-rings, and everything appears to be intact. I'm not sure if it's a cold weather issue, or what. Any idea where to start?"


Thanks!!
kjinxx2 is offline  
Old 11-25-2012, 04:47 PM #1211
AgainstAllEnemies92
"SHOWTIME"
 
AgainstAllEnemies92's Avatar
 
Join Date: Sep 2011
Location: St. Louis
AgainstAllEnemies92 plays in the APPA D4 division
AgainstAllEnemies92 supports DLX Technology
Ok. Brand new to P.E. Bought a slightly used Ego X off of here. Shot great for 2 outtings, on the 3rd time I went to play with it, I started shooting and as I would walk the trigger and ramp, the bolt wasn't returning fast enough. I put a little oil on the bolt and ram and then chrono'd the marker. It was at 180fps. I turned it up to 295fps but that brought the set screw extremely far from the reg. It seemed ok, and next point, the problem persisted. I went back and lived the lpr and set the screw flush. Swapped the battery out, then when it went to fire, nothing. The air somehow stopped gassing the gun, the ASA was holding air though. I messed with the reg screw and got a couple of small puffs that barely moved the bolt. Now it won't even respond that much. It's turning on but that's it. Help!?
__________________
ANIMOSITY 92
LuxeMOB
POWERED BY
WACKY WARRIORS
ANSgear.com.
AgainstAllEnemies92 is offline  
Old 11-26-2012, 02:42 AM #1212
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by kjinxx2 View Post
Hey Bill,

Seems like you accidentally skipped over my question

"Hello,

I recently purchased an Ego 08. It has no leaks but velocity caps around 245 or so - that is with the HPR screw as far out as possible. I stripped the gun, examined all o-rings, and everything appears to be intact. I'm not sure if it's a cold weather issue, or what. Any idea where to start?"


Thanks!!
- Try a new Energy, Duracell or Energizer battery. The gun needs a good amount of power to run the marker properly. A lessor brand of battery may read fully charged but doesn't have the upkeep to sustain the power needed to run the gun. This is the #1 cause of all issues in an EGO.
- Replace the #11 rammer oring. Even if it looks good. It will be the largest black oring
towards the rear of the rammer (page 55/56 in the manual).
- With in your Inline regulator is a large spring. This spring sits on the piston only one way. If you take the piston out of the reg body you will notice the spring will slide onto the piston easy one way and with alot of friction the other. You want the spring to sit with no friction. Lube the piston oring and re-install (pages 51/52 in the manual) .
- HPR Piston: Check the HPR Piston reg seat. There should be a small plastic like disk that is pressed into the end of the piston shaft. Make sure it is there and not cracked.
- Set your dwell to 14.0
- QEV Diaphragm issue. Inside the QEV block, between the blue body and silver caps, is a rubber diaphragm. This part should be one piece. Make sure it is not ripped or cut (see pages 64/65 in the manual).
- LPR: Be sure the LPR is assembled properly. There are 5 parts inside the LPR Cap. Listing from front to rear - Adjuster screw, adjuster piston (silver cuplike part), gold spring, silver piston and gold spring. The oring on the piston should be lightly greased with Eclipse grease or Sleek.Both springs are the same. Put the adjuster screw flush to one turn out, see if this affects the velocity at all.
- While you have the LPR apart check the LPR piston seat. Looks just like the HPR piston but smaller. Seat is in the same area...
- ASA On/Off knob turned in to far? When you add your air system to the gun you want to turn the knob until you hear the initial gas transfer. Do not turn it more then one complete turn more or you will actually restrict the airflow coming out of your air system.
- Complete oring overhaul, cleaning and lubrication.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-26-2012, 02:45 AM #1213
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by AgainstAllEnemies92 View Post
Ok. Brand new to P.E. Bought a slightly used Ego X off of here. Shot great for 2 outtings, on the 3rd time I went to play with it, I started shooting and as I would walk the trigger and ramp, the bolt wasn't returning fast enough. I put a little oil on the bolt and ram and then chrono'd the marker. It was at 180fps. I turned it up to 295fps but that brought the set screw extremely far from the reg. It seemed ok, and next point, the problem persisted. I went back and lived the lpr and set the screw flush. Swapped the battery out, then when it went to fire, nothing. The air somehow stopped gassing the gun, the ASA was holding air though. I messed with the reg screw and got a couple of small puffs that barely moved the bolt. Now it won't even respond that much. It's turning on but that's it. Help!?
- Try a new Energy, Duracell or Energizer battery. The gun needs a good amount of power to run the marker properly. A lessor brand of battery may read fully charged but doesn't have the upkeep to sustain the power needed to run the gun. This is the #1 cause of all issues in an EGO.
- Change all three rammer orings
- HPR Piston: Check the HPR Piston reg seat. There should be a small plastic like disk that is pressed into the end of the piston shaft. Make sure it is there and not cracked.
- Check the LPR. Make sure both springs are present. There should be 4 pieces within the LPR. Starting from front: Adjuster screw, spring, Regulator piston and gold spring. Put the adjuster screw flush to one turn in.
- While you have the LPR apart check the LPR piston seat. It is a plastic like disk pressed into the end of the shaft. If it isnt there, you need to replace the piston.
- Clean the solenoid out as shown in the manual on pages 67 and 68 of the manual. When you re-lube the spool, use a very small amount of Eclipse grease.
- Did you yake the bolt pin out of the bolt for any reason? Maybe you installed it back upside down.
- Set the dwell to stock.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-26-2012, 09:37 PM #1214
joshnielson
extreme nitemare hrl
 
joshnielson's Avatar
 
Join Date: Apr 2009
Location: ft hood tx
When i keep the silencers on my geo plus bolt it only sgoots 220 if i take them off and tirn my reg screw dang near poking out the bottom it will go up 299 280 ish what could this be
joshnielson is offline  
Old 11-26-2012, 10:13 PM #1215
EMPIR3baller113
TheyTookOurJobs
 
EMPIR3baller113's Avatar
 
Join Date: May 2005
Location: New jerzey
EMPIR3baller113 plays in the PSP
EMPIR3baller113 owns a Planet Eclipse Ego
EMPIR3baller113 has achieved Level 1 in PbNation Pursuit
EMPIR3baller113 has achieved Level 2 in PbNation Pursuit
Got a 08 ego with a crack at the bottom of the trigger frame that then goes around the rail mount. Anywhere to get 08 trigger frames? Or any ideas on how to fix? Thanks
__________________
GEARBAG
EMPIR3baller113 is online now  
Old 11-27-2012, 03:30 AM #1216
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by joshnielson View Post
When i keep the silencers on my geo plus bolt it only sgoots 220 if i take them off and tirn my reg screw dang near poking out the bottom it will go up 299 280 ish what could this be
Did you up the dwell to 14.5?
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-27-2012, 03:31 AM #1217
Bill
Paintball Showcase
 
Bill's Avatar
 
Join Date: Nov 2001
Location: Paintball Showcase
Annual Supporting Member
Bill is a Supporting Member
Bill is a founding member
 has been a member for 10 years
Bill owns a Planet Eclipse Ego
Quote:
Originally Posted by EMPIR3baller113 View Post
Got a 08 ego with a crack at the bottom of the trigger frame that then goes around the rail mount. Anywhere to get 08 trigger frames? Or any ideas on how to fix? Thanks
I will have to check availability. PM me.
__________________
WWW.PAINTBALLSHOWCASE.COM

Certified NorthEast Eclipse Technician/Warranty Center!

Used Gun thread: EGO8s, DMs, Shockers, and more...
Bill is offline  
Old 11-27-2012, 10:07 AM #1218
ijinxd
 
 
ijinxd's Avatar
 
Join Date: Jan 2010
Location: California
ijinxd owns a Planet Eclipse Ego
ijinxd has perfected Level 1 in PbNation Pursuit
ijinxd has achieved Level 3 in PbNation Pursuit
ijinxd supports DLX Technology
Hey Bill, would you mind checking on the availability of 07 Ego triggers?
The one I have with me has a stripped adjustment screw.

Also, with the Zick2 installed, what should I change on the settings?
ijinxd is offline  
Closed Thread


Thread Tools

Posting Rules
Forum Jump