Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 09-28-2013, 02:56 PM #1
JeremyNeufeld
 
 
JeremyNeufeld's Avatar
 
Join Date: Nov 2011
Location: Toronto, Canada
JeremyNeufeld owns a Planet Eclipse Ego
JeremyNeufeld has achieved Level 1 in PbNation Pursuit
JeremyNeufeld has perfected Level 1 in PbNation Pursuit
JeremyNeufeld has achieved Level 2 in PbNation Pursuit
Ego LV1 Issue, Jack Wood Please Help!

Hey there,

So I've had an LV1 since they were released and had no issues until about 2 months ago.

In the last two months however my LV1 cannot shot over 12bps, has poor efficiency, and sometimes mid stroke the bolt with stay open too long allowing excess gas out.

In terms of the guns set up, to combat the guns slow bps, I set the Solenoid Flow Restrictors to 10/10 (in accordance to the manual). I have the LPR at the stock 3/4 turns out from fully closed, and I have my bolt and rammer lubed in accordance to the manual.

The only thing that has been changed about the gun is that is was part swapped before ever shooting it, and has worked flawlessly until 2 months ago.

The gun doesn't seem to have any real signs of wear, it has about 65,000-75,000 shots on it (counter was reset by accident at some point), and has been well maintained. I'd like to have this beast up and running again, so if anyone has any advice, please send it my way.

Thanks!
JeremyNeufeld is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 09-28-2013, 03:38 PM #2
aresfiend
Snake player McFatass
 
aresfiend's Avatar
 
Join Date: Feb 2012
Location: Rice Lake, WI
aresfiend has achieved Level 1 in PbNation Pursuit
aresfiend has achieved Level 2 in PbNation Pursuit
aresfiend has achieved Level 3 in PbNation Pursuit
aresfiend supports Empire
Try replacing your ram o-rings.

I'm not Jack Wood, but it sure sounds like that might be the issue.
__________________
You may call it fat, I call it bounce padding.
Dynamic broke meter (relevant when adding when trading): I got paid yesterday
EΔRL
aresfiend is offline   Reply With Quote
Old 09-28-2013, 05:56 PM #3
JeremyNeufeld
 
 
JeremyNeufeld's Avatar
 
Join Date: Nov 2011
Location: Toronto, Canada
JeremyNeufeld owns a Planet Eclipse Ego
JeremyNeufeld has achieved Level 1 in PbNation Pursuit
JeremyNeufeld has perfected Level 1 in PbNation Pursuit
JeremyNeufeld has achieved Level 2 in PbNation Pursuit
Quote:
Originally Posted by aresfiend View Post
Try replacing your ram o-rings.

I'm not Jack Wood, but it sure sounds like that might be the issue.
I actually just put in the light weight rammer (has not been used yet) along with putting my SFR back to factory settings and after doing some testing am having the same issues.
JeremyNeufeld is offline   Reply With Quote
Old 09-28-2013, 06:16 PM #4
tonycon
Knuckleheads Paintball
 
tonycon's Avatar
 
Join Date: Mar 2010
Location: Chi-Town
Annual Supporting Member
tonycon owns a Planet Eclipse Geo
tonycon owns a Planet Eclipse Ego
tonycon owns a Planet Eclipse Lv1
tonycon supports our troops
tonycon is Legendary
tonycon owns a Planet Eclipse GSL
Have you tried cleaning/greasing the hpr and lpr? Check for worn orings in both...or just re build them both.
__________________
Swamp SLS-whitebrown CSL-Midnight/Poison LV1 Pure/Prestige GSL

Proudly Sponsored By:
PBExplosion VirtueSpire Valken Paintball

KnuckleHeads Paintball Team
Game footage
tonycon is offline   Reply With Quote
Old 09-28-2013, 06:22 PM #5
CrusaderPB
Field, Pro Shop & Repairs
 
CrusaderPB's Avatar
 
Join Date: Feb 2010
Location: Fairless Hills, PA
Annual Supporting Member
CrusaderPB owns a Planet Eclipse Ego
CrusaderPB supports Bob Gurnsey
CrusaderPB supports our troops
CrusaderPB has perfected Level 1 in PbNation Pursuit
CrusaderPB has achieved Level 3 in PbNation Pursuit
CrusaderPB supports Empire
Try tightening the cam lever. Over time, the screws come loose, causing the level to remain in the "open" position. Page 53 of the manual, left hand side of the marker, under the eye covers (need to remove frame too).

I've been this same sort of issue while working at the tents, we traced the problem to this at the time.

Of course, with 60-70,000 shots, you've replaced the orings and inspected the reg seats right? Might as well service the whole gun at once, know what I mean?
__________________
Crusader Paintball -Serving Philadelphia, Trenton and Princeton
225 Lincoln Highway
Fairless Hills PA 19030 Phone: 215-949-4600
Now a Planet Eclipse Service Center

Like us on Facebook! Follow us on Twitter! Subscribe to our Thread!
CrusaderPB is offline   Reply With Quote
Old 09-28-2013, 11:00 PM #6
7paintball
Service at its best.
 
7paintball's Avatar
 
Join Date: Apr 2010
Location: Lockport, IL
Quote:
Originally Posted by CrusaderPB View Post
Try tightening the cam lever. Over time, the screws come loose, causing the level to remain in the "open" position. Page 53 of the manual, left hand side of the marker, under the eye covers (need to remove frame too). I've been this same sort of issue while working at the tents, we traced the problem to this at the time. Of course, with 60-70,000 shots, you've replaced the orings and inspected the reg seats right? Might as well service the whole gun at once, know what I mean?
Had one come in not long ago that seems to have the same problems yours is having.. Check the can lever, and while you are at it no reason not to rebuild the reg.
__________________
7pbA.com
ALL THINGS PAINTBALL & AIRSOFT
1143 E 9th St.
Lockport, IL 60441
(815) 588-1777


We always offer discounts to the Military, Police and Fire Departments.
7paintball is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump