Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 11-04-2011, 09:00 PM #1
comple
 
 
comple's Avatar
 
Join Date: Aug 2011
Location: Brownstown Twp, MI
Annual Supporting Member
comple supports DLX Technology
Brand new Demon, problems need help!

Just got my demon in the mail last night and am liking the feel, love the oled and look of marker but it's giving me problems. Velocity was next to nothing out of box and had FSDO so turned velo up, got it up higher but every 3rd shot or so was next to no velocity (would travel about 15 feet) and now it's every 10th shot actually seems to hit hard, bolt seems to be travelling VERY slow and creeping back very slowly while leaking out of barrel/feedneck while bolt slowly travels back.

Any help would be appreciated!! Hoping to use this tomorrow!

Edit: Just turned HPR all the way in and all the way out testing in between, didn't change anything whatsoever.

Last edited by comple : 11-04-2011 at 09:16 PM.
comple is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 11-04-2011, 09:30 PM #2
Sick420
Hitting the Snake Fast!
 
Sick420's Avatar
 
Join Date: May 2010
Location: *714*OC
Take the bolt out wipe the old lube off a re lube it lightly. Check the new demon videos on how to service the bolt. Hope this helps.
Sick420 is offline   Reply With Quote
Old 11-04-2011, 09:36 PM #3
comple
 
 
comple's Avatar
 
Join Date: Aug 2011
Location: Brownstown Twp, MI
Annual Supporting Member
comple supports DLX Technology
Ok, I'll give that a shot thank you Sick. Hope it works I'll let ya know!! Low on air so hopefully this does it haha.
comple is offline   Reply With Quote
Old 11-04-2011, 09:59 PM #4
SHOOTNPOO
MACDEV MASTER US TECH
 
SHOOTNPOO's Avatar
 
Join Date: Mar 2008
SHOOTNPOO works for a Paintball manufacturer
SHOOTNPOO plays in the USPL
SHOOTNPOO posts videos on PbNation
Completely clean the bolt, can and guide of all old lube. Relube all parts over and the problem will be gone.
Another thing is this is what all the stock serttings should be.

Dwell 15
debounce 5
eye delay 3.0
Eye sensitivity 10.00
Bolt delay 8.00
Fsdo time 10sec
Fsdo dwell 1.5
Loader pulse 20ms

These are stock settings please make sure that the marker has these settings before changing anything besides relube of the bolt.

Eric
SHOOTNPOO is offline   Reply With Quote
Old 11-04-2011, 10:30 PM #5
comple
 
 
comple's Avatar
 
Join Date: Aug 2011
Location: Brownstown Twp, MI
Annual Supporting Member
comple supports DLX Technology
Quote:
Originally Posted by SHOOTNPOO View Post
Completely clean the bolt, can and guide of all old lube. Relube all parts over and the problem will be gone.
Another thing is this is what all the stock serttings should be.

Dwell 15
debounce 5
eye delay 3.0
Eye sensitivity 10.00
Bolt delay 8.00
Fsdo time 10sec
Fsdo dwell 1.5
Loader pulse 20ms

These are stock settings please make sure that the marker has these settings before changing anything besides relube of the bolt.

Eric

Just took bolt apart and lubed the bolt/can/guide and it's cycling perfectly now aside from FSDO every time I stop shooting for 20 seconds or more. Sometimes the FSDO lasts for 2 or 3 shots rather than just 1. Any suggestion on this?
comple is offline   Reply With Quote
Old 11-04-2011, 10:39 PM #6
SHOOTNPOO
MACDEV MASTER US TECH
 
SHOOTNPOO's Avatar
 
Join Date: Mar 2008
SHOOTNPOO works for a Paintball manufacturer
SHOOTNPOO plays in the USPL
SHOOTNPOO posts videos on PbNation
Did u set the noard as i said?
SHOOTNPOO is offline   Reply With Quote
Old 11-04-2011, 10:49 PM #7
comple
 
 
comple's Avatar
 
Join Date: Aug 2011
Location: Brownstown Twp, MI
Annual Supporting Member
comple supports DLX Technology
Quote:
Originally Posted by SHOOTNPOO View Post
Did u set the noard as i said?
Didn't mess with any of them and it was advertised as brand new so didn't check but Dwell's at 13.5, lemme swap that to 15. Think that might be the issue? Out of air so can't try until I'm at the field tomorrow unfortunately.
comple is offline   Reply With Quote
Old 11-04-2011, 11:24 PM #8
SHOOTNPOO
MACDEV MASTER US TECH
 
SHOOTNPOO's Avatar
 
Join Date: Mar 2008
SHOOTNPOO works for a Paintball manufacturer
SHOOTNPOO plays in the USPL
SHOOTNPOO posts videos on PbNation
Put settings as i posted and u will be fine.
It is poss someone made changes


Like i said put all the settings as i have posted and you.will not have any issus.
SHOOTNPOO is offline   Reply With Quote
Old 11-04-2011, 11:30 PM #9
comple
 
 
comple's Avatar
 
Join Date: Aug 2011
Location: Brownstown Twp, MI
Annual Supporting Member
comple supports DLX Technology
Quote:
Originally Posted by SHOOTNPOO View Post
Put settings as i posted and u will be fine.
It is poss someone made changes


Like i said put all the settings as i have posted and you.will not have any issus.
Ok, got em all how you have them I'll let you know if all is well tomorrow thanks! So pumped to use the Demon!
comple is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump