Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 02-09-2012, 11:30 AM #1
Mercs-FreakShow
Austin Hiler
 
Mercs-FreakShow's Avatar
 
Join Date: Feb 2012
Location: Berea, KY
Mercs-FreakShow has perfected Level 1 in PbNation Pursuit
Mercs-FreakShow has achieved Level 2 in PbNation Pursuit
My Raptor Silver Eagle-HELP

Okay so my stock model Raptor Silver Eagle, will not fire a round at every pull of the trigger like it should. Its supposed to be semi automatic but i must pull the cocking ram back after evry shot to fireanother. Ive checked the exploded view diagram of the gun and made sure all parts were in the right place and so on andthey were. So i dont know whats wrong with it. Can someone tell me?
__________________
Top Shots™ Paintball Team
Red Ball Woods
Berea, KY
Mercs-FreakShow is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 02-09-2012, 12:37 PM #2
melkson
Raptor Guru
 
melkson's Avatar
 
Join Date: Jan 2005
Location: Central CO
well, as I understand it, you are saying that there are no leaks, but the Raptor fails to recock after every shot, forcing you to manually recock the Raptor, is this correct?

If so, there are 2 major causes for this. 1 is just lack of proper lubrication. Have you lubed the marker, and is so, with what? when?

number 2 is bad/swollen/missing o-rings. If the hammer o-ring is missing, or the bolt o-rings are swollen, this will increase friction and cause the marker to not recock properly.

A 3rd possibility if the velocity is too low, but even them she whould recock sometimes.

let us know.
melkson is offline   Reply With Quote
Old 02-09-2012, 12:58 PM #3
Mercs-FreakShow
Austin Hiler
 
Mercs-FreakShow's Avatar
 
Join Date: Feb 2012
Location: Berea, KY
Mercs-FreakShow has perfected Level 1 in PbNation Pursuit
Mercs-FreakShow has achieved Level 2 in PbNation Pursuit
As far as i know the o-rings look just fine, a few look slightly loose but other than that i see no missing or broken o-ring, and i havnt lubed it so maybe that is the problem if that could cause it. And velocity wise i doubt that is the problem because just yesterday i fixed it so the bolt and cocking ram wont bounce after firing due to too much air pressure. So it may be the lube. Ill have to get some and check it. Thesame night i got it off my freind it didnt go semi for about 10 minutes but then out of no where it did for a short time, but was also double firing(shooting 2 pballs at once) almost every other shot. Could anything else be a factor now tht youve heard this? P?S? since the night i got it i had to swap the 2 bottom front and back knobs because my friend had them on back wards but i did it with the diagram so its fine now.
__________________
Top Shots™ Paintball Team
Red Ball Woods
Berea, KY

Last edited by Mercs-FreakShow : 02-09-2012 at 01:01 PM. Reason: forgot to put something
Mercs-FreakShow is offline   Reply With Quote
Old 02-09-2012, 01:39 PM #4
Mercs-FreakShow
Austin Hiler
 
Mercs-FreakShow's Avatar
 
Join Date: Feb 2012
Location: Berea, KY
Mercs-FreakShow has perfected Level 1 in PbNation Pursuit
Mercs-FreakShow has achieved Level 2 in PbNation Pursuit
And its a blue aluminum body. Full STOCK everything as far as i know.
__________________
Top Shots™ Paintball Team
Red Ball Woods
Berea, KY
Mercs-FreakShow is offline   Reply With Quote
Old 02-11-2012, 03:12 PM #5
Mercs-FreakShow
Austin Hiler
 
Mercs-FreakShow's Avatar
 
Join Date: Feb 2012
Location: Berea, KY
Mercs-FreakShow has perfected Level 1 in PbNation Pursuit
Mercs-FreakShow has achieved Level 2 in PbNation Pursuit
ok so it has been lubede and has new o-rings but still will not go semi. i still must manual jack a round after every shot any other possibilities melkson?
__________________
Top Shots™ Paintball Team
Red Ball Woods
Berea, KY
Mercs-FreakShow is offline   Reply With Quote
Old 02-14-2012, 12:28 PM #6
NoX13
WARNING: I Do Dumb ****!
 
NoX13's Avatar
 
Join Date: Jun 2005
Location: 18974
NoX13 has achieved Level 4 in PbNation Pursuit
NoX13 has achieved Level 5 in PbNation Pursuit
NoX13 is Legendary
I miss my raptor.. thing was a beast..lol..


it could be any number of things from something as already said the velocity it outta whack to a bumper that is missing or out of place , or even the spring itself is really bad/ or not the right one (if someone else has owned it or screwing with it ANYTHING is possible)

open up a light colored towel and start breaking the marker down, as you do it lay the parts out on the towel in the same position they would be in the marker and as you would see them in the exploded view of the manual/diagram

that will give you a much better idea idea of what you could be missing or what needs to be replaced..

clean and inspect all the parts you have while comparing to the diagram..

lightly lube all areas needed and start reassembly ..

if you have issues after that you can always send it to me and Ill fix it for nothing provided you pay shipping both ways and any needed parts..
__________________
I shot the Sheriff,The Deputy And the Ref.. But we all knew the Ref had it coming.

My drinking team has a paintball problem.

**** you, **** you, Youre Cool, **** YOU!,

Tiberius T9 Package
http://www.pbnation.com/showthread.php?t=4388362
NoX13 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump