Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 10-19-2013, 08:56 PM #1
xXxRIOTxXx
 
 
xXxRIOTxXx's Avatar
 
Join Date: Oct 2008
Dangerous Powers G4 Problem, not out of the box issue.



VIDEO

My G4 will not fire at all. All it makes is a “ Tsssss “ sound when the trigger is pulled as shown in the video. I have looked at about every online posting about G4’s not shooting, not working, bolt stick, you name it. I have not found a solution. I have tried every recommendation that I have come across, and the gun is still not firing.
I have…
Tried four different lubes…grease and oils
Tried Greasing/Oiling each o-ring / bolt… little to none…then a medium coating….and also a larger coat with each of the four lubes
Replaced all the o-rings in the gun and then repeated the step above with different levels of coating on all the parts (o-rings / bolt )
I have tried changing the dwell to every different setting and also the ABS dwell
Tried five different batteries
Tried different air tanks
The whole gun has been gone through, and everything is in good shape.

The only upgrade on the gun is the DYE Hyper 3 regulator. The reason I put this regulator on the gun was because the stock regulator is not working properly, which is another mystery to me. The regulator is in flawless condition. Nothing is damaged internally. When I adjust the velocity screw all the way in to all the way out it shoots ~220 FPS and does not change. When screwing the velocity screw about mid-way in I was able to get the velocity up the 230ish. But then if I screwed it out or in any farther it would drop to ~220 again. Once I put the Hyper 3 regulator on the marker, the gun shot amazing with zero problems. After about 3 months of playing with the gun, I started to have this issue where the marker would not fire and make the “ Tsssss “ sound when I first aired up the gun. Eventually after dry firing the marker the “ Tsssss “ went away and the marker actually fired. Then a week later the gun would not fire at all when aired up, which is my problem above.

All help appreciated, thank you.
xXxRIOTxXx is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 10-19-2013, 09:11 PM #2
firefoxx04
Up the Irons
 
firefoxx04's Avatar
 
Join Date: Jul 2008
Location: Michigan
firefoxx04 supports Bob Gurnsey
firefoxx04 supports DLX Technology
So you greased the noid?

Did you replace the orings on the noid piston?


edit: it sounds like a stuck noid. I would be willing to be money that either A) Greasing or replacing the noid orings will fix it or B) A new noid will fix it.


New noids I think are $35 or a parts kit is around $55. Both are priced VERY well compared to other markers. MY GT noid is a $160 part.
firefoxx04 is offline   Reply With Quote
Old 10-19-2013, 09:16 PM #3
Darkh2o
DPOTer since 2007
 
Darkh2o's Avatar
 
Join Date: Apr 2007
Location: Bloomington, Ill-a-noiz
Quote:
Originally Posted by firefoxx04 View Post
So you greased the noid?

Did you replace the orings on the noid piston?


edit: it sounds like a stuck noid. I would be willing to be money that either A) Greasing or replacing the noid orings will fix it or B) A new noid will fix it.


New noids I think are $35 or a parts kit is around $55. Both are priced VERY well compared to other markers. MY GT noid is a $160 part.

i was thinking the same thing. noid piston is not moving.
__________________


I'm not Old, everyone else is "New".
Darkh2o is offline   Reply With Quote
Old 10-20-2013, 07:35 PM #4
xXxRIOTxXx
 
 
xXxRIOTxXx's Avatar
 
Join Date: Oct 2008
Quote:
Originally Posted by firefoxx04 View Post
So you greased the noid?

Did you replace the orings on the noid piston?


edit: it sounds like a stuck noid. I would be willing to be money that either A) Greasing or replacing the noid orings will fix it or B) A new noid will fix it.


New noids I think are $35 or a parts kit is around $55. Both are priced VERY well compared to other markers. MY GT noid is a $160 part.
Quote:
Originally Posted by Darkh2o View Post
i was thinking the same thing. noid piston is not moving.

Yes I did replace the solenoid o-rings, I replaced them again today thinking I might get lucky and it works. Unfortunately nothing changed once again, I am about to order a new solenoid and see if this fixes the problem. I found one for $35 which isn't to bad. Appreciate the help guys, I will let you know if this solves my problem.
xXxRIOTxXx is offline   Reply With Quote
Old 10-20-2013, 08:18 PM #5
firefoxx04
Up the Irons
 
firefoxx04's Avatar
 
Join Date: Jul 2008
Location: Michigan
firefoxx04 supports Bob Gurnsey
firefoxx04 supports DLX Technology
The parts kit for $55 is well worth the extra $20, if possible. New eyes and reg parts along with screws and detents.


Sometimes a noid just craps out and no amount of fresh grease or new orings will fix it. Been there done that.
firefoxx04 is offline   Reply With Quote
Old 10-20-2013, 08:53 PM #6
xmc1146
Mount Vernon, Wa
 
xmc1146's Avatar
 
Join Date: Nov 2006
xmc1146 owns a Planet Eclipse Geo
xmc1146 is for the Gunfight
xmc1146 owns a Planet Eclipse GSL
make sure the piston is installed correctly and there is a spring in there.
xmc1146 is offline   Reply With Quote
Old 10-20-2013, 09:06 PM #7
firefoxx04
Up the Irons
 
firefoxx04's Avatar
 
Join Date: Jul 2008
Location: Michigan
firefoxx04 supports Bob Gurnsey
firefoxx04 supports DLX Technology
usually the lack of a spring will cause a large leak down the barrel
firefoxx04 is offline   Reply With Quote
Old 10-21-2013, 10:33 AM #8
Hadrien
 
 
Hadrien's Avatar
 
Join Date: Sep 2012
I thought I had a bad solenoid in my G3, but it ended up being I had two o-rings in the wrong places on the bolt. My gun made a "Pfft" sound, where the solenoid was moving, but the bolt would never move. The "Pfft" sound in your video seems a bit softer than the problem I was having though.

I know the o-rings in the G4 are in the body and not on the bolt, but you may want to double or triple check those before ordering a solenoid.

Does the bolt "cycle" normally if you move it by hand? Do you really have to kind of poke it through or is everything smooth?

That still doesn't explain the weirdness with your original G4 regulator though. Maybe a full strip down, cleaning, and rebuild of the gun again would help if you have enough o-rings and time. But from your original post, as well as your replies it sounds like you have tried just about everything.

I was able to get a G4 rebuild kit for my G3 (I have a G4 reg on it) off of eBay for like $49, which was a pretty decent deal.
Hadrien is offline   Reply With Quote
Old 10-21-2013, 11:18 AM #9
firefoxx04
Up the Irons
 
firefoxx04's Avatar
 
Join Date: Jul 2008
Location: Michigan
firefoxx04 supports Bob Gurnsey
firefoxx04 supports DLX Technology
If new orings are used, they should be 017 orings for the bolt



firefoxx04 is offline   Reply With Quote
Old 10-21-2013, 11:54 AM #10
Hadrien
 
 
Hadrien's Avatar
 
Join Date: Sep 2012
Quote:
Originally Posted by firefoxx04 View Post
If new orings are used, they should be 017 orings for the bolt



Is that #3 - 19X2 o-ring in the body used for the bolt seal as well or is that the "bumper" o-ring?
Hadrien is offline   Reply With Quote
Old 10-21-2013, 12:06 PM #11
CA_Tectonics
 
 
CA_Tectonics's Avatar
 
Join Date: Feb 2010
Location: Northern CA
Quote:
Originally Posted by Hadrien View Post
Is that #3 - 19X2 o-ring in the body used for the bolt seal as well or is that the "bumper" o-ring?
That particular o-ring is the equivalent to the sail o-ring on your G3 bolt. It seals off the air in the back half of the marker so it doesn't escape around the outside of the bolt. It is not really a bumper per say. There is a plastic bumper piece that is actually on the bolt - near the back end rim of the bolt.


Oh yea........nice o-ring chart guys .
__________________
Graphite Dangerous Power REV-I
– TechT bolt engine, REV-I & Disruptive barrel kits, Prophecy V2 w/ Empire feedgate, Crossfire SS 68/4500
Maroon and Polished Aluminum Dangerous Power Threshold
– 7th Element board, TechT bolt engine, magnet trigger kit, REV-I PMD, Sly Dual Carbon barrel kit, Prophecy V2, Crossfire SS 68/4500
Black and Silver Dangerous Power F8
– APE Rampage board, VS bolt, magnet trigger kit, F8 gauge, REDZ barrel kit, Halo B w/ Exalt feedgate, PMI 68/4500
Polished Aluminum and Red Dangerous Power F8
– Virtue board, VS bolt, magnet trigger kit, Halo B w/ Exalt feedgate, PMI 68/4500
CA_Tectonics is offline   Reply With Quote
Old 10-25-2013, 05:39 PM #12
xXxRIOTxXx
 
 
xXxRIOTxXx's Avatar
 
Join Date: Oct 2008
Received my full parts kit with reg rebuild/ solenoid/ etc.

Replaced everything with the parts kit, besides a few screws, eyes, and battery harness. Replaced the solenoid, did a STOCK regulator rebuild, and replaced all orings. The gun has been brought back to life, and the STOCK regulator is adjustable now.

But also just to note...when i aired up and tried to shoot the gun before the rebuild. There was a massive and constant leak through the frame. Maybe the solenoid just completely crapped out ? I don't know what caused that, but atleast the gun is in perfect working condition now.


EDIT:

I found these in the G4 part kit aswell, i could not find out where these go though? On the parts breakdown picture I don't see anything that looks like these 2 parts.






When I did my stock regulator rebuild, on the parts breakdown picture, there is this little disc at the bottom of the reg. I however did not replace this because I could not get the other one out. It looks as if there is one down at the bottom, but it will not come out. I left it alone and did not put a new one in. Do any of you know how to get that piece out?



Last edited by xXxRIOTxXx : 10-25-2013 at 06:15 PM.
xXxRIOTxXx is offline   Reply With Quote
Old 10-25-2013, 05:57 PM #13
xmc1146
Mount Vernon, Wa
 
xmc1146's Avatar
 
Join Date: Nov 2006
xmc1146 owns a Planet Eclipse Geo
xmc1146 is for the Gunfight
xmc1146 owns a Planet Eclipse GSL
what part of Virginia you from?
xmc1146 is offline   Reply With Quote
Old 10-25-2013, 06:13 PM #14
xXxRIOTxXx
 
 
xXxRIOTxXx's Avatar
 
Join Date: Oct 2008
Quote:
Originally Posted by xmc1146 View Post
what part of Virginia you from?
Newport News, but I normally play at Bethel Battlefield in hampton, and Chesapeake Sports Park
xXxRIOTxXx is offline   Reply With Quote
Old 10-25-2013, 06:19 PM #15
xmc1146
Mount Vernon, Wa
 
xmc1146's Avatar
 
Join Date: Nov 2006
xmc1146 owns a Planet Eclipse Geo
xmc1146 is for the Gunfight
xmc1146 owns a Planet Eclipse GSL
Quote:
Originally Posted by xXxRIOTxXx View Post
Newport News, but I normally play at Bethel Battlefield in hampton, and Chesapeake Sports Park
xmc1146 is offline   Reply With Quote
Old 10-25-2013, 07:09 PM #16
CA_Tectonics
 
 
CA_Tectonics's Avatar
 
Join Date: Feb 2010
Location: Northern CA
Quote:
Originally Posted by xXxRIOTxXx View Post
Received my full parts kit with reg rebuild/ solenoid/ etc.

Replaced everything with the parts kit, besides a few screws, eyes, and battery harness. Replaced the solenoid, did a STOCK regulator rebuild, and replaced all orings. The gun has been brought back to life, and the STOCK regulator is adjustable now.

But also just to note...when i aired up and tried to shoot the gun before the rebuild. There was a massive and constant leak through the frame. Maybe the solenoid just completely crapped out ? I don't know what caused that, but atleast the gun is in perfect working condition now.


EDIT:

I found these in the G4 part kit aswell, i could not find out where these go though? On the parts breakdown picture I don't see anything that looks like these 2 parts.


[IMG]http://i1003.photobucket.com/albums/af160/pballer2563/randoms_zpsbb84b485.jpg[IMG]



When I did my stock regulator rebuild, on the parts breakdown picture, there is this little disc at the bottom of the reg. I however did not replace this because I could not get the other one out. It looks as if there is one down at the bottom, but it will not come out. I left it alone and did not put a new one in. Do any of you know how to get that piece out?


Well at least you got it working again .

As for the parts.......in the pic I left showing above, the silver thing on the right looks to be a power/eyes button. On the Rev-I and FX, there is a red one for power and a silver one for eyes on/off . Not sure what the other thing is . I can say that it isn't on any of the Fusions, the Rev-I, or the Threshy.

Also, I can't help on the disk either. I have not had the opportunity to work with a G4 regulator.
__________________
Graphite Dangerous Power REV-I
– TechT bolt engine, REV-I & Disruptive barrel kits, Prophecy V2 w/ Empire feedgate, Crossfire SS 68/4500
Maroon and Polished Aluminum Dangerous Power Threshold
– 7th Element board, TechT bolt engine, magnet trigger kit, REV-I PMD, Sly Dual Carbon barrel kit, Prophecy V2, Crossfire SS 68/4500
Black and Silver Dangerous Power F8
– APE Rampage board, VS bolt, magnet trigger kit, F8 gauge, REDZ barrel kit, Halo B w/ Exalt feedgate, PMI 68/4500
Polished Aluminum and Red Dangerous Power F8
– Virtue board, VS bolt, magnet trigger kit, Halo B w/ Exalt feedgate, PMI 68/4500
CA_Tectonics is offline   Reply With Quote
Old 10-25-2013, 07:21 PM #17
xXxRIOTxXx
 
 
xXxRIOTxXx's Avatar
 
Join Date: Oct 2008
Quote:
Originally Posted by CA_Tectonics View Post
Well at least you got it working again .

As for the parts.......in the pic I left showing above, the silver thing on the right looks to be a power/eyes button. On the Rev-I and FX, there is a red one for power and a silver one for eyes on/off . Not sure what the other thing is . I can say that it isn't on any of the Fusions, the Rev-I, or the Threshy.

Also, I can't help on the disk either. I have not had the opportunity to work with a G4 regulator.
Haha thanks for pointing that out. That slipped right past my eyes . The rubber piece fits over the silver button, so it may just be a rubber cover for it.
xXxRIOTxXx is offline   Reply With Quote
Old 10-25-2013, 07:26 PM #18
CA_Tectonics
 
 
CA_Tectonics's Avatar
 
Join Date: Feb 2010
Location: Northern CA
Hahaha. Makes sense now. I think when someone buys the upgraded E1 board, they get those too. Anyway, sounds like your good.....other than that disk.
__________________
Graphite Dangerous Power REV-I
– TechT bolt engine, REV-I & Disruptive barrel kits, Prophecy V2 w/ Empire feedgate, Crossfire SS 68/4500
Maroon and Polished Aluminum Dangerous Power Threshold
– 7th Element board, TechT bolt engine, magnet trigger kit, REV-I PMD, Sly Dual Carbon barrel kit, Prophecy V2, Crossfire SS 68/4500
Black and Silver Dangerous Power F8
– APE Rampage board, VS bolt, magnet trigger kit, F8 gauge, REDZ barrel kit, Halo B w/ Exalt feedgate, PMI 68/4500
Polished Aluminum and Red Dangerous Power F8
– Virtue board, VS bolt, magnet trigger kit, Halo B w/ Exalt feedgate, PMI 68/4500
CA_Tectonics is offline   Reply With Quote
Old 10-25-2013, 07:30 PM #19
xXxRIOTxXx
 
 
xXxRIOTxXx's Avatar
 
Join Date: Oct 2008
Quote:
Originally Posted by CA_Tectonics View Post
Hahaha. Makes sense now. I think when someone buys the upgraded E1 board, they get those too. Anyway, sounds like your good.....other than that disk.
It looked like there was still a disc at the bottom of the reg. So at least it has all its parts and works now.

Thanks to all that helped
xXxRIOTxXx is offline   Reply With Quote
Old 10-25-2013, 10:26 PM #20
firefoxx04
Up the Irons
 
firefoxx04's Avatar
 
Join Date: Jul 2008
Location: Michigan
firefoxx04 supports Bob Gurnsey
firefoxx04 supports DLX Technology
The disc is just a spacer of some sort, no need to replace it.

When putting the G4 Reg back together, specifically the adjustment screw and "steel ball bearing thingy" can be a pain. Glad you go it running.

The grip leak was probably your previous noid venting air.
firefoxx04 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump