Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 01-17-2015, 10:56 PM #1
Jordan428
 
 
Jordan428's Avatar
 
Join Date: Jun 2011
Location: Alabama
Jordan428 owns a Planet Eclipse Geo
Velocity issue

Hey guys I have an issue with one of my luxes. It was shooting fine for 4 straight weekends. And then boom a problem. The day of the problem it was Crono'd to 285 and it was shooting good for one game then here came the problem. It would drop from 280 to 190 then it wouldn't even shoot paint just push them into the barrel. He would take it back to the crono it would go back to 280 but then from that time to going back to the field it dropped back down to 190 before not shooting at all. I'm pretty sure it is a bad reg spring mixed with a bad reg seat. I assume reg spring because it's the silver one and judging by breech wear it probably has a few pallets shot through it. Also it has a pooty stage 2 core but that's basically the same as a stock 2.0 core with a diffrent bolt so I doubt that's the problem. Thanks in advance
__________________
Setup 1:
Triple Fade Triple Splash pooty'd Luxe 1.5
Watermelon Spire
Ninja 68

Setup 2:
White/Purple pooty'd Luxe 1.0
Empire Z2
Ninja 68

ROLL TIDE ROLL

Last edited by Jordan428 : 01-17-2015 at 11:02 PM.
Jordan428 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 01-18-2015, 01:20 AM #2
Pooty51
Pootypaintball.com
 
Pooty51's Avatar
 
Join Date: Sep 2005
Location: OC Cal
Yes, I would check the reg guts for sure. If still the same then look at the bolt sail oring then other powercore orings. If still nothing then remove the ft screw and up the dwell. Hope it's not the noid. But I am sure it's reg related
__________________
www.pootypaintball.com = For Custom anno, Ninja tanks, Custom 1-1 Guns, Custom Parts, Factory spares, Rare hard to find parts and upgrades, Gun mods, Lubes and Things

---Pooty's Youtube Channel - Mod - Tech - Product Videos---

---Pooty Paintball Facebook-Anno Shop---
Pooty51 is offline   Reply With Quote
Old 01-18-2015, 02:42 AM #3
Jordan428
 
 
Jordan428's Avatar
 
Join Date: Jun 2011
Location: Alabama
Jordan428 owns a Planet Eclipse Geo
Thanks for the info pooty. I'll defiantly rebuild the reg to see if that's the problem.
__________________
Setup 1:
Triple Fade Triple Splash pooty'd Luxe 1.5
Watermelon Spire
Ninja 68

Setup 2:
White/Purple pooty'd Luxe 1.0
Empire Z2
Ninja 68

ROLL TIDE ROLL
Jordan428 is offline   Reply With Quote
Old 01-18-2015, 10:04 PM #4
wyndan21
"L" for LUXE :)
 
wyndan21's Avatar
 
Join Date: Mar 2010
Location: CANADA 306
wyndan21 supports Team VICIOUS
wyndan21 supports Team VICIOUS
wyndan21 supports Team VICIOUS
wyndan21 supports DLX Technology
Same thing happened to mine

Would crono 287-295 then when I went to play it was like it would shoot fine then it would drop off cause the paint stream was severely arching and it sounded like my gun was skipping shots..

I totally rebuilt my core and hand fitted everything I took the reg apart replaced the orings.. My luxe is a 2.0 it has the black reg spring ..

Another thing I took out the piston reg seat and the clear reg seat plug looked like a mushroom a skinny bottom and wider top I replaced it with a reg seat out of my older 1.5 stock luxe oring kit.. I haven't aired it up yet but he feather touch screw is out and the manifold screw is at flush Im thinking of ordering a feather touch and the new updated spring and reg piston.. But for now I'm going to test it out ..
__________________
SAVAGE D2 X-BALL 2014 #21
P.A WILDSIDE D2-X 2013 #2
SASK DEFIANCE D2-5MAN 09'-13' #21

PAWG GOD BLESS ALEXIS TEXAS, JESSIE ROGERS AND SIRI

WYNDAN 'ZONGO' CYR #21
Always Strive And Prosper A$VP
Long live A$AP
wyndan21 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump