Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 07-25-2011, 01:52 AM #1
dom088
 
 
dom088's Avatar
 
Join Date: Jun 2011
Location: Canada
Exclamation please help!..... raptor

Hey guys... Well long ago my sister got a red raptor.. Its been sitting and wen I went to air it up.. It really leaks down the barrel.. When I cock it.. It than blows out of the neck feed...
What is this?? Orings on the bolt?
I don't have the manual for it anymore.

Thanks alot
dom088 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 07-25-2011, 07:52 AM #2
FirstTarget
 
 
Join Date: Jun 2005
It is the cup seal. Included is a link to a spyder kit. It is the white two diameter piece.
http://www.paintball-discounters.com...-parts-kit.htm

Here is parts diagram:
http://www.wolfpackpaintballteam.com...agleXtreme.gif
Bolt bumper, part#12 puts stress on connecting pin, part #6. It is better to put a bumper in line with part #25, which is the way the rest of STBB are made. This is really the only real problem with the original setup. Hope this helps.
FirstTarget is offline   Reply With Quote
Old 07-25-2011, 11:19 AM #3
dom088
 
 
dom088's Avatar
 
Join Date: Jun 2011
Location: Canada
thanks!

in the diagram part #27.... is backwards on my gun....
the tip of the rod is threaded if i am correct???
dom088 is offline   Reply With Quote
Old 07-25-2011, 12:09 PM #4
dom088
 
 
dom088's Avatar
 
Join Date: Jun 2011
Location: Canada
http://www.smartpartsparts.com/Produ...=6234&CartID=1

this is the correct seal... right?

this would be the cause of a massive barrel leak... and feedneck leak when cocked??

i cant shoot the gun... its like it doesnt have enough pressure to operate the gun since its leaking out of the barrel...
dom088 is offline   Reply With Quote
Old 07-25-2011, 04:08 PM #5
Fubarius
Yep, it's orange.
 
Fubarius's Avatar
 
Join Date: Aug 2003
Location: New Richmond, WI
Annual Supporting Member
 has been a member for 10 years
Fubarius supports our troops
Fubarius has achieved Level 1 in PbNation Pursuit
Fubarius has achieved Level 2 in PbNation Pursuit
Fubarius is a Forum Captain
The seal might not need replacing. Often Raptors are dry fired too much (cocking and pulling the trigger with no air source on the gun), this causes a dent on the back side of the valve which jams the valve pin open.

Pull out the valve and check that the valve pin slides freely in and out of the valve.
__________________
David Johnson, AKA Fubarius.

000110 200 11202 10 000020
012211 021 22110 22 121101
222001 222 10220 00 022212
Fubarius is offline   Reply With Quote
Old 07-25-2011, 05:32 PM #6
dom088
 
 
dom088's Avatar
 
Join Date: Jun 2011
Location: Canada
Quote:
Originally Posted by Fubarius View Post
The seal might not need replacing. Often Raptors are dry fired too much (cocking and pulling the trigger with no air source on the gun), this causes a dent on the back side of the valve which jams the valve pin open.

Pull out the valve and check that the valve pin slides freely in and out of the valve.


im a little bit of a durp with BE guns.....
i am not even sure where this valve pin is...
it has been dry fired i will tell you this..
dom088 is offline   Reply With Quote
Old 07-25-2011, 05:45 PM #7
Fubarius
Yep, it's orange.
 
Fubarius's Avatar
 
Join Date: Aug 2003
Location: New Richmond, WI
Annual Supporting Member
 has been a member for 10 years
Fubarius supports our troops
Fubarius has achieved Level 1 in PbNation Pursuit
Fubarius has achieved Level 2 in PbNation Pursuit
Fubarius is a Forum Captain
From the above diagram, valve pin (part number 17) gets stuck inside the valve (part number 18).
__________________
David Johnson, AKA Fubarius.

000110 200 11202 10 000020
012211 021 22110 22 121101
222001 222 10220 00 022212
Fubarius is offline   Reply With Quote
Old 07-25-2011, 08:06 PM #8
dom088
 
 
dom088's Avatar
 
Join Date: Jun 2011
Location: Canada
thats not stuck in there...
i took it apart and it slid out with no issues.
dom088 is offline   Reply With Quote
Old 07-25-2011, 08:34 PM #9
dom088
 
 
dom088's Avatar
 
Join Date: Jun 2011
Location: Canada
alright guys!
i fixed it, it was the seal... wasnt making proper connection.


now when i shoot it will shoot.. but it does the full auto sometimes (same as when there is low pressure in the tank).. i have about 1500 psi in my HPA tank..
whats this from?
dom088 is offline   Reply With Quote
Old 07-25-2011, 09:20 PM #10
Fubarius
Yep, it's orange.
 
Fubarius's Avatar
 
Join Date: Aug 2003
Location: New Richmond, WI
Annual Supporting Member
 has been a member for 10 years
Fubarius supports our troops
Fubarius has achieved Level 1 in PbNation Pursuit
Fubarius has achieved Level 2 in PbNation Pursuit
Fubarius is a Forum Captain
Well, that's blowback basics.

Make sure gun is clean.
Make sure gun is well lubed. Use oil, NOT grease.
Check hammer o-ring. Make sure it's in good condition.
Check bolt o-rings, make sure they're not swollen (it causes drag).

And for a Raptor specific issue. Look on the back face of the valve. There's two holes, one in the middle, and a smaller one a little offset from the middle. The smaller one is the gas path for the recock gas. Try to make the valve is rotated so that the little hole is on the top, or else the valve retention screw might block it and give the gun less recock force.
__________________
David Johnson, AKA Fubarius.

000110 200 11202 10 000020
012211 021 22110 22 121101
222001 222 10220 00 022212
Fubarius is offline   Reply With Quote
Old 07-25-2011, 09:41 PM #11
dom088
 
 
dom088's Avatar
 
Join Date: Jun 2011
Location: Canada
alright i am lost... haha

orings are all fine and not swollen
dom088 is offline   Reply With Quote
Old 07-26-2011, 08:54 AM #12
melkson
Raptor Guru
 
melkson's Avatar
 
Join Date: Jan 2005
Location: Central CO
check out my raptor troubleshooting guide. Should help alot.

http://www.pbnation.com/showthread.php?t=3060961
melkson is offline   Reply With Quote
Old 07-26-2011, 11:54 AM #13
dom088
 
 
dom088's Avatar
 
Join Date: Jun 2011
Location: Canada
problems fixed!
thanks alot guys!
dom088 is offline   Reply With Quote
Old 07-30-2011, 06:34 PM #14
kebone
I am qmto on youtube.
 
kebone's Avatar
 
Join Date: Jul 2007
kebone is playing at Living Legends V
kebone owns a Planet Eclipse Ego
kebone owns a Planet Eclipse Ego
kebone has achieved Level 2 in PbNation Pursuit
Another happy brass eagle user! Sucess! lol, sorry i didnt see this sooner.
__________________
That Brass Eagle guy.

i like that site-which-shall-not-be-named.
http://www.youtube.com/user/qmto?blend=1&ob=4#p/a

KEVIN'S CLASSIC ELECTRO SALE
kebone is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump