Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 08-15-2011, 01:04 AM #1
meatwad969
PSN: thebuttninja
 
meatwad969's Avatar
 
Join Date: Jul 2007
Location: 707
i just dont know where else to turn. (MQ1 issue)

so i have this old gen1 MQ valve. its silver. its missing the rear valve oring.

its got issues. for instance, the oring that seals the valve intake port performs a poor seal every 5th or so cycle, resulting in "plup plup plup PPSSSSHHHHHHH" -- no matter where my pressures are at. from zeroing out the HPR and turning it up 1/8th turns, eventually it will reach the point where there is a noticeable air discharge and then a horrid leak.

unfortunately i havent had an Ecocker for about a year now, and when i picked up the old MQ valve it didnt work for me then, so now im trying to refur'b it. id like to know the O ring sizes, and order a batch of replacement orings.

**since i havent had an Ecocker for a year, i have no clue what my dwell settings were at back then**

thanks for any input.
-meat
meatwad969 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 08-16-2011, 12:00 AM #2
meatwad969
PSN: thebuttninja
 
meatwad969's Avatar
 
Join Date: Jul 2007
Location: 707
i was informed it was a pressure issue, i had a CP reg at the time and couldnt fine tune my pressures like i thought i was.
meatwad969 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump