Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 07-10-2010, 08:40 PM #1
burnie11
 
 
Join Date: May 2009
luxe leak

alright guys just got a couple simple questions im sure someone can answer..
1. is there any other orings then the smaller white one that goes on the end of tube, that would cause a leak between the frame and body? pretty much what is happening is when its gassed up no leak...wait 10secs a leak starts, then if you take a shot it will stop and wait 10secs leak starts again and only leaks when it sits for more then 10secs not shooting... any ideas?

2. what would cause the luxe to discharge a small amount of air out of the backcap, only when shooting a ball?

just fyi, 2 different luxes, and any help with these problems would much be appriciated

Last edited by burnie11 : 07-10-2010 at 08:52 PM.
burnie11 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 07-10-2010, 09:17 PM #2
Ragin Cajun
CLICK, CLICK, BOOM
 
Ragin Cajun's Avatar
 
Join Date: Dec 2001
Location: South Louisiana
Annual Supporting Member
Ragin Cajun is a founding member
Ragin Cajun is one of the top 1000 posters on PbNation
Ragin Cajun is a Forum Captain
1. The leak from the grip frame is the reg creeping. Take the reg off and clean it.
2. The luxe discharges air from the noid every shot. This is normal.
Ragin Cajun is offline   Reply With Quote
Old 07-10-2010, 09:23 PM #3
burnie11
 
 
Join Date: May 2009
Quote:
Originally Posted by Ragin Cajun View Post
1. The leak from the grip frame is the reg creeping. Take the reg off and clean it.
2. The luxe discharges air from the noid every shot. This is normal.
thanks ragin
1. just yesterday i took the reg apart and cleaned and lubed it, and the same problem still occured?
2.this is a more noticeable noise, and partly making my backcap pop up when i shoot, more then normal. have had my luxe for over a year and havent had this happen before

anything else you can think of? thanks again

both luxes r bone stock also if that helps
burnie11 is offline   Reply With Quote
Old 07-10-2010, 09:46 PM #4
uranjack
Marker Tech.
 
uranjack's Avatar
 
Join Date: Jul 2007
Location: California
uranjack posts videos on PbNation
uranjack plays in the APPA beginner division
uranjack supports DLX Technology
Try a normal macro line and asa combo. It doesn't mean that it was dirty because it was creeping. Replace the 20/70 on the latch. Not the one that keeps the latch down but the one that goes into the body.
__________________
Eddie Tamao Fan#23


Current Markers: Red/Black Ego8, Redz Black/Red Ego7, Black/Black NXT, Black/Gold XSV SL74, Gold/Black Ego11
uranjack is offline   Reply With Quote
Old 07-10-2010, 10:50 PM #5
burnie11
 
 
Join Date: May 2009
Quote:
Originally Posted by uranjack View Post
Try a normal macro line and asa combo. It doesn't mean that it was dirty because it was creeping. Replace the 20/70 on the latch. Not the one that keeps the latch down but the one that goes into the body.
thanks alot i shall try those and get back to u guys shortly, if anything else comes to mind plz post, thanks again
burnie11 is offline   Reply With Quote
Old 07-14-2010, 08:57 PM #6
burnie11
 
 
Join Date: May 2009
hey guys so i tried the marco reg/asa combo, no leak, took a bunch of shot and let the gun sit for 10min and no leak again. put the luxe reg back on aired it up and leaking, take a shot and same thing again.
so my question is, is there a way to service the reg, or will it need a whole new one.
Secondly the other leak outta the backcap stopped, i didnt change any orings just cleaned and relubed the one that was there and been fine since. thanks again guys
burnie11 is offline   Reply With Quote
Old 07-14-2010, 09:22 PM #7
uranjack
Marker Tech.
 
uranjack's Avatar
 
Join Date: Jul 2007
Location: California
uranjack posts videos on PbNation
uranjack plays in the APPA beginner division
uranjack supports DLX Technology
I would call darryl to see what he has available.
__________________
Eddie Tamao Fan#23


Current Markers: Red/Black Ego8, Redz Black/Red Ego7, Black/Black NXT, Black/Gold XSV SL74, Gold/Black Ego11
uranjack is offline   Reply With Quote
Old 07-15-2010, 06:37 AM #8
Ragin Cajun
CLICK, CLICK, BOOM
 
Ragin Cajun's Avatar
 
Join Date: Dec 2001
Location: South Louisiana
Annual Supporting Member
Ragin Cajun is a founding member
Ragin Cajun is one of the top 1000 posters on PbNation
Ragin Cajun is a Forum Captain
I'd also check the 17-90 Oring on the top of the reg. Not the one on the tip but the one below it.
Ragin Cajun is offline   Reply With Quote
Old 07-15-2010, 09:12 PM #9
burnie11
 
 
Join Date: May 2009
thx again guys
burnie11 is offline   Reply With Quote
Old 07-18-2010, 03:48 PM #10
burnie11
 
 
Join Date: May 2009
so the leak from the backcapped stopped for 1 day of play, then today i aried my gun up to play and started doing it again. i refered to the bolt diagram and changed all orings where it said a leak in the backcap wud be caused by. and nothing still leaking for 5 secs when i take a shot. i also tried another luxe reg on my gun just to be sure it wasnt the reg creeping and it wasnt? could this have anything to do with my feather touch? help guys thanks
burnie11 is offline   Reply With Quote
Old 07-23-2010, 07:48 PM #11
burnie11
 
 
Join Date: May 2009
any ideas guys?
burnie11 is offline   Reply With Quote
Old 07-23-2010, 09:02 PM #12
Evac.
Wolfpack
 
Evac.'s Avatar
 
Join Date: Sep 2009
Location: Queens
Annual Supporting Member
Evac. is a Paintball photographer
Evac. plays in the PSP
did you change the oring between the body and frame?
Evac. is offline   Reply With Quote
Old 07-24-2010, 08:16 PM #13
burnie11
 
 
Join Date: May 2009
Quote:
Originally Posted by Evac. View Post
did you change the oring between the body and frame?
no i did not, however today i switched bolts with a known working luxe and the problem stopped, i then went piece by piece switching out each part of the bolt and testing, finally when i put the known working backcap piece on the other 3 parts of my bolt the problem stopped. however i changed all 3 orings on the backcap and the latch oring already, only ones i havent changed are the 2 tiny ones (but if it were them it would leak when normally aired) maybe ill try changing the orings again, not sure what else to do?
burnie11 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump