Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 05-02-2010, 06:12 PM #1
james12147
 
 
Join Date: Jan 2010
broken slg help

ok so i bought a broken slg from a guy for really cheap thinking if i can get it to work itd be great. the problem is, I have no clue about anything with the gun since i didnt get a manual. the actual problem with the slg is when i put in the HPA tank, it won't dry fire or shoot any paint, the trigger will just click. if i press the bleed button thing in the back air leaks out. also, he said he had never opened it up. so if anyone can give me a place to start to try to fix this or point me in the right direction it'd be much appreciated
james12147 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 05-02-2010, 07:22 PM #2
Cayguide
 
 
Join Date: Mar 2010
Here is a link to a pdf of the manual: LINK

So are you saying that you pull the trigger and you get the click of the solenoid, but no shot? What are the LEDs on the back of the grip doing while this is going on? Are they blinking? First thought is replace the battery. Next thought would be to clean the eyes, or at least try to fire with the eyes turned off. After that, call Dye!

My SLG was doing the clicking thing, tried everything. Called Dye and they fixed it up for me.
Cayguide is offline   Reply With Quote
Old 05-02-2010, 07:58 PM #3
james12147
 
 
Join Date: Jan 2010
yep it clicks when I pull the trigger but it doesn't shoot. and the led is blinking red when I shoot with nothing in it but if I load a ball the light turns solid green, so I don't think the eyes are the problem. i'll give dye a call tomorrow though and i'll try shooting with eyes off too and I'll also pick up a new 9 volt
james12147 is offline   Reply With Quote
Old 05-02-2010, 08:39 PM #4
Cayguide
 
 
Join Date: Mar 2010
Just so you know for when you call, they fixed my seer and honed my breach. I had the same exact symptoms as you are describing. Took 2.5 weeks from shipping to them to receiving. Shoots great now.
Cayguide is offline   Reply With Quote
Old 05-02-2010, 09:19 PM #5
james12147
 
 
Join Date: Jan 2010
well I'm not really worried about the time it takes to fix it as long as it works. and is there a fee for sending it in and having it fixed because I don't have a warranty, and if so, how much? also, would it matter that I'm not the original owner of the gun? thanks.
james12147 is offline   Reply With Quote
Old 05-03-2010, 09:56 AM #6
The Inflicted
.detcilfnI ehT
 
The Inflicted's Avatar
 
Join Date: Jan 2002
Location: Chattanooga, TN
Cayguide is probably right about that battery.
Try a brand-new Energizer or Duracell alkaline and see what happens.
The SLG doesn't like dollar store batteries.
The Inflicted is online now   Reply With Quote
Old 05-03-2010, 02:12 PM #7
james12147
 
 
Join Date: Jan 2010
ok I put in a brand new duracell alkaline & its still doing the same thing, gassed it up, no leaks anywhere. put one ball in, the LED turned solid green, so it recognized the ball. but then i pulled the trigger and instead of firing it just clicks. then after i clicked it once it went to a blinking green LED. but im gonna give dye a call.

EDIT: I called dye and the guy told me i need to hone the breech with a honing tool, so while i'm taking apart the gun i'm gonna clean everything and change/lube the o rings. i don't exactly know how to hone a breech, can anyone give me any tips with that & does the suggestion of honing the breech sound like it'll fix the problem?

EDIT #2: i completely disassembled, cleaned, and re assembled almost every part. it was a little tough taking the bolt out so im pretty sure the breech honing fix is the way to make it work. but now would filing down the bolt be a better alternative? because thats what i did with my spyder electra when the bolt was getting stuck (even though that bolt is plastic and easy to sand down)

Last edited by james12147 : 05-03-2010 at 03:48 PM.
james12147 is offline   Reply With Quote
Old 05-03-2010, 03:53 PM #8
Cayguide
 
 
Join Date: Mar 2010
Why not send it to Dye and let them fix it? surely it is under warranty as honing a breech would be considered a manufacturer defect
Cayguide is offline   Reply With Quote
Old 05-03-2010, 04:26 PM #9
james12147
 
 
Join Date: Jan 2010
well I would do that but I don't have the warranty I was just given a broken gun. so I'm just gonna try to fix it myself or have a local shop help me
james12147 is offline   Reply With Quote
Old 05-03-2010, 07:44 PM #10
Cayguide
 
 
Join Date: Mar 2010
I bet you $$ they will take care of you. They sold a gun with too small a breech, that is a mfr defect they will take care of. Plus, from what I have seen, they take great care of the folks who run their gear. PM one of the service reps here and I bet they help you out.
Cayguide is offline   Reply With Quote
Old 05-03-2010, 08:13 PM #11
james12147
 
 
Join Date: Jan 2010
thanks, i'll try that. how do i find a service rep, though?
james12147 is offline   Reply With Quote
Old 05-04-2010, 09:03 AM #12
Cayguide
 
 
Join Date: Mar 2010
Call their 800# or look in these forums for replies from techs. They will have an icon under their user name saying they are a manufacturer rep.
Cayguide is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump