Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 04-19-2010, 11:19 AM #1
varq
 
 
Join Date: Jul 2007
GEO not rapid firing

Hi all,

Need some help.

Geo with ST Kit and GR2
Tank- Crossfire with new CF reg and PMI Pure energy High output
Dwell 14.5
I am registered with PE 00535

Ive been using this gun flawlessly since Nov 2008. This weekend i encountered my first problem. Shoots fine when I take one shot at a time and chronos consistent at 270 +- 5. When I rapid fire the paint goes no where.... sometimes loads 2 or 3 balls in the barrel and the gun just stops blasting.

I took apart the frame assembly and cleaned the red gasket and filter. The filter was dirty. The gasket looked good.. and i put it back together,.. same problem.. I took it apart again and now i think I have a leak in that area and still experience the same problem. I also replaced the orings on the bolt , can and shaft as the manaul instructed... but getting bolt stick in rapid fire since the gun isnt getting the pressure it needs. I also took the regulator apart cleaned and relubed...

Not sure what else to do if anyone has any ideas.. Last resort is to send to Gerry in Rhode Island.

thanks
varq is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 04-19-2010, 03:07 PM #2
Snakeorbust
 
 
Join Date: May 2008
Hey I had the exact same problem two weeks ago. Still haven't fixed it, but I did find that if I put the stock bolt in it worked fine. Tried that yet?
__________________
USMC Paintballer
Snakeorbust is offline   Reply With Quote
Old 04-19-2010, 03:08 PM #3
Tagachi
 
 
Tagachi's Avatar
 
Join Date: Sep 2009
Location: Norway
Tagachi owns a Planet Eclipse Geo
Tagachi supports Bob Gurnsey
have u changed battery?
__________________
MacDev Clone /Gloss Black
PE Geo /Lagoon
Tagachi is offline   Reply With Quote
Old 04-19-2010, 05:45 PM #4
varq
 
 
Join Date: Jul 2007
i did change the battery twice.. didnt fix it... but i have not tried the stock bolt... will try that and report back
varq is offline   Reply With Quote
Old 04-19-2010, 06:08 PM #5
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
Service the reg.

Service the solenoid.

Service the bolt assembly.

Make sure that the bolt can move freely.

Screw the ASA knob in to ensure that the bottle valve is fully open.

Conversely, if you are already screwing the ASA knob in all the way, try backing it out 1/2 - 1 turn. With some combinations of tank and ASA, screwing the degassing pin in too far can actually block air flow from the air system.
Uziel Gal is offline   Reply With Quote
Old 04-20-2010, 07:28 PM #6
varq
 
 
Join Date: Jul 2007
I tried the old bolt and didnt work... I serviced the noid, reg etc... no luck. gonna have to send it in. will update findings in case someone else runs into this.
varq is offline   Reply With Quote
Old 04-21-2010, 09:01 AM #7
bmoney003
187 cRew it's Murda!!
 
bmoney003's Avatar
 
Join Date: Oct 2006
Location: Rhody
bmoney003 is a Professional paintball player
bmoney003 plays in the PSP
bmoney003 owns a Planet Eclipse Geo
you need a new noid....I had the exact same thing last week...replaced the ball check..which allowed for rapid fire...but still had a leak. Big bill replaced the whole noid...said it was unserviceable..

its warranteed...so no worries
__________________
Fox4paintball
| Planet Eclipse |
bmoney003 is offline   Reply With Quote
Old 05-01-2010, 08:41 PM #8
varq
 
 
Join Date: Jul 2007
new noid is right, thats was replaced and now back to normal
varq is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump