Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 04-19-2010, 02:49 AM #1
OG Mooninite
 
 
OG Mooninite's Avatar
 
Join Date: Oct 2009
Location: Eureka
OG Mooninite owns a Planet Eclipse Geo
OG Mooninite owns a Planet Eclipse Ego
OG Mooninite supports Team VICIOUS
Geo making very strange noise after every shot

So like the title says, everytime i shoot my geo its make a very strange noise. It sounds almost like plastic gears grinding, and i checked my rotor and it definitely wasnt coming from there.

It sounds almost like a wind up top being spun on the ground, and it started getting longer the more i shot. i took out the bolt and everything, cleaned it and made sure everything looked good, and then tried again and it still happened, but it was louder

everything else is fine, and even when ripping it fires fine. I wanted to know what this could be, as i know it cant be good

Thanks in advance for the help!
__________________
Team Insidious


Sponsored by:

Revolution Paintball
OG Mooninite is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 04-19-2010, 04:13 AM #2
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
Check the Propshaft for cracks - cracked Props have been known to make all kinds of funny noises.
Uziel Gal is offline   Reply With Quote
Old 04-19-2010, 02:14 PM #3
OG Mooninite
 
 
OG Mooninite's Avatar
 
Join Date: Oct 2009
Location: Eureka
OG Mooninite owns a Planet Eclipse Geo
OG Mooninite owns a Planet Eclipse Ego
OG Mooninite supports Team VICIOUS
well after shooting it more, about 30-40 balls and it stopped making the noise



and what could have caused my prop shaft to break?
__________________
Team Insidious


Sponsored by:

Revolution Paintball
OG Mooninite is offline   Reply With Quote
Old 04-19-2010, 02:24 PM #4
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
If the marker has been fired without the Prop bumper in place, it can crack. There may be other reasons, but that's the obvious one that springs to mind.
Uziel Gal is offline   Reply With Quote
Old 04-19-2010, 03:37 PM #5
OG Mooninite
 
 
OG Mooninite's Avatar
 
Join Date: Oct 2009
Location: Eureka
OG Mooninite owns a Planet Eclipse Geo
OG Mooninite owns a Planet Eclipse Ego
OG Mooninite supports Team VICIOUS
so should i replace my o-ringsw on my prop shaft then?

its not doing it anymore, and i checked it and it doesnt look like there is any damage
__________________
Team Insidious


Sponsored by:

Revolution Paintball
OG Mooninite is offline   Reply With Quote
Old 04-19-2010, 04:04 PM #6
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
If the bumper looks worn, then it is definitely worth replacing. If too much of it wore away, or it broke off, then it could definitely be bad for your marker.
Uziel Gal is offline   Reply With Quote
Old 04-20-2010, 02:31 PM #7
OG Mooninite
 
 
OG Mooninite's Avatar
 
Join Date: Oct 2009
Location: Eureka
OG Mooninite owns a Planet Eclipse Geo
OG Mooninite owns a Planet Eclipse Ego
OG Mooninite supports Team VICIOUS
any other possible causes? cause i mean, if my prop shaft was cracked or the bumpers were work down it would still do it right?

and it stopped after shooting it a bit
__________________
Team Insidious


Sponsored by:

Revolution Paintball
OG Mooninite is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump