Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 03-22-2010, 02:32 PM #1
akeroso
 
 
Join Date: Mar 2010
SLG 2010 Help

hi, my brother bought an SLG 2010 about a week ago and the day it arrived we gassed it up and shot it and it broke paint around the 10th or 15th shot. We were using an Invert TOO loader at the stock configuration it comes in. We cleaned it up and lubed it and yesterday we shot it again but this time with an Empire Prophecy loader. It chopped again around the 10th shot and I saw that the paintball was halfway down the feedneck when the gun chopped. I started searching the net and read that this could be due to the loaders being too fast and causing ball jumps inside the feedneck.

Could this be because of the hopper?

What else can I do to fix this problem?

Has anyone experienced anything similar?

Thanx
akeroso is offline   Reply With Quote
Old 03-22-2010, 02:33 PM #2
akeroso
 
 
Join Date: Mar 2010
it seems like whenever I go past 3-4 bps a ball gets stuck between the chamber and the feed-neck [eyes on]. I re-lubed, checked the detents, orings, cleaned the eyes.. everything. Even lowered the pressure down a bit but it still did the same thing. Could this be the hopper feeding too fast? However I doubt it because I am shooting semi auto slowly.
akeroso is offline   Reply With Quote
Old 04-20-2010, 01:09 PM #3
blackjack5566
 
 
blackjack5566's Avatar
 
Join Date: Mar 2010
Location: 951 SC VILLAGE!!!
blackjack5566 owns a Planet Eclipse Geo
blackjack5566 owns a Planet Eclipse Ego
blackjack5566 supports Team VICIOUS
blackjack5566 is for the Gunfight
The thing about slg, is that there tested with rotors at dye, so you have to have a good hopper like a rotor or halo too. the empire should keep up. This is weird, reduce the torque on the prophecy and see if that helps. The pressure on the balls might be the problem
__________________
HHHHH!!!!
DYE NT OWNERS UNITED
BLACK AND GRAPHITE DM10
blackjack5566 is offline   Reply With Quote
Old 04-20-2010, 03:16 PM #4
Josh49
 
 
Josh49's Avatar
 
Join Date: Apr 2010
I would check to make sure the paint is of good quality as well as make sure there isnt to much lube on the bolt o-rings. Good luck and I hope someone can help with your isue.
__________________
Guns: Invert Mini & Proto SLG
Josh49 is offline   Reply With Quote
Old 04-20-2010, 03:58 PM #5
jonotwist
fistfull o'sunshine & joy
 
jonotwist's Avatar
 
Join Date: Sep 2006
Location: NE ohio
Annual Supporting Member
jonotwist is playing at Living Legends VII
jonotwist plays in the APPA D4 division
jonotwist supports Empire
the question neede to figure out the problem is whether the gun is actually chopping paint or not. (barrel break, crushed ball, ect)
__________________
Speak, if you have ought to say worth the listening
vintage old feedback High Tech Shiny Feedback

-You want money, I need stuff.- PM ME!

ego 5/6 ETEK feednecks, .45 grips, Boblong directmount ASA, spyder Unitec back.
jonotwist is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump