Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 01-19-2010, 02:16 AM #1
fabio92
 
 
fabio92's Avatar
 
Join Date: Jul 2008
geo HELP

my geo was working fine the other day but then last game the bolt jammed. i de-gassed the gun and checked everything out and everything seems ok. when i gas up the gun it wont shoot. the battery is fresh and there is enough air in the tank. the setting are all stock still and no upgrades to the gun. when i pull the trigger and everything is on the board chirps like usual but it wont shoot and it leaks down the bolt. help me out guys. PM ME
fabio92 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 01-19-2010, 03:04 AM #2
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
Moved to the Geo forum.

First things first, you say that the board "chirps" - is the board set to training mode?
Uziel Gal is offline   Reply With Quote
Old 01-19-2010, 10:02 AM #3
Team Capital Offense
 
 
Join Date: Mar 2006
Team Capital Offense owns a Planet Eclipse Geo
sounds like training mode.

for the Leak down the bolt, check inner can oring, 14x2 prop shaft oring and possibly front outer can oring. Also, check your 14x2 on the bolt...not because of the leak but for misfiring issue (in case it isnt in training)
__________________
Proudly Sponsored By:
ATN Corp., Planet Eclipse, VFORCE, Full Clip USA, Flurry Industries, Tarjac Inc., Command Decisions, Splatbrothers Paintball Facebook: Team Capital Offense
Team Capital Offense is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump