Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 10-12-2009, 03:56 PM #1
blvictory
 
 
Join Date: Jul 2009
bob long victory velocity problem

hey guys im having a problem with my victory..for some reason i cant get my velocity to go up above 260 fps.....i have an lpr/hpr tester and presure is set to lpr 80psi and hpr 220psi...even if i turn up my hpr my velocity still stays in the 260fps range..please help thanx
blvictory is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 10-12-2009, 04:09 PM #2
xeese
Mangled Manual Maker
 
xeese's Avatar
 
Join Date: Dec 2006
Location: North Carolina
xeese works for a Paintball manufacturer
xeese supports our troops
How is your paint to bore match?
__________________
BLAST Manual Specialist

Best boards in the business
xeese is offline   Reply With Quote
Old 10-12-2009, 04:17 PM #3
blvictory
 
 
Join Date: Jul 2009
over bore .693 even with .691 still wont go up
blvictory is offline   Reply With Quote
Old 10-12-2009, 04:30 PM #4
Davvid
Capital Edge Hitters
 
Davvid's Avatar
 
Join Date: Dec 2003
Location: Folsom, Ca. 916
 has been a member for 10 years
Quote:
Originally Posted by blvictory View Post
over bore .693 even with .691 still wont go up
I think Xeese is on your answer. 691 and 693 are to big for paint nowa days. I just bumped down from a 689 to a 685 and she is shooting great. I used a 685 at the World Cup last week shooting 295fps useing gold,silver,and evil all shot great with no breaks that I saw.
Davvid is offline   Reply With Quote
Old 10-12-2009, 04:35 PM #5
blvictory
 
 
Join Date: Jul 2009
i will try that thanks......if my battery was low with it mess with the velocity also?
blvictory is offline   Reply With Quote
Old 10-12-2009, 04:36 PM #6
Nemesis75
 
 
Nemesis75's Avatar
 
Join Date: Aug 2007
Location: Miami, FL
yeah if the battery is low change it.
Nemesis75 is offline   Reply With Quote
Old 10-12-2009, 04:39 PM #7
blvictory
 
 
Join Date: Jul 2009
i tried raising my hpr and still shoots 260fps range i mean it shouid atleast go up even if i over bore
blvictory is offline   Reply With Quote
Old 10-12-2009, 04:42 PM #8
Nemesis75
 
 
Nemesis75's Avatar
 
Join Date: Aug 2007
Location: Miami, FL
youre screwing it in right? look up the manual on boblongdirect.com that should help.
Nemesis75 is offline   Reply With Quote
Old 10-12-2009, 04:48 PM #9
blvictory
 
 
Join Date: Jul 2009
ya i have the manual and i have the tester pressure is set to factory it was working when i first got it then the last 2 times i used it started crappin out....i also a have a vice and i've never had a problem with it
blvictory is offline   Reply With Quote
Old 10-12-2009, 04:54 PM #10
wyn1370
...---...
 
wyn1370's Avatar
 
Join Date: Dec 2001
Location: Waterford, MI
Annual Supporting Member
wyn1370 is a Supporting Member
wyn1370 is a founding member
 has been a member for 10 years
wyn1370 donated to help Peyton Trent
wyn1370 owns a Planet Eclipse SLS
wyn1370 owns a Planet Eclipse CSL
try a different tank. the on/off may be pushing the pin valve in too far or not enough.
__________________
Originally posted by manike
"Pants are only worn on the outside by Americans, Canadians and Superhero's..."
wyn1370 is online now   Reply With Quote
Old 10-12-2009, 05:11 PM #11
blvictory
 
 
Join Date: Jul 2009
went and tried a different tank still the same result...... is anyone having the same problem?
blvictory is offline   Reply With Quote
Old 10-12-2009, 05:23 PM #12
Greeblesnort
His Supreme Geekness
 
Greeblesnort's Avatar
 
Join Date: Jul 2008
Location: in a house
Greeblesnort donated to help Peyton Trent
Greeblesnort owns a Planet Eclipse Ego
Greeblesnort supports Team VICIOUS
yes, I had this exact same problem two weekends ago at the Vicious streetball event. So did another victory owner.

I tore mine down and re-lubed it and believe that I've got it corrected now. However, I'm running 80/230 to get a not-very-consistent 270-280fps. A couple of my other suspicions (on mine anyway), is that I've still got a white donut, and it was a little cool that day and I noticed that when I tore it down to re-lube, I don't think the front and back of the engine were snugged down.

Is it possible (or likely) that the two outer pieces could work just a little loose? Would that cause a velocity problem?

edit: my thread on essentially the same problem

edit2: I don't think barrel match was the problem that day, as I was using a Furious .685

edit3: bumping my dwell up to 8 seemed to help a little, but it was still horribly inconsistent

if you find a solution, please let me know as well =)

Last edited by Greeblesnort : 10-12-2009 at 05:33 PM.
Greeblesnort is offline   Reply With Quote
Old 10-12-2009, 05:25 PM #13
Nemesis75
 
 
Nemesis75's Avatar
 
Join Date: Aug 2007
Location: Miami, FL
have you tried resetting your regs?
Nemesis75 is offline   Reply With Quote
Old 10-12-2009, 05:30 PM #14
blvictory
 
 
Join Date: Jul 2009
oh i c well atleast your fps goes up...even if i raise my hpr higher than 230 my velocity still around 260-265fps.........its just a piss off cuz it was shooting great in the begining....have u called blast?
blvictory is offline   Reply With Quote
Old 10-12-2009, 05:31 PM #15
blvictory
 
 
Join Date: Jul 2009
i have reseted my regs...but will try again thank you
blvictory is offline   Reply With Quote
Old 10-12-2009, 05:36 PM #16
blvictory
 
 
Join Date: Jul 2009
Quote:
Originally Posted by Greeblesnort View Post
yes, I had this exact same problem two weekends ago at the Vicious streetball event. So did another victory owner.

I tore mine down and re-lubed it and believe that I've got it corrected now. However, I'm running 80/230 to get a not-very-consistent 270-280fps. A couple of my other suspicions (on mine anyway), is that I've still got a white donut, and it was a little cool that day and I noticed that when I tore it down to re-lube, I don't think the front and back of the engine were snugged down.

Is it possible (or likely) that the two outer pieces could work just a little loose? Would that cause a velocity problem?

edit: my thread on essentially the same problem

edit2: I don't think barrel match was the problem that day, as I was using a Furious .685

edit3: bumping my dwell up to 8 seemed to help a little, but it was still horribly inconsistent

if you find a solution, please let me know as well =)
ya i also have the white donut....if i find a solution ill let u know...and thanx for the help much appreciated
blvictory is offline   Reply With Quote
Old 10-12-2009, 05:40 PM #17
Greeblesnort
His Supreme Geekness
 
Greeblesnort's Avatar
 
Join Date: Jul 2008
Location: in a house
Greeblesnort donated to help Peyton Trent
Greeblesnort owns a Planet Eclipse Ego
Greeblesnort supports Team VICIOUS
well, I may just call Blast to see if they'll send me a new donut even if I'm not having the really bad problems associated with the bad white ones.
Greeblesnort is offline   Reply With Quote
Old 10-12-2009, 05:50 PM #18
blvictory
 
 
Join Date: Jul 2009
Quote:
Originally Posted by Greeblesnort View Post
well, I may just call Blast to see if they'll send me a new donut even if I'm not having the really bad problems associated with the bad white ones.
u mind filling me in after u talk to them....thanx
blvictory is offline   Reply With Quote
Old 10-12-2009, 06:13 PM #19
Banger5
v THE MAN v
 
Banger5's Avatar
 
Join Date: May 2008
You can also send you victory in to get the supercharger kit which solves all velocity problems

it includes a new bolt, donut, blast guide/poppet shaft, and ram shaft
__________________
I GUP FOR SCRUB STATUS

Chris Silber Support Group

"I close my eyes, but all I see is red.
I bite my tongue, but all I taste is blood. "
Banger5 is offline   Reply With Quote
Old 10-12-2009, 06:17 PM #20
blvictory
 
 
Join Date: Jul 2009
At what cost
blvictory is offline   Reply With Quote
Old 10-12-2009, 07:48 PM #21
wyn1370
...---...
 
wyn1370's Avatar
 
Join Date: Dec 2001
Location: Waterford, MI
Annual Supporting Member
wyn1370 is a Supporting Member
wyn1370 is a founding member
 has been a member for 10 years
wyn1370 donated to help Peyton Trent
wyn1370 owns a Planet Eclipse SLS
wyn1370 owns a Planet Eclipse CSL
$65 which includes return shipping
__________________
Originally posted by manike
"Pants are only worn on the outside by Americans, Canadians and Superhero's..."
wyn1370 is online now   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump