Low Batteries on a RM? - PbNation
Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

 
Archived Thread - Cannot Edit  
Old 11-07-2001, 03:07 PM #1
Thourne
Pump Gun Aficionado
 
Thourne's Avatar
 
Join Date: Nov 2001
Location: Morehead, KY
Thourne is a founding member
 has been a member for 10 years
Low Batteries on a RM?

I'm just curious...I've got a buddy I work with who bought a reconditioned RM a while back, and it's never really worked right (leaky cupseal or reg). Well we finally got those worked out and now the firing sequence in the gun doesn't work right...it's like the ram is moving too fast. I was wondering is this a low battery problem or something else. Thanks for your help in advance...
Thourne is offline  
Old Sponsored Links Remove Advertisement
Advertisement
Old 11-07-2001, 09:11 PM #2
-=JPaintball=-
 
 
Join Date: Sep 2001
Location: Minnesota
 has been a member for 10 years
maybe the same prob

Well i dont know if i can explain this right but it seemed like the same thing was wrong with a freinds rm that i was just working on... it was actually stopping short because the hammer/sear assembly piece was not functioning right...the sear would go down to far cuasing it not to catch the ram deal...it would just hit it and go back... the problem was that the sear wasnt able to catch the ram deal there...hard for me to explain but its sounds identicle... i just ordered a new hammer/sear peice...hope this helps a little
__________________
"Aim low they might be crawling"


2k1 C&C Deep Purple Angel
-=JPaintball=- is offline  
 




Posting Rules
Forum Jump