Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 07-30-2009, 01:30 PM #1
thejones
 
 
Join Date: May 2005
Broken quest...where to send it?

I got a quest on trade over a year ago and I've had a hell of a time getting it to work. I replaced the solenoid wire, bolt tube, got an o-ring kit, and had a local shop work on it. It appeared they got it working, and then as soon i got home and gassed it up...it stopped working. On top of this, the shop went out of business, so I have nowhere local to take it.

Is there a reputable shop/place I can send it to have it fixed?

Thanks in advance!
thejones is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 07-30-2009, 01:36 PM #2
spideyman1
Shark week continues!
 
spideyman1's Avatar
 
Join Date: Dec 2006
Location: South Jersey
send it to critical paintball
__________________
Feed Back Quest
Rowan University
Mechanical Engineering
spideyman1 is offline   Reply With Quote
Old 07-30-2009, 01:50 PM #3
bomb_xero
LIKE A BOSS
 
bomb_xero's Avatar
 
Join Date: Sep 2006
Location: 603
bomb_xero donated to help Peyton Trent
bomb_xero has achieved Level 1 in PbNation Pursuit
bomb_xero has achieved Level 2 in PbNation Pursuit
bomb_xero has achieved Level 3 in PbNation Pursuit
any idea whats wrong? tell us more and maybe we can help
__________________
THIS SPACE FOR RENT
bomb_xero is offline   Reply With Quote
Old 07-30-2009, 02:01 PM #4
thejones
 
 
Join Date: May 2005
The board appears to be working, and I can hear the solenoid clicking away. After removing and lubing the tube and pin, replacing ALL o-rings, it will fire once or twice and then seize. It's been a while since i've aired it up, so I can remember if it locks forward or back, but I believe it gets stuck in the forward position. It routinely shears one of the o-rings when this happens too (also...cant remember which one exactly.)

Does that vague info help at all?
thejones is offline   Reply With Quote
Old 07-31-2009, 08:28 AM #5
Uziel Gal
It's not a Geo2, honest..
 
Uziel Gal's Avatar
 
Join Date: Mar 2004
Location: London, UK
Uziel Gal donated to help Peyton Trent
Uziel Gal owns a Planet Eclipse Geo
Uziel Gal owns a Planet Eclipse Ego
Uziel Gal supports our troops
You say you've changed o-rings, so this may not be relevant, but then again, if you say that an o-ring was breaking each time, then maybe it is: -

http://www.pbnation.com/showthread.php?t=2913293

I would also check the inside of the bolt and the inside of the marker for scratches, and check the inside of the o-ring grooves on the bolt for hairline cracks.
Uziel Gal is offline   Reply With Quote
Old 07-31-2009, 10:24 AM #6
thejones
 
 
Join Date: May 2005
Thanks

I'll check those out when I go home and see if I can narrow down what the problem is.

I've heard they are great guns...but unfortunately I've never gotten a chance to use mine.
thejones is offline   Reply With Quote
Old 08-01-2009, 09:48 PM #7
ihaveorracle
 
 
ihaveorracle's Avatar
 
Join Date: May 2006
Exact same problem with mine as well. Never been able to play a full day with it. Please post solutions!
ihaveorracle is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump