Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 06-08-2009, 03:35 PM #1
PlayFront36
Now in HD!
 
PlayFront36's Avatar
 
Join Date: Aug 2003
Location: Illinois
 has been a member for 10 years
Board powering on by itself?

A buddy of mine has an Epiphany (dont tell me to go to the Epiphany forum...I posted there already without luck) and whenever the battery even touches the terminals of the 9V plug the board powers on. It does not allow him to shoot or anything. Just a blue light and mild chirping from time to time. Cant access anything. Ideas?
PlayFront36 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 06-08-2009, 03:36 PM #2
openingact
I Live My Life 300 fps
 
openingact's Avatar
 
Join Date: May 2007
Location: Menasha, WI
Is the powerbutton possible being pressed down by the button even without your finger on it?
__________________
Christ Krew Sons of Thunder CPPA
openingact is offline   Reply With Quote
Old 06-08-2009, 03:41 PM #3
danolin04
 
 
danolin04's Avatar
 
Join Date: Mar 2009
Location: northwest-not in WA
what kind of board is it? I had a virtue that turned on when the battery touched it. it even stayed on when i took the battery off which was kinda creepy. I called up V and they told me my board was toast. hopefully your friend either has a virtue cause they are covered or another warenteed board or this isn't the same problem. other symptoms of my board included no reaction when pushing the button or trigger and a rapidly blinking red light.
__________________
Pigs can fly, you just need a catapalt
danolin04 is offline   Reply With Quote
Old 06-08-2009, 03:50 PM #4
PlayFront36
Now in HD!
 
PlayFront36's Avatar
 
Join Date: Aug 2003
Location: Illinois
 has been a member for 10 years
The whole internal assembly is out of the marker and the button is free...nothing can push it down.

The board is Blackheart. Has been working fine until last weekend. Then it worked sporadically. Now its always on when the battery comes in contact.
PlayFront36 is offline   Reply With Quote
Old 06-08-2009, 04:03 PM #5
WillIbe
 
 
Join Date: Oct 2008
the power button is probably corroded, maybe try a little drop of WD40 on the button?
__________________
"Originally posted by PBMT: Oh, and btw, you worrying about grammar on internet forums is like watching a special olympics race judge yelling at a contestant for going outside of his lines on the track...no one cares and you look like an idiot doing so."
WillIbe is offline   Reply With Quote
Old 06-08-2009, 04:50 PM #6
PlayFront36
Now in HD!
 
PlayFront36's Avatar
 
Join Date: Aug 2003
Location: Illinois
 has been a member for 10 years
Sounds questionable. Will wait for other suggestions.
PlayFront36 is offline   Reply With Quote
Old 06-08-2009, 06:59 PM #7
danolin04
 
 
danolin04's Avatar
 
Join Date: Mar 2009
Location: northwest-not in WA
give sp a call and see what hey say. it's their board but like i said earlier even though it's a blackheart it has the same symptoms as mine. BTW did you power it up without the magnet in the noid or with the cap off the noid?
__________________
Pigs can fly, you just need a catapalt
danolin04 is offline   Reply With Quote
Old 06-08-2009, 07:24 PM #8
PlayFront36
Now in HD!
 
PlayFront36's Avatar
 
Join Date: Aug 2003
Location: Illinois
 has been a member for 10 years
Magnet in the solenoid? Cap off of it? The solenoid looks rickity enough as it is...Im not touching that thing.

Will call SP tomorrow. Anyone have a service number?
PlayFront36 is offline   Reply With Quote
Old 06-09-2009, 01:52 AM #9
danolin04
 
 
danolin04's Avatar
 
Join Date: Mar 2009
Location: northwest-not in WA
Quote:
Originally Posted by PlayFront36 View Post
Magnet in the solenoid? Cap off of it? The solenoid looks rickity enough as it is...Im not touching that thing.

Will call SP tomorrow. Anyone have a service number?
okay just saying that could make a board go screwy. heres the main SP number 800.992.2147 don't know how many automated computers your gonna have to listen to though.
__________________
Pigs can fly, you just need a catapalt
danolin04 is offline   Reply With Quote
Old 06-09-2009, 05:45 PM #10
snotshooter
Moose Gore
 
snotshooter's Avatar
 
Join Date: Sep 2005
Location: Sacto, CA
__________________
CBS= Crap Battery Syndrome
snotshooter is offline   Reply With Quote
Old 06-09-2009, 08:08 PM #11
skyflier43
\/\/Commence Drooling\/\/
 
skyflier43's Avatar
 
Join Date: Dec 2007
Location: with your mom!
skyflier43 posts videos on PbNation
skyflier43 has achieved Level 2 in PbNation Pursuit
I sent my blackheart in the other day, cause it was leaking and they sent it back to me and it works perfect, go on the website, submit a RMA form, and then send it into them, the east coast location, anyways in the box with the board, put a piece of paper, with ur RMA number and in like 10 days u should have it back, fixed.
skyflier43 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump