Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 04-05-2016, 11:04 AM #1
bond 559
 
 
Join Date: Feb 2016
reflex rail 2014 won't shoot

Ok so I recently bought a reflex rail and took it to the field and it shot like a beauty.... after cleaning my gun and lubing the bolt I tested it and it worked fine.....2 weeks later I took it to the field and the first couple games it shot fine but then I noticed that there was a ball rolling out every 2-3 time I pulled the trigger (semimode) as well as the shot and the pressure was inconsistent....so I changed the regulator seat and bought a new eye pipe with detents and now it don't shoot I watched a video on how to change the regulator seat and did it exactly the same I've looked my o rings and they seem fine....I really don't wanna take it to local shop and pay big bucks to fix so I'm on my last resort and to hoping that one of you can help me... So what I'm asking is I know there's a lot of reasons for reflex rail not too fire so I will cancel out some of these I know the solenoid works cuz everytime I pull trigger I hear the click I change the battery all program setting modes are set to default ....the o rings look fine unless there's something specific I'm supposed to look for ....I know this is kinda confusing so I'll answer any questions with as much detail as possible....if nothing works do you know wats the most expensive part I would have to pay for to fix.....basically worst case scenario....Anything will help....thanks
bond 559 is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 05-04-2016, 09:31 AM #2
Shocker_Monkey
KCCO
 
Shocker_Monkey's Avatar
 
Join Date: Mar 2003
Location: Wisconsin
Annual Supporting Member
Shocker_Monkey is a Supporting Member
 has been a member for 10 years
Shocker_Monkey is playing at Living Legends IX
Shocker_Monkey is Legendary
Shocker_Monkey is Boss
Shocker_Monkey supports Ninja Paintball
Does it fire with the eyes off? Hold the bottom button for second, the light should blink red I think.

This will tell you if the engine is functioning correctly.
__________________

==========================================
WISCONSIN NAVARONE
==========================================

Last edited by Shocker_Monkey : 05-04-2016 at 09:33 AM.
Shocker_Monkey is offline   Reply With Quote
Old 05-06-2016, 02:33 PM #3
Tabouare
 
 
Join Date: Oct 2015
Tabouare supports Ninja Paintball
did you mess with the velocity screw when you changed the seat? There could be no air thus no firing.

did you push with a tool on the regulator piston? Did you lube the piston / lube the entire regulator assembly? it could be stuck or there could be a debris in there.
Tabouare is offline   Reply With Quote
Old 05-06-2016, 02:39 PM #4
Tabouare
 
 
Join Date: Oct 2015
Tabouare supports Ninja Paintball
saw your other post, it could also be a lubing issue of the bolt
I had to relube the bolt every 1000-1500 shots on my 2012 reflex otherwise I would get the symptoms you had loss of velocity 2-3 balls coming out of the barrel. cold conditions makes it worst.

too much grease and after 1000x shots it doesn't shoot, not enough it doesn't work.
Correct amount and you're good to go for 1-2 cases

it's a trial error unfortunately that you need to figure out by playing but the symptoms are always the same
Tabouare is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump