Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 06-25-2015, 07:42 PM #1
RALSPORT
 
 
RALSPORT's Avatar
 
Join Date: Jan 2006
Location: St Louis
Annual Supporting Member
3.5 solenoid leak?

Hopefully someone can help. I just aired up my geo and it has a leak around the solenoid area.
I have tried using a different core from a friend. still leaks.
I put new gaskets on the solenoid, still leaks.
It will shoot just fine just a small leak that annoys me.
Any ideas?
RALSPORT is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 06-25-2015, 07:48 PM #2
187skiers
Constructive OCD
 
187skiers's Avatar
 
Join Date: Apr 2008
Location: San Francisco, CA
187skiers owns a Planet Eclipse Geo
Mine had this issue after my first time playing with it. Luckily a friend of mine hade a 3.5 and let me swap parts until I found the problem.

- in my case, after swapping the solenoid manifolds out I was able to stop the leak. I got on the phone with the shop I bought the gun from and they sent me a new manifold. Ever since then it's held air just fine.

Try swapping parts with your buddies 3.5 until you find the part that's causing a leak.
187skiers is offline   Reply With Quote
Old 06-26-2015, 05:27 AM #3
Jack Wood
 
 
Jack Wood's Avatar
 
Join Date: Jul 2001
Location: Planet Eclipse, England
Annual Supporting Member
Jack Wood is a founding member
 has been a member for 10 years
Jack Wood works for a Paintball manufacturer
Jack Wood owns a Planet Eclipse GSL
Also check and grease the secondary spool and secondary spool cap inside the manifold.

Jack
Jack Wood is offline   Reply With Quote
Old 06-27-2015, 12:11 AM #4
RALSPORT
 
 
RALSPORT's Avatar
 
Join Date: Jan 2006
Location: St Louis
Annual Supporting Member
I Will keep you posted of what I find out. Thanks
RALSPORT is offline   Reply With Quote
Old 06-28-2015, 11:21 PM #5
RALSPORT
 
 
RALSPORT's Avatar
 
Join Date: Jan 2006
Location: St Louis
Annual Supporting Member
Cleaned the spool and cap, lightly greased and rechecked. Still leaks.
I think the solenoid is the culprit.
RALSPORT is offline   Reply With Quote
Old 06-29-2015, 12:38 AM #6
187skiers
Constructive OCD
 
187skiers's Avatar
 
Join Date: Apr 2008
Location: San Francisco, CA
187skiers owns a Planet Eclipse Geo
9.99999 out 10 times its not the solenoid.

Did you try swapping new gaskets? Did you lightly grease them?
Did you ensure they were seated correctly?
Have you tried a new manifold?

The manifold is what I'm guessing it is. Because your problem sounds exactly like mine did. Probably just some poor tolerance with the plastic.
187skiers is offline   Reply With Quote
Old 06-29-2015, 09:22 PM #7
RALSPORT
 
 
RALSPORT's Avatar
 
Join Date: Jan 2006
Location: St Louis
Annual Supporting Member
I Just got a new manifold for it and gaskets(3), lightly greased.
Aired up, Leaking still.
I was hoping it would correct the leak.
187 Thanks for the helping. I guess the solenoid is my next step.
RALSPORT is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump