My 12v revs SUK! - PbNation
Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

 
Archived Thread - Cannot Edit  
Old 10-17-2001, 12:02 AM #1
Kevin O'Dell
Play nice or else.
 
Kevin O'Dell's Avatar
 
Join Date: Oct 2001
Location: Behind you, in the shado
 has been a member for 10 years
Angry My 12v revs SUK!

I have 2 12v revs and neither one will work. I put fresh batteries in them, turn them on and the red led comes on and the paddle turns very slowly, if at all. I sent them back under warranty last fall for the same problem, and now they are doing it again. I have been very carefull not to overload them. I also have several customers with the same problem. Anybody have any ideas? Should we just burn the B.E. crap and buy H.A.L.O.s?
Kevin O'Dell is offline  
Old Sponsored Links Remove Advertisement
Advertisement
Old 10-18-2001, 11:25 AM #2
HostileIntent
Run Thru Ninja
 
HostileIntent's Avatar
 
Join Date: Apr 2001
Location: MA
 has been a member for 10 years
HostileIntent owns a Planet Eclipse Geo
that that happens to mine. revy suck. i'm buying either a HALO or a Rico AK.
__________________
JG the 187 cheater beater run thru masta overshoot blasta!

*1ne

"you gotta get that money no matter how you do... secret inditement ****, right thur"
HostileIntent is offline  
Old 10-18-2001, 09:27 PM #3
Kevin O'Dell
Play nice or else.
 
Kevin O'Dell's Avatar
 
Join Date: Oct 2001
Location: Behind you, in the shado
 has been a member for 10 years
I'm not impressed with the ric's quality. It's pretty fragile for the price. I'm going to check with National tommorrow to see if they have received any H.A.L.O.s yet.
Kevin O'Dell is offline  
Old 10-22-2001, 11:19 PM #4
honeyside
 
 
honeyside's Avatar
 
Join Date: Oct 2001
Location: Richmond
 has been a member for 10 years
problem?

check and see if the screw on the hopper by the bottom by the battery, if that is too tight it will cause loose conection thinking the battery is weak.
__________________
Captain of Team RVA
couldn't shake a stick at us

DO YOU LIKE SHINEY THINGS?
honeyside is offline  
Old 11-03-2001, 08:43 PM #5
saso
 
 
saso's Avatar
 
Join Date: Sep 2001
 has been a member for 10 years
.

Go for the ric....halo is tooo bulky ric lets u see better..only fragile part is lid..yess i know mine ripped off but the staff is very nice and always supplies u with another on super fast
saso is offline  
Old 11-08-2001, 09:59 PM #6
Yama
 
 
Yama's Avatar
 
Join Date: Sep 2001
Location: Minnesota
Yama is a Supporting Member
 has been a member for 10 years
i dont really like the rics they are too loud. go to warpig.com and they have all the loaders that they tested.
Yama is offline  
Old 11-10-2001, 07:23 PM #7
Kevin O'Dell
Play nice or else.
 
Kevin O'Dell's Avatar
 
Join Date: Oct 2001
Location: Behind you, in the shado
 has been a member for 10 years
about warpig

Been there. I wasn't impressed by any of them I want to try a halo, if they ever get thier heads out of thier and get it on the market. I really don't want the added weight and bulk of a warp feed to keep up with my gun, but I might have to. The evolution kept up nicely when it didn't jam so I'm hoping the halo will work.
Kevin O'Dell is offline  
Old 11-14-2001, 04:42 PM #8
euphoria526
Music Man
 
euphoria526's Avatar
 
Join Date: Oct 2001
Location: Hollyhood
 has been a member for 10 years
hmmm didi you put the batteries in back wards..no j/k...(not calling you a dumba$$)
but things like that happen to the best of us and it is really embarassing, but it happens
__________________
You know your old skool when your marker isn't on pbreview.com

If you know what i'm saying when i say Chuff Chuff. awesome, if you dont, your just plain dumb.
euphoria526 is offline  
Old 11-14-2001, 06:33 PM #9
Phatty
 
 
Phatty's Avatar
 
Join Date: Apr 2001
Location: East Palestine, OH
 has been a member for 10 years
Maybe a new board could be the answer. I have an unused stock revy board. If your interested, let me know.
__________________
Play with the best, die like the rest!
Phatty is offline  
Old 11-15-2001, 06:26 PM #10
Kevin O'Dell
Play nice or else.
 
Kevin O'Dell's Avatar
 
Join Date: Oct 2001
Location: Behind you, in the shado
 has been a member for 10 years
NO I DIDN'T PUT THE BATTERIES IN BACKWARDS! Yes the board was the problem in one, so I installed a pre brass beagle board and it works fine. It is a black loader so I don't have to worry about sunlight activating it. The other one is a pre brass beagle blue loader with a second gen. board and motor. The motor tested out as having high resistance. High amp. draw with slow or no movement. And the board sucks too. Put the both of them together and it's guaranteed not to work. (It's brass beagle, what do you expect.)


I want a H.A.L.O.... NOW!!
Kevin O'Dell is offline  
 




Posting Rules
Forum Jump