Find fields & stores near you!
Find fields and stores
Zipcode
PbNation News
PbNation News
Community Focus
Community Focus

Reply
 
Thread Tools
Old 12-30-2007, 02:03 AM #1
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
Common Legend Problem Fixes

Heres some common problems with quick answers to each

This is a living document and will be updated commonly

and as you can see ... many of these problems can be fixed by getting the v2 parts ... or resetting your board settings to stock

I DO NOT TAKE ANY RESPONSIBILITY FOR DAMAGES ... THESE ARE COMMON FIXES AND YOU ARE PERFORMING THEM AT YOUR OWN RISK

#1 - My gun fires but the paintballs just fall out of the barrel

----- Check your rammer ... if you have a V1 rammer check for cracks in the metal rings -- the lightened rammer and pin are 20 dollars through infinitylegend.com

----- Reset your dwell settings to stock

----- Make sure your Reg is turn up appropriately ... and check airways for blockages

----- Change your battery!

----- Make sure you have not installed your bolt upside down ... the inlet hole faces downard

#2 - My bolt sticks forward or sputters when shot

----- This can be caused by your pressure being too high .. zero out your reg (on cp regs this is done by turning the set screw IN all the way) then turn it up to correct pressure

----- This is either a dirty solenoid - dirty QEV ... send to infinity - This is generally caused by over-lubeing the rammer .... remember if you ARE using grease for the rammer only use a SMALL amount ... Tri flo gun oil is recommended by infinity

#3 - My gun is skipping shots when i pull the trigger

----- Frank alerted me to another cause of shots being skipped ... if you have a reflashed board ... If your led flashes green you should have no problems, however, when the led turns to orange or red (meaning the battery is running low) ... it may read that there is no ball in the breech ... it may still fire SINGLE shots (not multiple)

----- Check the back of your board ... if it has V1 (written in marker) or nothing on the back send it to infinity for a free upgrade to a V2 board

#4 - My eye covers are stripped

----- You may use loctite to "glue" your allen key into the screw then when dry turn ... to remove allen key heat the loctite to release

----- If this fails use a dremel to cut a slot for a flat head screwdriver

#5 - When i shoot my legend the bolt pin pops up

----- Check your rammer (V1) for bent rings ... 20 dollars to infinity will get you a V2 rammer

----- Check to make sure your pin retaining screw (located in the back of the bolt) is tightened appropriately

#6 - My bolt pin will not fit into my rammer or my bolt seems to sit too far forward when in the rest position (This is directed at V2 rammers ... if you have a V1 rammer then your rings are bent and you need to purchase a V2 rammer)

----- Take out your rammer and try to put the pin into the rammer ... if this works you are just not putting the pin in the correct place

----- If your pin will not fit in the rammer while outside the gun you will need to file the pin ... take a common nail file and scrape one at a time untill the pin will fit snugly into the rammer

#7 - My legend is chopping

i can only touch on a few of the problems ... if none of these apply to you then feel free to post a thread asking for assistance

----- I cannot stress this enough ... if you have the soft face bolt you MUST be using the new smaller bumper o-ring on your ram ... otherwise ... YOU WILL CHOP ... if you need the o ring contact infinity and explain your situation and they will be more than happy to help out

----- Over tightening your barrel can cause the wall near the o ring in your breech to become smashed making nice little burrs that will cut up any paint you put through it

=====To check for this.
=====1. Remove all air from the gun
=====2. Take the barrel off the gun.
=====3. Look down the front of your gun.
=====4. Look for a grove on the o-ring wall from the barrel
=====5. Push a ball with your finger through the blow back O-ring. It should slide through very easily.

=====To Fix this.
=====You can send your gun in to Infinity and we will Hone the upper part of your body to make sure no burrs are present.
=====There will be no charge for this. We only ask you pay for the shipping.

(straight out of glens keyboard)

----- Check your detents ... there should be no damage or pieces of them missing

----- Turn your dwell up to 11 or 12 ... then adjust your inline reg pressure down to compensate

----- If you are shooting mis-shapen or different sized paint consider buying a soft face bolt

----- (For WAS board) Set your eye mode to ROF eye mode instead of unlimited ROF (ROF eye mode uses a simpler eye logic and this may solve your problem)

#8 - My gun is leaking down the barrel

----- Check your valve orings and cup seal ... if you do not feel comfortable doing this send it out to infinity ... there is a video in the stickies on how to correctly disassemble the legend ... i recommend watching it before attempting anything

#9 - When i pull the trigger my gun does not shoot

----- If your solenoid does not click then you have most likely ripped or pinched wires ... send to infinity ... one thing you can check yourself is if you are using standard 45* frame grips check your noid (the brassy colored box) to make sure you havent tightened your upper screws too tight .. this can crack bend or puncture the solenoid case and cause it to cease working

----- Again, if your solenoid is not clicking ... check your dwell ... if it is too low your solenoid will not even open and therefore will not click/let air through ... thanks pheonix!

----- If your solenoid does click you have an air problem ... be sure your air system is on and your reg is allowing air to pass through

#10 - My 45* grip screws wont go in correctly

----- Be aware that your top screws are actually shorter than the bottom ones and it does matter which way they go (top SHORT .... bottom LONG) [[EDIT: i accidently put the opposite in here ... THANK YOU FRANKDATANK for correcting me]] ... also be aware that you do not tighten the top screws too tightly (because they are what hold your solenoid in place)

#11 - I blew a hose and now the gun blows every hose i put in the gun

----- Legends do NOT use autococker hosing ... contact infinity for them to ship some hose out to you

#12 - My paintballs are swerving and i cannot get accurate shots

----- This is limited to one of four problems (this is assuming your not chopping ....)
1. Your paint is jacked up ...
2. Your bore does not match your paint (too big too small) or is dirty
3. Your FPS is too low or too high
4. Your detents may be damaged

#13 - I am double feeding / chopping

----- What hopper are you using? Halo B's have a problem of feeding too hard ... if you have an upgraded board in your loader ... attempt to lower the force settings ... Vlocities i have found to work best in combination with legends (this is merely a suggestion) however i know many others using other hoppers with great success

----- Check your detents ... black ones should work fine (if they arent damaged) however extra hard blues will most likely completely eliminate this problem

#14 - My bolt pin is REALLY hard to pull out / push in

----- Look in the groove of your rammer for any paint or debris

----- rotate your rammer 180 degrees then try putting your bolt pin in ... if this helps then your rammer is bent (primarily a V1 ram issue)

----- Adjust the retention set screw in the back of the bolt (non soft face only)

----- most likely you have metal burrs on your bolt pin ... grab a nail file and file down the flat edges of the pin little by little until it fits more easily

I will continue adding later ... i got stuff to do!
__________________

Infinity Legend Parts Swap

Last edited by asdffdsaasdf : 07-14-2009 at 12:30 AM.
asdffdsaasdf is offline   Reply With Quote
Old Sponsored Links Remove Advertisement
Advertisement
Old 12-30-2007, 07:09 PM #2
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
updated a bit ... and suggestions are appreciated
__________________

Infinity Legend Parts Swap
asdffdsaasdf is offline   Reply With Quote
Old 12-31-2007, 11:15 AM #3
NEhItMaN
GSp Renegades
 
NEhItMaN's Avatar
 
Join Date: Mar 2007
i have problem number 9 it shoots but i cant herew the niod
__________________
L3g1on-HoT FoR 09
Fueled by hate.
PhAmOuS-MeDiA*PhAmOuS-MeDiA*PhAmOuS-MeDiA*PhAmOuS-MeDiA*PhAmOuS-MeDiA*PhAmOuS-MeDiA
NEhItMaN is offline   Reply With Quote
Old 12-31-2007, 12:23 PM #4
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
what do you mean it shoots? ... if the rammer is traveling forward and hitting the popit then your solenoid is working

explain a little more and ill try and help you out
__________________

Infinity Legend Parts Swap
asdffdsaasdf is offline   Reply With Quote
Old 12-31-2007, 07:43 PM #5
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
updated ... any common problems you guys are seeing that im not thinking of at the moment?
__________________

Infinity Legend Parts Swap
asdffdsaasdf is offline   Reply With Quote
Old 12-31-2007, 07:59 PM #6
NorcalLegend
 
 
NorcalLegend's Avatar
 
Join Date: Jun 2007
Location: 925
NorcalLegend owns a Planet Eclipse Etek
sticky for sure....
__________________
www.USPN.biz
NorcalLegend is offline   Reply With Quote
Old 01-02-2008, 04:50 PM #7
NEhItMaN
GSp Renegades
 
NEhItMaN's Avatar
 
Join Date: Mar 2007
it shots but i cant here the noid is that normal
__________________
L3g1on-HoT FoR 09
Fueled by hate.
PhAmOuS-MeDiA*PhAmOuS-MeDiA*PhAmOuS-MeDiA*PhAmOuS-MeDiA*PhAmOuS-MeDiA*PhAmOuS-MeDiA
NEhItMaN is offline   Reply With Quote
Old 01-07-2008, 11:07 PM #8
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
updated ... i think it might be done .. i cant think of anything else
__________________

Infinity Legend Parts Swap
asdffdsaasdf is offline   Reply With Quote
Old 01-10-2008, 05:30 PM #9
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
Ha ... thanks Frank for proving above post wrong

any other ideas ... id like them
__________________

Infinity Legend Parts Swap
asdffdsaasdf is offline   Reply With Quote
Old 01-10-2008, 09:11 PM #10
phoenix03
People do things
 
phoenix03's Avatar
 
Join Date: Dec 2006
Location: 478
the solenoid not clicking can also because by a bad battery or the dwell being too low. The low dwell happened to me once.
__________________
Droid
phoenix03 is offline   Reply With Quote
Old 01-26-2008, 05:35 PM #11
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
updated again
__________________

Infinity Legend Parts Swap
asdffdsaasdf is offline   Reply With Quote
Old 02-01-2008, 12:50 PM #12
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
i asked to see if this should be stickied and i got no reply ... do you guys think it should be?

i mean its basically a troubleshooting thread
__________________

Infinity Legend Parts Swap
asdffdsaasdf is offline   Reply With Quote
Old 02-01-2008, 12:56 PM #13
ryan_wallace92 (Banned)
Niagara Destruction
 
ryan_wallace92's Avatar
 
Join Date: Jun 2007
Location: grimsby CANADA!!
i dont feel like making a whole thread on this, but i am having some Soft Face bolt problems...

i put the bolt into the spot where it is supposed to go, push down on the bolt pin so that it is in the ram, it IS in the ram

when i fire one shot, the bolt recycles back, but when i shoot it a second time, the bolt pin gets pushed up a tiny bit, and the bolt is not connected to the ram anymore

any thoughts on how this could be fixeD?
ryan_wallace92 is offline   Reply With Quote
Old 02-01-2008, 12:59 PM #14
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
first try rotating your ram in the housing 180 degrees and try this again ... if its still a problem then its fault is based somewhere in the pin ... do soft face bolts have a pin retaining screw like the stock ones? ... if so then i would reccomend tightening it

and go from there
__________________

Infinity Legend Parts Swap
asdffdsaasdf is offline   Reply With Quote
Old 02-01-2008, 01:00 PM #15
ryan_wallace92 (Banned)
Niagara Destruction
 
ryan_wallace92's Avatar
 
Join Date: Jun 2007
Location: grimsby CANADA!!
you mean a screw at the back of the bolt? no they do not
ryan_wallace92 is offline   Reply With Quote
Old 02-01-2008, 01:01 PM #16
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
is the screw located on the side or inside the front of the bolt then?
__________________

Infinity Legend Parts Swap
asdffdsaasdf is offline   Reply With Quote
Old 02-01-2008, 01:06 PM #17
ryan_wallace92 (Banned)
Niagara Destruction
 
ryan_wallace92's Avatar
 
Join Date: Jun 2007
Location: grimsby CANADA!!
there are two holes on either side of the bolt, but they do not look like an allen key screw or anything like that, and there is no screw in the front of th ebolt
ryan_wallace92 is offline   Reply With Quote
Old 02-01-2008, 01:08 PM #18
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
well then try the rotating 180 degrees thing

if that works then your rammer is at fault

if it dosent then its your bolt pin

talk to infinity and see what they say


also take your rammer out and mae sure its fitting in there right
__________________

Infinity Legend Parts Swap
asdffdsaasdf is offline   Reply With Quote
Old 02-01-2008, 01:13 PM #19
ryan_wallace92 (Banned)
Niagara Destruction
 
ryan_wallace92's Avatar
 
Join Date: Jun 2007
Location: grimsby CANADA!!
ok i will try that out, i will let you know what happends, i emailed infinity and ill see what their response is also

you can add it to your list when its all said and done
ryan_wallace92 is offline   Reply With Quote
Old 02-01-2008, 01:27 PM #20
asdffdsaasdf
Smasher of Keyboards
 
asdffdsaasdf's Avatar
 
Join Date: Sep 2006
Location: St. Louis - IL Side
its already in there! ... sort of

DO YOU GUYS THINK THIS SHOULD BE STICKIED
__________________

Infinity Legend Parts Swap
asdffdsaasdf is offline   Reply With Quote
Old 02-01-2008, 01:50 PM #21
ryan_wallace92 (Banned)
Niagara Destruction
 
ryan_wallace92's Avatar
 
Join Date: Jun 2007
Location: grimsby CANADA!!
deff
ryan_wallace92 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
Forum Jump